aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/ti/matrix-gui/0001-Disable-cursor-override-for-X11.patch27
-rw-r--r--recipes/ti/matrix-gui/dm365-evm/init26
-rw-r--r--recipes/ti/matrix-gui/init24
-rw-r--r--recipes/ti/matrix-gui/matrix-gui.desktop7
-rw-r--r--recipes/ti/matrix-gui_svn.bb30
5 files changed, 19 insertions, 95 deletions
diff --git a/recipes/ti/matrix-gui/0001-Disable-cursor-override-for-X11.patch b/recipes/ti/matrix-gui/0001-Disable-cursor-override-for-X11.patch
deleted file mode 100644
index 61eba44eea..0000000000
--- a/recipes/ti/matrix-gui/0001-Disable-cursor-override-for-X11.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From b0e91f703ffdcc73f854a672ec16ebbf21293c9c Mon Sep 17 00:00:00 2001
-From: Chase Maupin <chase.maupin@ti.com>
-Date: Mon, 24 May 2010 12:51:49 -0500
-Subject: [PATCH] Disable cursor override for X11
-
-* Disable the cursor override option for using the matrix_gui
- program with X11.
----
- main.cpp | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/main.cpp b/main.cpp
-index 978e327..1f55e94 100644
---- a/main.cpp
-+++ b/main.cpp
-@@ -43,7 +43,7 @@ int main(int argc, char * argv[])
- {
- QApplication matrix(argc, argv);
- QApplication::setStyle(new CustomStyle);
-- QApplication::setOverrideCursor(QCursor(Qt::BlankCursor));
-+// QApplication::setOverrideCursor(QCursor(Qt::BlankCursor));
-
- // Create a new window to display a web page.
- MainWindow * pWindow = new MainWindow(0, QString(argv[1]), true);
---
-1.6.0.4
-
diff --git a/recipes/ti/matrix-gui/dm365-evm/init b/recipes/ti/matrix-gui/dm365-evm/init
deleted file mode 100644
index 3aadc1e6d9..0000000000
--- a/recipes/ti/matrix-gui/dm365-evm/init
+++ /dev/null
@@ -1,26 +0,0 @@
-#! /bin/sh
-matrixgui="/usr/bin/matrix_gui"
-GUI_OPTS="-geometry 720x480+0+10 -display transformed:Rot0 /usr/share/matrix/html/menu_main.html"
-
-test -x "$matrixgui" || exit 0
-
-case "$1" in
- start)
- # switch to component 480p mode
- echo 480P-60 > /sys/class/davinci_display/ch0/mode
- echo COMPONENT > /sys/class/davinci_display/ch0/output
- echo -n "Starting Matrix GUI application"
- start-stop-daemon --start --quiet --background --pidfile /var/run/matrix-gui.pid --exec $matrixgui -- $GUI_OPTS
- echo "."
- ;;
- stop)
- echo -n "Stopping Matrix GUI application"
- start-stop-daemon --stop --quiet --pidfile /var/run/matrix-gui.pid
- echo "."
- ;;
- *)
- echo "Usage: /etc/init.d/matrix-gui {start|stop}"
- exit 1
-esac
-
-exit 0
diff --git a/recipes/ti/matrix-gui/init b/recipes/ti/matrix-gui/init
deleted file mode 100644
index 40b651260c..0000000000
--- a/recipes/ti/matrix-gui/init
+++ /dev/null
@@ -1,24 +0,0 @@
-#! /bin/sh
-
-matrixgui="/usr/bin/matrix_gui"
-GUI_OPTS="/usr/share/matrix/html/menu_main.html"
-
-test -x "$matrixgui" || exit 0
-
-case "$1" in
- start)
- echo -n "Starting Matrix GUI application"
- start-stop-daemon --start --quiet --background --pidfile /var/run/matrix-gui.pid --exec $matrixgui -- $GUI_OPTS
- echo "."
- ;;
- stop)
- echo -n "Stopping Matrix GUI application"
- start-stop-daemon --stop --quiet --pidfile /var/run/matrix-gui.pid
- echo "."
- ;;
- *)
- echo "Usage: /etc/init.d/matrix-gui {start|stop}"
- exit 1
-esac
-
-exit 0
diff --git a/recipes/ti/matrix-gui/matrix-gui.desktop b/recipes/ti/matrix-gui/matrix-gui.desktop
deleted file mode 100644
index 52b5831fc0..0000000000
--- a/recipes/ti/matrix-gui/matrix-gui.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=Matrix GUI
-Comment=Start the Matrix GUI application
-Exec=/usr/bin/matrix_gui /usr/share/matrix/html/menu_main.html
-Terminal=false
-Type=Application
-X-GNOME-Autostart-enabled=true
diff --git a/recipes/ti/matrix-gui_svn.bb b/recipes/ti/matrix-gui_svn.bb
index 4bfe7c2654..f52294dbe4 100644
--- a/recipes/ti/matrix-gui_svn.bb
+++ b/recipes/ti/matrix-gui_svn.bb
@@ -4,27 +4,35 @@ LICENSE = "BSD"
SECTION = "multimedia"
PRIORITY = "optional"
-SRCREV = "58"
-PV = "1.0"
-PR = "r14+svnr${SRCPV}"
+SRCREV = "136"
+PV = "1.1"
+PR = "r16+svnr${SRCPV}"
-SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' \
- file://0001-Disable-cursor-override-for-X11.patch \
- file://init \
- file://matrix-gui.desktop \
-"
+PLATFORM_dm365 = "dm365"
+PLATFORM_da850-omapl138-evm = "omapl138"
+PLATFORM_omap3evm = "omap3530"
+PLATFORM_dm37x-evm = "dm3730"
+PLATFORM_am37x-evm = "am3715"
+PLATFORM_beagleboard = "am3715"
+PLATFORM ?= "<UNDEFINED>"
+
+SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
S = "${WORKDIR}/trunk"
+CXXFLAGS_da850-omapl138-evm_append = " -DPlatform_omapl138 "
+CXXFLAGS_dm365_append = " -DPlatform_dm365 "
+PACKAGE_ARCH = ${MACHINE_ARCH}
+
inherit qt4x11
do_install() {
install -d ${D}/${bindir}
install -m 0755 ${S}/matrix_gui ${D}/${bindir}
install -d ${D}${sysconfdir}/init.d/
- install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-gui
- install -d ${D}/${sysconfdir}/xdg/autostart
- install -m 0755 ${WORKDIR}/matrix-gui.desktop ${D}/${sysconfdir}/xdg/autostart
+ install -c -m 0755 ${S}/${PLATFORM}/etc/x11/init ${D}${sysconfdir}/init.d/matrix-gui
+ install -d ${D}/${sysconfdir}/xdg/autostart
+ install -m 0755 ${S}/${PLATFORM}/etc/x11/matrix-gui.desktop ${D}/${sysconfdir}/xdg/autostart
}
FILES_${PN}-autostart = "${sysconfdir}/xdg/autostart/matrix-gui.desktop"