aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini12
-rw-r--r--recipes/php/php-5.3.0/acinclude-xml2-config.patch18
-rw-r--r--recipes/php/php-5.3.0/pear-makefile.patch11
-rw-r--r--recipes/php/php-native_5.3.0.bb3
4 files changed, 40 insertions, 4 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index abbaa2de7e..61e3a6c87d 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1,7 +1,3 @@
-[http://www.live555.com/liveMedia/public/live.2009.06.02.tar.gz]
-md5=088f848b64cef1d54034bc24cfa3c156
-sha256=66c54241bfcc7ea42fe40e1c93739be79a3c065390c4163c0f2647ac45c24758
-
[http://www.directfb.org/downloads/Extras/++DFB-0.9.25.tar.gz]
md5=c6a2705f6210d8ede50a947b375f1c0b
sha256=b3dbf01563dd60d63cff543ea8cd0c885381e78ecbbab8ff176e46df3f198a88
@@ -15610,6 +15606,10 @@ sha256=ee3edf1ea89a90f2b7f82ad09b83c25dc8ea8ca7cf0fce2aa921f897929b2bb9
md5=6f15406664ef31172c68d46567569bb8
sha256=9532b981c9b8974ceedd3d25a8f9a0e167a92c9da0dece47f34a4ec34e34b1cf
+[http://www.live555.com/liveMedia/public/live.2009.06.02.tar.gz]
+md5=088f848b64cef1d54034bc24cfa3c156
+sha256=66c54241bfcc7ea42fe40e1c93739be79a3c065390c4163c0f2647ac45c24758
+
[http://llvm.org/releases/1.9/llvm-1.9.tar.gz]
md5=866ba97420f5ce978b6a6b1cb4338890
sha256=17b82323151925ff5a7ad09a21781a0fa50ead4b87a339cee262271e4ededa13
@@ -19194,6 +19194,10 @@ sha256=5cac1e70df5019ebdfdab2e0b8b216f7fdf56b9895c9f68c993313918249bba3
md5=7380ffecebd95c6edb317ef861229ebd
sha256=1892b2dd50b56ae2c9aec027fcd9035b76673f113555bc2bc1007bab8ae4db81
+[http://us2.php.net/distributions/php-5.3.0.tar.bz2]
+md5=846760cd655c98dfd86d6d97c3d964b0
+sha256=83c9d86f830f8b188c70d3554d07b7416af90fd9e06d84340ffda58c09e58357
+
[http://efault.net/npat/hacks/picocom/dist/picocom-1.3.tar.gz]
md5=21865bf2891222082afc44afdd80aeaa
sha256=ed3e0190a1940cf08a167429aa3fd25b3ae7313fdf126f851a9abccc89845ee6
diff --git a/recipes/php/php-5.3.0/acinclude-xml2-config.patch b/recipes/php/php-5.3.0/acinclude-xml2-config.patch
new file mode 100644
index 0000000000..bf519d2934
--- /dev/null
+++ b/recipes/php/php-5.3.0/acinclude-xml2-config.patch
@@ -0,0 +1,18 @@
+--- /orig-acinclude.m4 2007-02-20 15:03:25.000000000 +0200
++++ /acinclude.m4 2007-02-20 15:03:24.000000000 +0200
+@@ -2359,12 +2359,9 @@
+ AC_DEFUN([PHP_SETUP_LIBXML], [
+ AC_CACHE_CHECK([for xml2-config path], ac_cv_php_xml2_config_path,
+ [
+- for i in $PHP_LIBXML_DIR /usr/local /usr; do
+- if test -x "$i/bin/xml2-config"; then
+- ac_cv_php_xml2_config_path="$i/bin/xml2-config"
+- break
+- fi
+- done
++
++ ac_cv_php_xml2_config_path="$PHP_LIBXML_DIR/xml2-config"
++
+ ])
+
+ if test -x "$ac_cv_php_xml2_config_path"; then
diff --git a/recipes/php/php-5.3.0/pear-makefile.patch b/recipes/php/php-5.3.0/pear-makefile.patch
new file mode 100644
index 0000000000..26de98a48f
--- /dev/null
+++ b/recipes/php/php-5.3.0/pear-makefile.patch
@@ -0,0 +1,11 @@
+--- /pear/orig-Makefile.frag 2007-03-16 12:18:33.000000000 +0200
++++ /pear/Makefile.frag 2007-03-16 12:35:48.000000000 +0200
+@@ -6,7 +6,7 @@
+ PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=E_ALL -dmemory_limit=-1 -ddetect_unicode=0
+
+ install-pear-installer: $(SAPI_CLI_PATH)
+- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
++ @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
+
+ install-pear:
+ @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
diff --git a/recipes/php/php-native_5.3.0.bb b/recipes/php/php-native_5.3.0.bb
new file mode 100644
index 0000000000..ac1c51fa3f
--- /dev/null
+++ b/recipes/php/php-native_5.3.0.bb
@@ -0,0 +1,3 @@
+require php-native.inc
+
+PR = "r3"