aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/gpe-clock/files/fix-install.patch13
-rw-r--r--recipes/gpe-clock/gpe-clock.inc2
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes/gpe-clock/files/fix-install.patch b/recipes/gpe-clock/files/fix-install.patch
new file mode 100644
index 0000000000..2d3e3032d0
--- /dev/null
+++ b/recipes/gpe-clock/files/fix-install.patch
@@ -0,0 +1,13 @@
+diff --git gpe-clock-0.25/Makefile-orig gpe-clock-0.25/Makefile
+index 4fa59bf..e716fcb 100644
+--- gpe-clock-0.25/Makefile-orig
++++ gpe-clock-0.25/Makefile
+@@ -36,7 +36,7 @@ $(PACKAGE): $(OBJS)
+
+ install-program: all
+ install -d $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ install -d $(DESTDIR)$(PREFIX)/share/pixmaps
+ install -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/
+ install -d $(DESTDIR)$(PREFIX)/share/applications
diff --git a/recipes/gpe-clock/gpe-clock.inc b/recipes/gpe-clock/gpe-clock.inc
index d4ae3da39c..b36fa7dafa 100644
--- a/recipes/gpe-clock/gpe-clock.inc
+++ b/recipes/gpe-clock/gpe-clock.inc
@@ -6,3 +6,5 @@ DEPENDS = "gtk+ libschedule libgpewidget gpe-announce atd libgpelaunch"
RDEPENDS = "gpe-announce"
inherit gpe
+
+SRC_URI += "file://fix-install.patch;patch=1"