aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/autotools.bbclass6
-rw-r--r--classes/base.bbclass4
-rw-r--r--classes/siteinfo.bbclass10
-rw-r--r--recipes/arm-kernel-shim/arm-kernel-shim_1.5.bb2
-rw-r--r--recipes/espeak/espeak_1.37.bb1
-rw-r--r--recipes/gnash/gnash.inc2
-rw-r--r--recipes/hping/hping2_1.9.9+2.0.0rc3.bb2
-rw-r--r--recipes/linux/ixp4xx-kernel.inc2
-rw-r--r--recipes/linux/linux.inc2
-rw-r--r--recipes/net-snmp/net-snmp.inc2
-rw-r--r--recipes/ogre/ogre-egl_svn.bb2
-rw-r--r--recipes/openssl/openssl.inc2
-rw-r--r--recipes/perl/perl_5.8.8.bb2
13 files changed, 20 insertions, 19 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index c53583b8b6..31d357892a 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -28,6 +28,12 @@ DEPENDS_prepend = "${@autotools_dep_prepend(d)}"
DEPENDS_virtclass-native_prepend = "${@autotools_dep_prepend(d)}"
DEPENDS_virtclass-nativesdk_prepend = "${@autotools_dep_prepend(d)}"
+inherit siteinfo
+
+# Space separated list of shell scripts with variables defined to supply test
+# results for autoconf tests we cannot run at build time.
+export CONFIG_SITE = "${@siteinfo_get_files(d)}"
+
acpaths = "default"
EXTRA_AUTORECONF = "--exclude=autopoint"
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 09eb70989a..76f97d865f 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -1355,10 +1355,6 @@ def check_app_exists(app, d):
# Patch handling
inherit patch
-# Configuration data from site files
-# Move to autotools.bbclass?
-inherit siteinfo
-
EXPORT_FUNCTIONS do_setscene do_clean do_mrproper do_distclean do_fetch do_unpack do_configure do_compile do_install do_package do_populate_pkgs do_rebuild do_fetchall
MIRRORS[func] = "0"
diff --git a/classes/siteinfo.bbclass b/classes/siteinfo.bbclass
index 93cee4f890..d7f27054b0 100644
--- a/classes/siteinfo.bbclass
+++ b/classes/siteinfo.bbclass
@@ -112,14 +112,6 @@ def siteinfo_get_files(d):
bb.debug(1, "SITE files " + sitefiles);
return sitefiles
-#
-# Export CONFIG_SITE to the enviroment. The autotools will make use
-# of this to determine where to load in variables from. This is a
-# space seperate list of shell scripts processed in the order listed.
-#
-export CONFIG_SITE = "${@siteinfo_get_files(d)}"
-
-
def siteinfo_get_endianess(d):
info = get_siteinfo_list(d)
if 'endian-little' in info:
@@ -141,5 +133,3 @@ def siteinfo_get_bits(d):
#
SITEINFO_ENDIANESS = "${@siteinfo_get_endianess(d)}"
SITEINFO_BITS = "${@siteinfo_get_bits(d)}"
-
-
diff --git a/recipes/arm-kernel-shim/arm-kernel-shim_1.5.bb b/recipes/arm-kernel-shim/arm-kernel-shim_1.5.bb
index 5e2bbb83cc..591a32f6f9 100644
--- a/recipes/arm-kernel-shim/arm-kernel-shim_1.5.bb
+++ b/recipes/arm-kernel-shim/arm-kernel-shim_1.5.bb
@@ -15,6 +15,8 @@ SRC_URI = "ftp://ftp.buici.com/pub/arm/arm-kernel-shim/arm-kernel-shim-${PV}.tar
S = ${WORKDIR}/arm-kernel-shim-${PV}
+inherit siteinfo
+
CMDLINE_CONSOLE = "console=${@bb.data.getVar("KERNEL_CONSOLE",d,1) or "ttyS0"}"
CMDLINE_ROOT_DSMG600 = "root=/dev/mtdblock2 rootfstype=jffs2 rootflags=noatime rw init=/linuxrc"
diff --git a/recipes/espeak/espeak_1.37.bb b/recipes/espeak/espeak_1.37.bb
index 2a5baf2420..f465f6f270 100644
--- a/recipes/espeak/espeak_1.37.bb
+++ b/recipes/espeak/espeak_1.37.bb
@@ -1,4 +1,5 @@
require espeak.inc
+inherit siteinfo
EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANESS", "be", "espeak-data (= ${PV})", "", d)}'
RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}"
diff --git a/recipes/gnash/gnash.inc b/recipes/gnash/gnash.inc
index bad1ae60ba..159fb414df 100644
--- a/recipes/gnash/gnash.inc
+++ b/recipes/gnash/gnash.inc
@@ -9,7 +9,7 @@ PR = "r6"
SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2 \
"
-inherit autotools pkgconfig
+inherit autotools pkgconfig siteinfo
EXTRA_OECONF = "--enable-gui=gtk \
--enable-renderer=cairo \
diff --git a/recipes/hping/hping2_1.9.9+2.0.0rc3.bb b/recipes/hping/hping2_1.9.9+2.0.0rc3.bb
index 471be84d29..f8f4bb7281 100644
--- a/recipes/hping/hping2_1.9.9+2.0.0rc3.bb
+++ b/recipes/hping/hping2_1.9.9+2.0.0rc3.bb
@@ -14,6 +14,8 @@ SRC_URI = "http://www.hping.org/hping2.0.0-rc3.tar.gz \
file://hping2_configure.patch;patch=1"
S = "${WORKDIR}/hping2-rc3"
+inherit siteinfo
+
#
# We've patched configure to accept byte order and ostype as env
# variables Pass those values in to stop it trying to figure it out
diff --git a/recipes/linux/ixp4xx-kernel.inc b/recipes/linux/ixp4xx-kernel.inc
index 10779c52c7..6422177f34 100644
--- a/recipes/linux/ixp4xx-kernel.inc
+++ b/recipes/linux/ixp4xx-kernel.inc
@@ -153,7 +153,7 @@ SRC_URI += "${IXP4XX_PATCHES}"
COMPATIBLE_HOST = 'arm.*-linux.*'
COMPATIBLE_MACHINE = '(ixp4xx|nslu2|fsg3)'
-inherit kernel
+inherit kernel siteinfo
ARCH = "arm"
diff --git a/recipes/linux/linux.inc b/recipes/linux/linux.inc
index 2da1df82c8..39d04e19ae 100644
--- a/recipes/linux/linux.inc
+++ b/recipes/linux/linux.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux Kernel"
SECTION = "kernel"
LICENSE = "GPLv2"
-inherit kernel
+inherit kernel siteinfo
RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
diff --git a/recipes/net-snmp/net-snmp.inc b/recipes/net-snmp/net-snmp.inc
index 7ba48c6dec..a96ae70f39 100644
--- a/recipes/net-snmp/net-snmp.inc
+++ b/recipes/net-snmp/net-snmp.inc
@@ -8,7 +8,7 @@ RDEPENDS_${PN}-dev = "net-snmp-client (= ${EXTENDPV}) net-snmp-server (= ${EXTEN
RRECOMMENDS_${PN}-dbg = "net-snmp-client (= ${EXTENDPV}) net-snmp-server (= ${EXTENDPV})"
INC_PR = "r5"
-inherit autotools update-rc.d
+inherit autotools update-rc.d siteinfo
TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/recipes/ogre/ogre-egl_svn.bb b/recipes/ogre/ogre-egl_svn.bb
index 82c7862013..abebf9d159 100644
--- a/recipes/ogre/ogre-egl_svn.bb
+++ b/recipes/ogre/ogre-egl_svn.bb
@@ -11,7 +11,7 @@ SRC_URI = "svn://ogre.svn.sourceforge.net/svnroot/ogre;module=trunk;proto=https
file://ogre-egl-update.diff;patch=1;pnum=0 \
"
-inherit autotools_stage
+inherit autotools_stage siteinfo
# This is the EGL version
EXTRA_OECONF = " --with-gui=gtk --disable-freetypetest --enable-ogre-demos --with-allocator=std --enable-threading=no --disable-cg --enable-gles "
diff --git a/recipes/openssl/openssl.inc b/recipes/openssl/openssl.inc
index a06033b0ec..28e0c921a8 100644
--- a/recipes/openssl/openssl.inc
+++ b/recipes/openssl/openssl.inc
@@ -6,6 +6,8 @@ SECTION = "libs/network"
SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz;name=src"
S = "${WORKDIR}/openssl-${PV}"
+inherit siteinfo
+
INC_PR = "r11"
AR_append = " r"
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index f084630cf9..2019ea6e03 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -41,6 +41,8 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/5.0/perl-5.8.8.tar.gz;name=perl588ta
file://config.sh-64-le \
file://config.sh-64-be"
+inherit siteinfo
+
# Where to find the native perl
HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl${PV}"