aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/webkit/arora_0.10.1.bb45
2 files changed, 49 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 1dc8fae380..b7257f2164 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1966,6 +1966,10 @@ sha256=68da29f515a26ca1b5722c940615ddc4b0550b2b1ad5d11129b1da636c353160
md5=88fa901c9a85633ab62365b0ee9df3b1
sha256=6651eb15c9f6dabf21af4067b723cb29a87827f66570bfab74fdc00d80cab129
+[http://arora.googlecode.com/files/arora-0.10.1.tar.gz]
+md5=ac38282a2d9134687d9c30dbb73c0fbc
+sha256=1828cbd348d1418287b29337e1047cfc3d6c092e18691cd9c6dfc2d6535bcebd
+
[ftp://ftp.ee.lbl.gov/arpwatch-2.1a15.tar.gz]
md5=cebfeb99c4a7c2a6cee2564770415fe7
sha256=c1df9737e208a96a61fa92ddad83f4b4d9be66f8992f3c917e9edf4b05ff5898
diff --git a/recipes/webkit/arora_0.10.1.bb b/recipes/webkit/arora_0.10.1.bb
new file mode 100644
index 0000000000..11da72e5ff
--- /dev/null
+++ b/recipes/webkit/arora_0.10.1.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "Arora is a lightweight cross-platform web browser"
+LICENE = "GPLv2"
+HOMEPAGE = "http://code.google.com/p/arora/"
+
+inherit qt4x11
+
+PR = "r1"
+
+SRC_URI = "http://arora.googlecode.com/files/arora-${PV}.tar.gz"
+
+do_configure_prepend() {
+ sed -i -e s:lrelease-qt4:${OE_QMAKE_LRELEASE}:g ${S}/src/locale/locale.pri
+}
+
+# Huge hack ahead:
+# Something is putting '.libs' in the Makefiles, which we do now want. The problem is that qmake generates makefiles during 'make all' *sigh*
+do_compile_prepend() {
+ ( oe_runmake src/Makefile tools/Makefile
+ cd ${S}/tools ; oe_runmake cacheinfo/Makefile htmlToXBel/Makefile placesimport/Makefile
+ )
+
+ for i in $(find ${S} -name 'Makefile') ; do
+ sed -i -e 's:/.libs::g' $i
+ make || true
+ done
+
+}
+
+do_install() {
+ sed -i -e s:/usr/local:${D}${prefix}:g install.pri
+ sed -i -e s:$(INSTALL_ROOT)/OE/angstrom-dev/work/armv7a-angstrom-linux-gnueabi/arora-0.10.1-r0/image/:$(INSTALL_ROOT)/:g src/Makefile
+
+ for i in $(find ${S} -name 'Makefile') ; do
+ sed -i -e s:/usr/local:${prefix}:g $i
+ done
+
+ oe_runmake -e INSTALL_ROOT=${D} install
+ cp -r ${D}/${D}/* ${D}/ || true
+ cp -r ${D}/usr/local/* ${D}${prefix} || true
+ rm -rf ${D}/usr/local ${D}/${D}
+}
+
+FILES_${PN} += "${datadir}/gnome-control-center ${datadir}/icons"
+
+