aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/pmacct/pmacct.inc34
-rw-r--r--recipes/pmacct/pmacct_0.12.1.bb6
-rw-r--r--recipes/pmacct/pmacct_0.7.9.bb30
3 files changed, 42 insertions, 28 deletions
diff --git a/recipes/pmacct/pmacct.inc b/recipes/pmacct/pmacct.inc
new file mode 100644
index 0000000000..39392d4d07
--- /dev/null
+++ b/recipes/pmacct/pmacct.inc
@@ -0,0 +1,34 @@
+DESCRIPTION = "Promiscuous mode IP Accounting package"
+HOMEPAGE = "http://www.pmacct.net"
+LICENSE = "GPLv2"
+DEPENDS = "libpcap"
+
+INC_PR = "r2"
+
+SRC_URI = "http://www.pmacct.net/pmacct-${PV}.tar.gz \
+ file://pmacct.init \
+ "
+
+SRC_URI_append_nylon = "file://pmacct.conf.eth0"
+
+inherit autotools
+
+# Without this it'll check for the headers in /usr/include
+EXTRA_OECONF = "--with-pcap-includes=${STAGING_INCDIR}"
+
+do_configure () {
+ oe_runconf
+}
+
+do_install() {
+ autotools_do_install
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/pmacct
+ install -m 755 ${WORKDIR}/pmacct.init ${D}${sysconfdir}/init.d/pmacct
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/pmacct/pmacct.conf.eth0"
+
+do_install_append_nylon() {
+ install -m 644 ${WORKDIR}/pmacct.conf.eth0 ${D}${sysconfdir}/pmacct
+}
diff --git a/recipes/pmacct/pmacct_0.12.1.bb b/recipes/pmacct/pmacct_0.12.1.bb
new file mode 100644
index 0000000000..112810b562
--- /dev/null
+++ b/recipes/pmacct/pmacct_0.12.1.bb
@@ -0,0 +1,6 @@
+PR = "${INC_PR}.0"
+include pmacct.inc
+
+SRC_URI[md5sum] = "82f11cac3fb14fc7f4754918272f685f"
+SRC_URI[sha256sum] = "e562a416b2483e4611764e9633e8b8b50b5ce008322f27994e6af6479a39f65a"
+
diff --git a/recipes/pmacct/pmacct_0.7.9.bb b/recipes/pmacct/pmacct_0.7.9.bb
index 493f082b90..684f445eed 100644
--- a/recipes/pmacct/pmacct_0.7.9.bb
+++ b/recipes/pmacct/pmacct_0.7.9.bb
@@ -1,31 +1,5 @@
-DESCRIPTION = "Promiscuous mode IP Accounting package"
-HOMEPAGE = "http://www.ba.cnr.it/~paolo/pmacct/"
-LICENSE = "GPLv2"
-DEPENDS = "libpcap"
-PR = "r2"
-
-SRC_URI = "http://www.ba.cnr.it/~paolo/pmacct/pmacct-${PV}.tar.gz \
- file://pmacct.init \
- file://pmacct.conf.eth0"
-
-inherit autotools
-
-# Without this it'll check for the headers in /usr/include
-EXTRA_OECONF = "--with-pcap-includes=${STAGING_INCDIR}"
-
-do_configure () {
- oe_runconf
-}
-
-do_install() {
- autotools_do_install
- install -d ${D}${sysconfdir}/init.d/
- install -d ${D}${sysconfdir}/pmacct
- install -m 755 ${WORKDIR}/pmacct.init ${D}${sysconfdir}/init.d/pmacct
- install -m 644 ${WORKDIR}/pmacct.conf.eth0 ${D}${sysconfdir}/pmacct
-}
-
-CONFFILES_${PN}_nylon = "${sysconfdir}/pmacct/pmacct.conf.eth0"
+PR = "${INC_PR}.0"
+require pmacct.inc
SRC_URI[md5sum] = "4964e093254d04873d34f282a7110413"
SRC_URI[sha256sum] = "63ed71d9b9c0f0e1283a5345f27e7e95f71a2cda8bab4150e2a4937cd8834b5d"