aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/images/shr-image.bb14
-rw-r--r--recipes/images/shr-image.inc17
-rw-r--r--recipes/tasks/task-shr-minimal.bb8
3 files changed, 12 insertions, 27 deletions
diff --git a/recipes/images/shr-image.bb b/recipes/images/shr-image.bb
index 23f4f64e4c..3d72ca0b53 100644
--- a/recipes/images/shr-image.bb
+++ b/recipes/images/shr-image.bb
@@ -16,17 +16,3 @@ IMAGE_INSTALL += "\
task-shr-gtk \
task-shr-cli \
"
-
-# perform some SHR convenience tweaks to the rootfs
-shr_rootfs_postprocess_append() {
- curdir=$PWD
- cd ${IMAGE_ROOTFS}
-
-
- #Replace desktop files
- echo "Icon=pidgin.png" >> ./usr/share/applications/pidgin.desktop
- sed -i "s/^X-Icon-path.*$//g" ./usr/share/applications/vagalume.desktop
-
- cd $curdir
-}
-
diff --git a/recipes/images/shr-image.inc b/recipes/images/shr-image.inc
index f06d86b429..9408091c8d 100644
--- a/recipes/images/shr-image.inc
+++ b/recipes/images/shr-image.inc
@@ -3,14 +3,12 @@
#------------------------------------------------------
PV = "2.0"
-PR = "r11"
+PR = "r12"
DEPENDS += "task-shr-minimal"
RDEPENDS += "\
- ${MACHINE_TASK_PROVIDER} \
- task-base \
task-shr-minimal-base \
task-shr-minimal-cli \
task-shr-minimal-fso \
@@ -18,23 +16,15 @@ RDEPENDS += "\
task-shr-minimal-audio \
task-shr-minimal-gtk \
task-shr-minimal-x \
- task-x11-illume \
- task-fso2-compliance \
- task-fonts-truetype-core \
"
IMAGE_INSTALL += "\
- ${MACHINE_TASK_PROVIDER} \
- task-base \
task-shr-minimal-base \
task-shr-minimal-cli \
task-shr-minimal-apps \
task-shr-minimal-audio \
task-shr-minimal-gtk \
task-shr-minimal-x \
- task-x11-illume \
- task-fso2-compliance \
- task-fonts-truetype-core \
"
inherit image
@@ -140,6 +130,11 @@ shr_rootfs_gta01_postprocess() {
cd $curdir
}
+# We don't want /boot directory in jffs2/ubi/ubifs images
+IMAGE_CMD_jffs2 = "mv ${IMAGE_ROOTFS}/boot ${IMAGE_ROOTFS}-boot && mkfs.jffs2 -x lzo --root=${IMAGE_ROOTFS} --faketime --output=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 ${EXTRA_IMAGECMD} && mv ${IMAGE_ROOTFS}-boot ${IMAGE_ROOTFS}/boot"
+IMAGE_CMD_ubi = "mv ${IMAGE_ROOTFS}/boot ${IMAGE_ROOTFS}-boot && echo \[ubifs\] > ubinize.cfg ; echo mode=ubi >> ubinize.cfg ; echo image=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubifs >> ubinize.cfg ; echo vol_id=0 >> ubinize.cfg ; echo vol_type=dynamic >> ubinize.cfg ; echo vol_name=${UBI_VOLNAME} >> ubinize.cfg ; echo vol_flags=autoresize >> ubinize.cfg;mkfs.ubifs -r ${IMAGE_ROOTFS} -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubifs ${MKUBIFS_ARGS} && ubinize -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubi ${UBINIZE_ARGS} ubinize.cfg && mv ${IMAGE_ROOTFS}-boot ${IMAGE_ROOTFS}/boot"
+IMAGE_CMD_ubifs = "mv ${IMAGE_ROOTFS}/boot ${IMAGE_ROOTFS}-boot && mkfs.ubifs -r ${IMAGE_ROOTFS} -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.ubifs.img ${MKUBIFS_ARGS} && mv ${IMAGE_ROOTFS}-boot ${IMAGE_ROOTFS}/boot"
+
ROOTFS_POSTPROCESS_COMMAND += " shr_rootfs_postprocess"
ROOTFS_POSTPROCESS_COMMAND_append_om-gta02 = ";shr_rootfs_gta02_postprocess"
diff --git a/recipes/tasks/task-shr-minimal.bb b/recipes/tasks/task-shr-minimal.bb
index 5b16a2a14b..00524be656 100644
--- a/recipes/tasks/task-shr-minimal.bb
+++ b/recipes/tasks/task-shr-minimal.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "SHR Lite Image Feed"
-PR = "r21"
+PR = "r22"
PV = "2.0"
LICENSE = "GPL"
@@ -63,6 +63,8 @@ PACKAGES += "\
RDEPENDS_${PN}-base = "\
+ ${MACHINE_TASK_PROVIDER} \
+ task-base \
netbase \
sysfsutils \
modutils-initscripts \
@@ -104,6 +106,8 @@ RDEPENDS_${PN}-audio_append_om-gta02 = "\
"
RDEPENDS_${PN}-x = "\
+ task-x11-illume \
+ task-fonts-truetype-core \
e-wm-menu-shr \
shr-wizard \
shr-theme-gry \
@@ -112,7 +116,7 @@ RDEPENDS_${PN}-x = "\
"
RDEPENDS_${PN}-apps = "\
- fso-abyss \
+ task-fso2-compliance \
phoneui-apps-messages \
phoneui-apps-contacts \
phoneui-apps-dialer \