aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/xml-commons/jaxp1.3-native_1.3.04.bb4
-rw-r--r--recipes/xml-commons/jaxp1.3_1.3.04.bb4
-rw-r--r--recipes/xml-commons/xml-commons-resolver1.1-native_1.2.bb6
-rw-r--r--recipes/xml-commons/xml-commons-resolver1.1_1.2.bb5
4 files changed, 7 insertions, 12 deletions
diff --git a/recipes/xml-commons/jaxp1.3-native_1.3.04.bb b/recipes/xml-commons/jaxp1.3-native_1.3.04.bb
deleted file mode 100644
index ae94b80140..0000000000
--- a/recipes/xml-commons/jaxp1.3-native_1.3.04.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require jaxp1.3_${PV}.bb
-
-inherit java-native
-
diff --git a/recipes/xml-commons/jaxp1.3_1.3.04.bb b/recipes/xml-commons/jaxp1.3_1.3.04.bb
index c33863047e..9dc75a5e86 100644
--- a/recipes/xml-commons/jaxp1.3_1.3.04.bb
+++ b/recipes/xml-commons/jaxp1.3_1.3.04.bb
@@ -22,6 +22,8 @@ do_compile() {
fastjar -c -m manifest.commons -f ${JARFILENAME} -C build .
}
-
SRC_URI[md5sum] = "5536f87a816c766f4999ed60593a8701"
SRC_URI[sha256sum] = "8e8a412aeb95644eaf14ec1a5cfd04833e38cac4a01b83d73d7de2368a35a597"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
diff --git a/recipes/xml-commons/xml-commons-resolver1.1-native_1.2.bb b/recipes/xml-commons/xml-commons-resolver1.1-native_1.2.bb
deleted file mode 100644
index 382be4373d..0000000000
--- a/recipes/xml-commons/xml-commons-resolver1.1-native_1.2.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require xml-commons-resolver1.1_${PV}.bb
-
-inherit java-native
-
-DEPENDS = "fastjar-native jaxp1.3-native"
-
diff --git a/recipes/xml-commons/xml-commons-resolver1.1_1.2.bb b/recipes/xml-commons/xml-commons-resolver1.1_1.2.bb
index 07421ab20b..206186a4c7 100644
--- a/recipes/xml-commons/xml-commons-resolver1.1_1.2.bb
+++ b/recipes/xml-commons/xml-commons-resolver1.1_1.2.bb
@@ -9,6 +9,7 @@ inherit java-library
S = "${WORKDIR}/xml-commons-resolver-${PV}"
DEPENDS = "fastjar-native jaxp1.3"
+DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native"
do_unpackpost() {
find src -exec \
@@ -33,6 +34,8 @@ do_compile() {
fastjar -C build -c -m src/manifest.resolver -f ${JARFILENAME} org
}
-
SRC_URI[md5sum] = "46d52acdb67ba60f0156043f30108766"
SRC_URI[sha256sum] = "55dbe7bd56452c175320ce9a97b752252c5537427221323c72e9b9c1ac221efe"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"