aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/qt4/qt-embedded_4.4.3.bb2
-rw-r--r--recipes/qt4/qt4-x11-free_4.4.3.bb2
-rw-r--r--recipes/qt4/qt_staging.inc7
3 files changed, 7 insertions, 4 deletions
diff --git a/recipes/qt4/qt-embedded_4.4.3.bb b/recipes/qt4/qt-embedded_4.4.3.bb
index 22715cc382..d0f57ca35f 100644
--- a/recipes/qt4/qt-embedded_4.4.3.bb
+++ b/recipes/qt4/qt-embedded_4.4.3.bb
@@ -1,2 +1,2 @@
require qt-embedded.inc
-PR = "r6"
+PR = "r7"
diff --git a/recipes/qt4/qt4-x11-free_4.4.3.bb b/recipes/qt4/qt4-x11-free_4.4.3.bb
index 987a489e97..d1bf335420 100644
--- a/recipes/qt4/qt4-x11-free_4.4.3.bb
+++ b/recipes/qt4/qt4-x11-free_4.4.3.bb
@@ -1,5 +1,5 @@
require qt4-x11-free.inc
-PR = "r4"
+PR = "r5"
SRC_URI += " \
file://0002-fix-resinit-declaration.patch;patch=1 \
diff --git a/recipes/qt4/qt_staging.inc b/recipes/qt4/qt_staging.inc
index 3bbcdcde22..21e1b4c31f 100644
--- a/recipes/qt4/qt_staging.inc
+++ b/recipes/qt4/qt_staging.inc
@@ -16,6 +16,7 @@ do_stage_append() {
sed -i s#"-L${S}/lib"##g libQt*.la
sed -i s#'$(OE_QMAKE_LIBS_X11)'#"${OE_QMAKE_LIBS_X11}"#g libQt*.la
+ # FIXME: is this really needed?
install -d ${STAGING_DIR_TARGET}/qt4/bin
cp ${STAGING_DIR_NATIVE}/qt4/bin/* ${STAGING_DIR_TARGET}/qt4/bin/ || true
cp ${STAGING_DIR_NATIVE}/${bindir}/{rcc*,uic*,moc*} ${STAGING_DIR_TARGET}/qt4/bin/ || true
@@ -30,9 +31,11 @@ do_stage() {
mkdir -p ${STAGE_TEMP}
oe_runmake install INSTALL_ROOT=${STAGE_TEMP}
- install -d ${STAGING_INCDIR}/
+ install -d ${STAGING_INCDIR}
install -d ${STAGING_LIBDIR}
- cp -pPRf ${STAGE_TEMP}/$includedir/* ${STAGING_INCDIR}/
+ cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/
+ install -d ${STAGING_DATADIR}/${QT_DIR_NAME}/mkspecs
+ cp -pPRf ${STAGE_TEMP}/${datadir}/${QT_DIR_NAME}/mkspecs/* ${STAGING_DATADIR}/${QT_DIR_NAME}/mkspecs/
for i in ${STAGE_TEMP}/${libdir}/*.la
do