aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/am3517-evm.conf (renamed from conf/machine/omap3517-evm.conf)2
-rwxr-xr-xcontrib/angstrom/sort.sh2
-rw-r--r--recipes/clutter/clutter.inc2
-rw-r--r--recipes/linux/linux-omap-psp-2.6.29/am3517-evm/defconfig (renamed from recipes/linux/linux-omap-psp-2.6.29/omap3517-evm/defconfig)0
-rw-r--r--recipes/linux/linux-omap-psp/am3517-evm/defconfig (renamed from recipes/linux/linux-omap-psp/omap3517-evm/defconfig)0
-rw-r--r--recipes/linux/linux-omap-psp_2.6.29.bb4
-rw-r--r--recipes/linux/linux-omap-psp_2.6.31.bb2
-rw-r--r--recipes/u-boot/u-boot_git.bb6
-rw-r--r--recipes/x-load/x-load_1.41.bb2
-rw-r--r--recipes/x-load/x-load_git.bb4
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/am3517-evm/xorg.conf (renamed from recipes/xorg-xserver/xserver-xorg-conf/omap3517-evm/xorg.conf)0
11 files changed, 13 insertions, 11 deletions
diff --git a/conf/machine/omap3517-evm.conf b/conf/machine/am3517-evm.conf
index 77ea2807b9..f7a60b4be4 100644
--- a/conf/machine/omap3517-evm.conf
+++ b/conf/machine/am3517-evm.conf
@@ -15,6 +15,8 @@ GUI_MACHINE_CLASS = "smallscreen"
require conf/machine/include/omap3.inc
+PACKAGE_EXTRA_ARCHS += "omap3517-evm"
+
# Ship all kernel modules
MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules kernel-modules"
diff --git a/contrib/angstrom/sort.sh b/contrib/angstrom/sort.sh
index c8b1d764aa..1e787a4ffa 100755
--- a/contrib/angstrom/sort.sh
+++ b/contrib/angstrom/sort.sh
@@ -58,7 +58,7 @@ case "$arch" in
"armv7")
machines="" ;;
"armv7a")
- machines="igep0020 omap3-touchbook beagleboard omap3evm omap3517-evm omap3-pandora omapzoom omapzoom2 overo" ;;
+ machines="igep0020 omap3-touchbook beagleboard omap3evm am3517-evm omap3517-evm omap3-pandora omapzoom omapzoom2 overo" ;;
"avr32")
machines="atngw100 at32stk1000" ;;
"bfin")
diff --git a/recipes/clutter/clutter.inc b/recipes/clutter/clutter.inc
index 705cece91e..55980eda02 100644
--- a/recipes/clutter/clutter.inc
+++ b/recipes/clutter/clutter.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Clutter graphics library"
HOMEPAGE = "http://www.clutter-project.org/"
LICENSE = "LGPL"
-COMPATIBLE_MACHINE = "(zylonite|mx31litekit|omap-3430ldp|omap-3430sdp|mx31ads|qemuarm|qemux86|ipodtouch|omap3517-evm|beagleboard|overo|omap3evm|omap5912osk)"
+COMPATIBLE_MACHINE = "(zylonite|mx31litekit|omap-3430ldp|omap-3430sdp|mx31ads|qemuarm|qemux86|ipodtouch|am3517-evm|beagleboard|overo|omap3evm|omap5912osk)"
STDDEPENDS = "virtual/libx11 gtk-doc-native pango glib-2.0 libxfixes gtk+"
BASE_CONF = "--disable-gtk-doc ${@get_clutter_fpu_setting(bb, d)}"
diff --git a/recipes/linux/linux-omap-psp-2.6.29/omap3517-evm/defconfig b/recipes/linux/linux-omap-psp-2.6.29/am3517-evm/defconfig
index 4fa37bd8ef..4fa37bd8ef 100644
--- a/recipes/linux/linux-omap-psp-2.6.29/omap3517-evm/defconfig
+++ b/recipes/linux/linux-omap-psp-2.6.29/am3517-evm/defconfig
diff --git a/recipes/linux/linux-omap-psp/omap3517-evm/defconfig b/recipes/linux/linux-omap-psp/am3517-evm/defconfig
index 9b22a1787f..9b22a1787f 100644
--- a/recipes/linux/linux-omap-psp/omap3517-evm/defconfig
+++ b/recipes/linux/linux-omap-psp/am3517-evm/defconfig
diff --git a/recipes/linux/linux-omap-psp_2.6.29.bb b/recipes/linux/linux-omap-psp_2.6.29.bb
index 4c213b1dd1..2a2754eb13 100644
--- a/recipes/linux/linux-omap-psp_2.6.29.bb
+++ b/recipes/linux/linux-omap-psp_2.6.29.bb
@@ -3,7 +3,7 @@ require linux.inc
DESCRIPTION = "Linux kernel for OMAP processors"
KERNEL_IMAGETYPE = "uImage"
-COMPATIBLE_MACHINE = "omap3evm|omap3517-evm"
+COMPATIBLE_MACHINE = "omap3evm|am3517-evm"
SRCREV = "9abb6eb717acbca192ab251a056e3a66b2b47884"
@@ -16,7 +16,7 @@ SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=gi
S = "${WORKDIR}/git"
-SRC_URI_append_omap3517-evm = " \
+SRC_URI_append_am3517-evm = " \
file://shiva-bits.diff;patch=1 \
file://shiva-ehci.diff;patch=1 \
"
diff --git a/recipes/linux/linux-omap-psp_2.6.31.bb b/recipes/linux/linux-omap-psp_2.6.31.bb
index 6828d52146..1e931e19e5 100644
--- a/recipes/linux/linux-omap-psp_2.6.31.bb
+++ b/recipes/linux/linux-omap-psp_2.6.31.bb
@@ -3,7 +3,7 @@ require linux.inc
DESCRIPTION = "Linux kernel for OMAP processors"
KERNEL_IMAGETYPE = "uImage"
-COMPATIBLE_MACHINE = "omap3evm|omap3517-evm"
+COMPATIBLE_MACHINE = "omap3evm|am3517-evm"
SRCREV = "9cf7a18fe227717dcc08163100dacd579de48e0c"
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 3d067c9ce6..15c3060a39 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -47,8 +47,8 @@ SRCREV_omap3evm = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
PV_omap3evm = "2009.03+${PR}+gitr${SRCREV}"
-SRCREV_omap3517-evm = "e60beb13cf0"
-SRC_URI_append_omap3517-evm = " \
+SRCREV_am3517-evm = "e60beb13cf0"
+SRC_URI_append_am3517-evm = " \
file://omap3evm/0001-Changes-for-making-a-NAND-build.patch;patch=1 \
file://omap3evm/0002-Fix-for-NFS-boot-for-OMAP3-EVM.patch;patch=1 \
file://omap3evm/0003-OMAP3-timer-handling-to-1ms-tick-and-CONFIG_SYS_HZ-t.patch;patch=1 \
@@ -66,7 +66,7 @@ file://omap3evm/0014-EMAC-driver-cleanup-removed-debug-prints.patch;patch=1 \
file://omap3evm/0015-EMAC-driver-Check-for-link-status-in-packet-send-lo.patch;patch=1 \
file://omap3evm/0016-Config-option-and-name-changed-to-omap3517_evm.patch;patch=1 \
"
-PV_omap3517-evm = "2009.03+${PR}+gitr${SRCREV}"
+PV_am3517-evm = "2009.03+${PR}+gitr${SRCREV}"
SRC_URI_omapzoom = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3-dev;protocol=git"
SRCREV_omapzoom = "d691b424f1f5bf7eea3a4131dfc578d272e8f335"
diff --git a/recipes/x-load/x-load_1.41.bb b/recipes/x-load/x-load_1.41.bb
index 0a38f5ba0f..6995e66e5a 100644
--- a/recipes/x-load/x-load_1.41.bb
+++ b/recipes/x-load/x-load_1.41.bb
@@ -1,6 +1,6 @@
require x-load.inc
-COMPATIBLE_MACHINE = "omap3517-evm"
+COMPATIBLE_MACHINE = "am3517-evm"
SRC_URI = "file://x-loader-03.00.00.01.tar.gz \
file://0013-board.c-print-boot-method-mmc-onenand-nand.patch;patch=1 \
diff --git a/recipes/x-load/x-load_git.bb b/recipes/x-load/x-load_git.bb
index 3368fce52f..0e0e603cb8 100644
--- a/recipes/x-load/x-load_git.bb
+++ b/recipes/x-load/x-load_git.bb
@@ -1,6 +1,6 @@
require x-load.inc
-DEFAULT_PREFERENCE_omap3517-evm = "-1"
+DEFAULT_PREFERENCE_am3517-evm = "-1"
DEFAULT_PREFERENCE_omap3-pandora = "-1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/x-load-git/${MACHINE}"
@@ -23,7 +23,7 @@ SRC_URI_append_omap3-touchbook = " \
"
-SRC_URI_append_omap3517-evm = " \
+SRC_URI_append_am3517-evm = " \
file://xload-shiva.diff;patch=1 \
"
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/omap3517-evm/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/am3517-evm/xorg.conf
index 983bb0823a..983bb0823a 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf/omap3517-evm/xorg.conf
+++ b/recipes/xorg-xserver/xserver-xorg-conf/am3517-evm/xorg.conf