aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/binutils/binutils-2.19.51/ld-stub-crash.patch26
-rw-r--r--recipes/binutils/binutils_2.19.51.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/recipes/binutils/binutils-2.19.51/ld-stub-crash.patch b/recipes/binutils/binutils-2.19.51/ld-stub-crash.patch
new file mode 100644
index 0000000000..1952649eb8
--- /dev/null
+++ b/recipes/binutils/binutils-2.19.51/ld-stub-crash.patch
@@ -0,0 +1,26 @@
+Index: bfd/elf32-arm.c
+===================================================================
+RCS file: /cvs/src/src/bfd/elf32-arm.c,v
+retrieving revision 1.196
+diff -p -c -u -r1.196 elf32-arm.c
+--- bfd/elf32-arm.c 22 May 2009 11:58:44 -0000 1.196
++++ bfd/elf32-arm.c 12 Jun 2009 13:18:20 -0000
+@@ -3175,11 +3175,15 @@ arm_type_of_stub (struct bfd_link_info *
+
+ /* We have an extra 2-bytes reach because of
+ the mode change (bit 24 (H) of BLX encoding). */
++ /* A stub is needed only if this call is not throught a PLT
++ entry, because PLT stubs handle mode switching
++ already. */
+ if (branch_offset > (ARM_MAX_FWD_BRANCH_OFFSET + 2)
+ || (branch_offset < ARM_MAX_BWD_BRANCH_OFFSET)
+- || ((r_type == R_ARM_CALL) && !globals->use_blx)
+- || (r_type == R_ARM_JUMP24)
+- || (r_type == R_ARM_PLT32))
++ || ( (((r_type == R_ARM_CALL) && !globals->use_blx)
++ || (r_type == R_ARM_JUMP24)
++ || (r_type == R_ARM_PLT32))
++ && !use_plt))
+ {
+ stub_type = (info->shared | globals->pic_veneer)
+ /* PIC stubs. */
diff --git a/recipes/binutils/binutils_2.19.51.bb b/recipes/binutils/binutils_2.19.51.bb
index 20038de34e..fe5491ee79 100644
--- a/recipes/binutils/binutils_2.19.51.bb
+++ b/recipes/binutils/binutils_2.19.51.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
require binutils.inc
LICENSE = "GPLv3"
@@ -14,6 +14,7 @@ SRC_URI = "\
file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
file://binutils-arm-pr7093.patch;patch=1 \
file://uclibc-segfault.patch;patch=1 \
+ file://ld-stub-crash.patch;patch=1;pnum=0 \
"
# powerpc patches