aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/kexecboot/linux-kexecboot/spitz/defconfig96
-rw-r--r--recipes/kexecboot/linux-kexecboot_git.bb4
-rw-r--r--recipes/linux/linux/spitz/defconfig8
-rw-r--r--recipes/linux/linux_git.bb4
4 files changed, 79 insertions, 33 deletions
diff --git a/recipes/kexecboot/linux-kexecboot/spitz/defconfig b/recipes/kexecboot/linux-kexecboot/spitz/defconfig
index 73d46130fe..486ea6ba5d 100644
--- a/recipes/kexecboot/linux-kexecboot/spitz/defconfig
+++ b/recipes/kexecboot/linux-kexecboot/spitz/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.35-rc3
-# Sun Jun 20 08:56:48 2010
+# Linux kernel version: 2.6.35-rc6
+# Thu Jul 22 23:42:39 2010
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -417,6 +417,7 @@ CONFIG_HAVE_AOUT=y
CONFIG_PM=y
# CONFIG_PM_DEBUG is not set
CONFIG_PM_SLEEP=y
+CONFIG_SUSPEND_NVS=y
CONFIG_SUSPEND=y
CONFIG_SUSPEND_FREEZER=y
CONFIG_APM_EMULATION=y
@@ -557,36 +558,82 @@ CONFIG_BLK_DEV_LOOP=y
# CONFIG_MG_DISK is not set
# CONFIG_MISC_DEVICES is not set
CONFIG_HAVE_IDE=y
-CONFIG_IDE=y
+# CONFIG_IDE is not set
#
-# Please see Documentation/ide/ide.txt for help/info on IDE drives
+# SCSI device support
#
-# CONFIG_BLK_DEV_IDE_SATA is not set
-CONFIG_IDE_GD=y
-CONFIG_IDE_GD_ATA=y
-# CONFIG_IDE_GD_ATAPI is not set
-CONFIG_BLK_DEV_IDECS=y
-# CONFIG_BLK_DEV_IDECD is not set
-# CONFIG_BLK_DEV_IDETAPE is not set
-# CONFIG_IDE_TASK_IOCTL is not set
-# CONFIG_IDE_PROC_FS is not set
+CONFIG_SCSI_MOD=y
+# CONFIG_RAID_ATTRS is not set
+CONFIG_SCSI=y
+CONFIG_SCSI_DMA=y
+# CONFIG_SCSI_TGT is not set
+# CONFIG_SCSI_NETLINK is not set
+CONFIG_SCSI_PROC_FS=y
#
-# IDE chipset support/bugfixes
+# SCSI support type (disk, tape, CD-ROM)
#
-# CONFIG_BLK_DEV_PLATFORM is not set
-# CONFIG_BLK_DEV_IDEDMA is not set
+# CONFIG_BLK_DEV_SD is not set
+# CONFIG_CHR_DEV_ST is not set
+# CONFIG_CHR_DEV_OSST is not set
+# CONFIG_BLK_DEV_SR is not set
+# CONFIG_CHR_DEV_SG is not set
+# CONFIG_CHR_DEV_SCH is not set
+# CONFIG_SCSI_MULTI_LUN is not set
+# CONFIG_SCSI_CONSTANTS is not set
+# CONFIG_SCSI_LOGGING is not set
+# CONFIG_SCSI_SCAN_ASYNC is not set
#
-# SCSI device support
+# SCSI Transports
+#
+# CONFIG_SCSI_SPI_ATTRS is not set
+# CONFIG_SCSI_FC_ATTRS is not set
+# CONFIG_SCSI_SAS_ATTRS is not set
+# CONFIG_SCSI_SAS_LIBSAS is not set
+# CONFIG_SCSI_SRP_ATTRS is not set
+CONFIG_SCSI_LOWLEVEL=y
+# CONFIG_LIBFC is not set
+# CONFIG_LIBFCOE is not set
+# CONFIG_SCSI_DEBUG is not set
+# CONFIG_SCSI_LOWLEVEL_PCMCIA is not set
+# CONFIG_SCSI_DH is not set
+# CONFIG_SCSI_OSD_INITIATOR is not set
+CONFIG_ATA=y
+# CONFIG_ATA_NONSTANDARD is not set
+CONFIG_ATA_VERBOSE_ERROR=y
+CONFIG_SATA_PMP=y
+
+#
+# Controllers with non-SFF native interface
+#
+# CONFIG_SATA_AHCI_PLATFORM is not set
+CONFIG_ATA_SFF=y
+
+#
+# SFF controllers with custom DMA interface
+#
+CONFIG_ATA_BMDMA=y
+
+#
+# SATA SFF controllers with BMDMA
+#
+# CONFIG_SATA_MV is not set
+
+#
+# PATA SFF controllers with BMDMA
+#
+
+#
+# PIO-only SFF controllers
+#
+CONFIG_PATA_PCMCIA=y
+CONFIG_PATA_PLATFORM=y
+
+#
+# Generic fallback / legacy drivers
#
-CONFIG_SCSI_MOD=y
-# CONFIG_RAID_ATTRS is not set
-# CONFIG_SCSI is not set
-# CONFIG_SCSI_DMA is not set
-# CONFIG_SCSI_NETLINK is not set
-# CONFIG_ATA is not set
# CONFIG_MD is not set
# CONFIG_PHONE is not set
@@ -616,7 +663,7 @@ CONFIG_INPUT_APMPOWER=y
CONFIG_INPUT_KEYBOARD=y
# CONFIG_KEYBOARD_ADP5588 is not set
# CONFIG_KEYBOARD_ATKBD is not set
-# CONFIG_QT2160 is not set
+# CONFIG_KEYBOARD_QT2160 is not set
# CONFIG_KEYBOARD_LKKBD is not set
CONFIG_KEYBOARD_GPIO=y
# CONFIG_KEYBOARD_TCA6416 is not set
@@ -1046,7 +1093,6 @@ CONFIG_LEDS_TRIGGERS=y
# LED Triggers
#
CONFIG_LEDS_TRIGGER_TIMER=y
-CONFIG_LEDS_TRIGGER_IDE_DISK=y
CONFIG_LEDS_TRIGGER_HEARTBEAT=y
# CONFIG_LEDS_TRIGGER_BACKLIGHT is not set
# CONFIG_LEDS_TRIGGER_GPIO is not set
diff --git a/recipes/kexecboot/linux-kexecboot_git.bb b/recipes/kexecboot/linux-kexecboot_git.bb
index d53baf9842..8631050645 100644
--- a/recipes/kexecboot/linux-kexecboot_git.bb
+++ b/recipes/kexecboot/linux-kexecboot_git.bb
@@ -1,7 +1,7 @@
require linux-kexecboot.inc
-KERNEL_RELEASE = "2.6.35-rc5"
-SRCREV = "f469461df6ff822f71b8737bda86eea20f16ff93"
+KERNEL_RELEASE = "2.6.35-rc6"
+SRCREV = "b37fa16e78d6f9790462b3181602a26b5af36260"
PV = "${KERNEL_RELEASE}+gitr${SRCPV}"
SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;branch=master \
diff --git a/recipes/linux/linux/spitz/defconfig b/recipes/linux/linux/spitz/defconfig
index f098d75d1a..312952f1ae 100644
--- a/recipes/linux/linux/spitz/defconfig
+++ b/recipes/linux/linux/spitz/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.35-rc4
-# Thu Jul 8 10:27:47 2010
+# Linux kernel version: 2.6.35-rc6
+# Thu Jul 22 23:22:01 2010
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1015,7 +1015,7 @@ CONFIG_ATA_BMDMA=y
# PIO-only SFF controllers
#
CONFIG_PATA_PCMCIA=y
-# CONFIG_PATA_PLATFORM is not set
+CONFIG_PATA_PLATFORM=y
#
# Generic fallback / legacy drivers
@@ -1161,7 +1161,7 @@ CONFIG_INPUT_APMPOWER=y
CONFIG_INPUT_KEYBOARD=y
# CONFIG_KEYBOARD_ADP5588 is not set
# CONFIG_KEYBOARD_ATKBD is not set
-# CONFIG_QT2160 is not set
+# CONFIG_KEYBOARD_QT2160 is not set
# CONFIG_KEYBOARD_LKKBD is not set
CONFIG_KEYBOARD_GPIO=y
# CONFIG_KEYBOARD_TCA6416 is not set
diff --git a/recipes/linux/linux_git.bb b/recipes/linux/linux_git.bb
index 231383e972..2b029d361a 100644
--- a/recipes/linux/linux_git.bb
+++ b/recipes/linux/linux_git.bb
@@ -1,7 +1,7 @@
require linux.inc
-KERNEL_RELEASE = "2.6.35-rc5"
-SRCREV = "f469461df6ff822f71b8737bda86eea20f16ff93"
+KERNEL_RELEASE = "2.6.35-rc6"
+SRCREV = "b37fa16e78d6f9790462b3181602a26b5af36260"
PV = "${KERNEL_RELEASE}+gitr${SRCPV}"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;branch=master \