aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xcontrib/python/generate-manifest-2.6.py4
-rw-r--r--recipes/python/python-2.6-manifest.inc6
-rw-r--r--recipes/python/python.inc2
-rw-r--r--recipes/python/python_2.6.1.bb2
4 files changed, 7 insertions, 7 deletions
diff --git a/contrib/python/generate-manifest-2.6.py b/contrib/python/generate-manifest-2.6.py
index d6fdcb456f..8d9272e4f1 100755
--- a/contrib/python/generate-manifest-2.6.py
+++ b/contrib/python/generate-manifest-2.6.py
@@ -164,7 +164,7 @@ if __name__ == "__main__":
"lib-dynload/.debug ${bindir}/.debug ${libdir}/.debug" )
m.addPackage( "python-devel", "Python Development Package", "python-core",
- "${includedir} config" ) # package
+ "${includedir} ${libdir}/libpython2.6.so config" ) # package
m.addPackage( "python-idle", "Python Integrated Development Environment", "python-core python-tkinter",
"${bindir}/idle idlelib" ) # package
@@ -281,7 +281,7 @@ if __name__ == "__main__":
"base64.* cookielib.* ftplib.* gopherlib.* hmac.* httplib.* mimetypes.* nntplib.* poplib.* smtplib.* telnetlib.* urllib.* urllib2.* urlparse.* uuid.* rfc822.* mimetools.*" )
m.addPackage( "python-netserver", "Python Internet Protocol Servers", "python-core python-netclient",
- "cgi.* BaseHTTPServer.* SimpleHTTPServer.* SocketServer.*" )
+ "cgi.* *HTTPServer.* SocketServer.*" )
m.addPackage( "python-pickle", "Python Persistence Support", "python-core python-codecs python-io python-re",
"pickle.* shelve.* lib-dynload/cPickle.so" )
diff --git a/recipes/python/python-2.6-manifest.inc b/recipes/python/python-2.6-manifest.inc
index aff86a1f76..00eda6b9c9 100644
--- a/recipes/python/python-2.6-manifest.inc
+++ b/recipes/python/python-2.6-manifest.inc
@@ -1,6 +1,6 @@
# WARNING: This file is AUTO GENERATED: Manual edits will be lost next time I regenerate the file.
-# Generator: '/local/pkg/oe/openembedded/contrib/python/generate-manifest-2.6.py' Version 20090812 (C) 2002-2009 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+# Generator: '../../contrib/python/generate-manifest-2.6.py' Version 20090812 (C) 2002-2009 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
# Visit the Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
@@ -99,7 +99,7 @@ FILES_python-json="${libdir}/python2.6/json "
DESCRIPTION_python-devel="Python Development Package"
RDEPENDS_python-devel="python-core"
-FILES_python-devel="${includedir} ${libdir}/python2.6/config "
+FILES_python-devel="${includedir} ${libdir}/libpython2.6.so ${libdir}/python2.6/config "
DESCRIPTION_python-difflib="Python helpers for computing deltas between objects."
RDEPENDS_python-difflib="python-lang python-re"
@@ -151,7 +151,7 @@ FILES_python-pprint="${libdir}/python2.6/pprint.* "
DESCRIPTION_python-netserver="Python Internet Protocol Servers"
RDEPENDS_python-netserver="python-core python-netclient"
-FILES_python-netserver="${libdir}/python2.6/cgi.* ${libdir}/python2.6/BaseHTTPServer.* ${libdir}/python2.6/SimpleHTTPServer.* ${libdir}/python2.6/SocketServer.* "
+FILES_python-netserver="${libdir}/python2.6/cgi.* ${libdir}/python2.6/*HTTPServer.* ${libdir}/python2.6/SocketServer.* "
DESCRIPTION_python-curses="Python Curses Support"
RDEPENDS_python-curses="python-core"
diff --git a/recipes/python/python.inc b/recipes/python/python.inc
index b31d80e688..5791297609 100644
--- a/recipes/python/python.inc
+++ b/recipes/python/python.inc
@@ -4,7 +4,7 @@ LICENSE = "PSF"
SECTION = "devel/python"
PRIORITY = "optional"
# bump this on every change in contrib/python/generate-manifest-2.6.py
-INC_PR = "ml6"
+INC_PR = "ml7"
DEFAULT_PREFERENCE = "-26"
diff --git a/recipes/python/python_2.6.1.bb b/recipes/python/python_2.6.1.bb
index 8ca51ae3bf..0a6a253ae0 100644
--- a/recipes/python/python_2.6.1.bb
+++ b/recipes/python/python_2.6.1.bb
@@ -1,7 +1,7 @@
require python.inc
DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl tk zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "ml5"
+PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \