aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/python/python-pygame-1.6/.mtn2git_empty0
-rw-r--r--packages/python/python-pygame-1.6/Setup57
-rw-r--r--packages/python/python-pygame-1.6/qpe.patch37
-rw-r--r--packages/python/python-pygame-1.7.1/qpe.patch37
-rw-r--r--packages/python/python-pygame_1.7.1.bb2
5 files changed, 1 insertions, 132 deletions
diff --git a/packages/python/python-pygame-1.6/.mtn2git_empty b/packages/python/python-pygame-1.6/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/python/python-pygame-1.6/.mtn2git_empty
+++ /dev/null
diff --git a/packages/python/python-pygame-1.6/Setup b/packages/python/python-pygame-1.6/Setup
deleted file mode 100644
index c4558b39bb..0000000000
--- a/packages/python/python-pygame-1.6/Setup
+++ /dev/null
@@ -1,57 +0,0 @@
-#This Setup file is used by the setup.py script to configure the
-#python extensions. You will likely use the "config.py" which will
-#build a correct Setup file for you based on your system settings.
-#If not, the format is simple enough to edit by hand. First change
-#the needed commandline flags for each dependency, then comment out
-#any unavailable optional modules in the first optional section.
-
-#SDL = ???
-
-FONT = -lSDL_ttf-2.0
-IMAGE = -lSDL_image-1.2
-MIXER = -lSDL_mixer-1.2
-SMPEG = -lsmpeg $(SDL)
-NUMERIC = -I.
-
-
-
-#the following modules are optional. you will want to compile
-#everything you can, but you can ignore ones you don't have
-#dependencies for, just comment them out
-
-imageext src/imageext.c $(SDL) $(IMAGE)
-font src/font.c $(SDL) $(FONT)
-mixer src/mixer.c $(SDL) $(MIXER)
-mixer_music src/music.c $(SDL) $(MIXER)
-movie src/movie.c $(SDL) $(SMPEG)
-surfarray src/surfarray.c $(SDL) $(NUMERIC)
-sndarray src/sndarray.c $(SDL) $(NUMERIC) $(MIXER)
-
-
-
-#these modules are required for pygame to run. they only require
-#SDL as a dependency. these should not be altered
-
-base src/base.c $(SDL)
-cdrom src/cdrom.c $(SDL)
-constants src/constants.c $(SDL)
-display src/display.c $(SDL)
-event src/event.c $(SDL)
-key src/key.c $(SDL)
-mouse src/mouse.c $(SDL)
-rect src/rect.c $(SDL)
-rwobject src/rwobject.c $(SDL)
-surface src/surface.c src/alphablit.c $(SDL)
-surflock src/surflock.c $(SDL)
-time src/time.c $(SDL)
-joystick src/joystick.c $(SDL)
-draw src/draw.c $(SDL)
-image src/image.c $(SDL)
-transform src/transform.c src/rotozoom.c src/scale2x.c $(SDL)
-
-
-#the following are placeholders. setup.py can use them to help
-#auto-copy needed DLLs into the pygame installation folder.
-#you can simply ignore these lines under non-windows, no need to
-#comment out.
-COPYLIB_smpeg $(SDL) $(SMPEG)
diff --git a/packages/python/python-pygame-1.6/qpe.patch b/packages/python/python-pygame-1.6/qpe.patch
deleted file mode 100644
index b4d3c01a2f..0000000000
--- a/packages/python/python-pygame-1.6/qpe.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- ./src/base.c~qpe.patch 2003-10-16 15:43:22.000000000 +0930
-+++ ./src/base.c 2004-05-11 02:09:14.000000000 +0930
-@@ -37,6 +37,12 @@
- #include<windows.h>
- extern int SDL_RegisterApp(char*, Uint32, void*);
- #endif
-+#ifdef QWS
-+
-+int SDL_main(int argc, char *argv[]) { return 0; };
-+
-+extern void initQCop(int argc, char *argv[]);
-+#endif
-
- #if defined(macintosh)
- #if(!defined(__MWERKS__) && !TARGET_API_MAC_CARBON)
-@@ -691,7 +697,10 @@
- {
- PyObject *module, *dict, *apiobj;
- static void* c_api[PYGAMEAPI_BASE_NUMSLOTS];
--
-+#ifdef QWS
-+ char *args[] = {"pygame", NULL};
-+#endif
-+
- /* create the module */
- module = Py_InitModule3("base", init__builtins__, doc_pygame_MODULE);
- dict = PyModule_GetDict(module);
-@@ -722,6 +731,9 @@
- /*some intiialization*/
- Py_AtExit(atexit_quit);
- install_parachute();
-+#ifdef QWS
-+ initQCop(1, args);
-+#endif
- #ifdef MS_WIN32
- SDL_RegisterApp("pygame", 0, GetModuleHandle(NULL));
- #endif
diff --git a/packages/python/python-pygame-1.7.1/qpe.patch b/packages/python/python-pygame-1.7.1/qpe.patch
deleted file mode 100644
index b4d3c01a2f..0000000000
--- a/packages/python/python-pygame-1.7.1/qpe.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- ./src/base.c~qpe.patch 2003-10-16 15:43:22.000000000 +0930
-+++ ./src/base.c 2004-05-11 02:09:14.000000000 +0930
-@@ -37,6 +37,12 @@
- #include<windows.h>
- extern int SDL_RegisterApp(char*, Uint32, void*);
- #endif
-+#ifdef QWS
-+
-+int SDL_main(int argc, char *argv[]) { return 0; };
-+
-+extern void initQCop(int argc, char *argv[]);
-+#endif
-
- #if defined(macintosh)
- #if(!defined(__MWERKS__) && !TARGET_API_MAC_CARBON)
-@@ -691,7 +697,10 @@
- {
- PyObject *module, *dict, *apiobj;
- static void* c_api[PYGAMEAPI_BASE_NUMSLOTS];
--
-+#ifdef QWS
-+ char *args[] = {"pygame", NULL};
-+#endif
-+
- /* create the module */
- module = Py_InitModule3("base", init__builtins__, doc_pygame_MODULE);
- dict = PyModule_GetDict(module);
-@@ -722,6 +731,9 @@
- /*some intiialization*/
- Py_AtExit(atexit_quit);
- install_parachute();
-+#ifdef QWS
-+ initQCop(1, args);
-+#endif
- #ifdef MS_WIN32
- SDL_RegisterApp("pygame", 0, GetModuleHandle(NULL));
- #endif
diff --git a/packages/python/python-pygame_1.7.1.bb b/packages/python/python-pygame_1.7.1.bb
index 429ae6fdf8..d80359dbba 100644
--- a/packages/python/python-pygame_1.7.1.bb
+++ b/packages/python/python-pygame_1.7.1.bb
@@ -6,9 +6,9 @@ LICENSE = "LGPL"
RDEPENDS = "python-core python-numeric libsdl-x11"
DEPENDS = "virtual/libsdl libsdl-image libsdl-mixer libsdl-net libsdl-ttf smpeg python-numeric"
SRCNAME = "pygame"
+PR = "ml1"
SRC_URI = "http://www.pygame.org/ftp/${SRCNAME}-${PV}release.tar.gz \
- file://qpe.patch;patch=1 \
file://Setup"
S = "${WORKDIR}/${SRCNAME}-${PV}release"