aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/slugos.inc8
-rw-r--r--packages/linphone/linphone_1.6.0.bb2
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.19.bb15
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.20.bb (renamed from packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc6.bb)15
4 files changed, 29 insertions, 11 deletions
diff --git a/conf/distro/include/slugos.inc b/conf/distro/include/slugos.inc
index 2e004d26bd..ba61355ba8 100644
--- a/conf/distro/include/slugos.inc
+++ b/conf/distro/include/slugos.inc
@@ -169,18 +169,12 @@ PREFERRED_VERSION_glibc ?= "2.3.5+cvs20050627"
# Select the correct versions of the kernel and modules (these are the
# defaults, override in the conf/distro top-level distro file).
PREFERRED_PROVIDER_virtual/kernel ?= "ixp4xx-kernel"
-PREFERRED_VERSION_ixp4xx-kernel ?= "2.6.19"
+PREFERRED_VERSION_ixp4xx-kernel ?= "2.6.20"
# Select the smallest provider of x11 libraries
PREFERRED_PROVIDER_virtual/libx11 ?= "diet-x11"
SRCDATE_diet-x11 ?= "20060106"
-# Latest wpa-supplicant which supports madwifi-ng
-PREFERRED_VERSION_wpa-supplicant ?= "0.5.1"
-
-# Latest linphone supports yeaphone
-PREFERRED_VERSION_linphone ?= "1.6.0"
-
# Ensure consistency across all SlugOS builds for the provider of a
# relational database - use the latest version of the SleepyCat
# Berkeley database
diff --git a/packages/linphone/linphone_1.6.0.bb b/packages/linphone/linphone_1.6.0.bb
index 99ba3878a2..f483368c79 100644
--- a/packages/linphone/linphone_1.6.0.bb
+++ b/packages/linphone/linphone_1.6.0.bb
@@ -1,5 +1,3 @@
-DEFAULT_PREFERENCE = "-1"
-
DESCRIPTION = "SIP-based IP phone (console edition)"
HOMEPAGE = "http://www.linphone.org/?lang=us"
LICENSE = "GPL-2"
diff --git a/packages/linux/ixp4xx-kernel_2.6.19.bb b/packages/linux/ixp4xx-kernel_2.6.19.bb
index 3be13fd971..6841c93d00 100644
--- a/packages/linux/ixp4xx-kernel_2.6.19.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.19.bb
@@ -6,7 +6,7 @@
# http://trac.nslu2-linux.org/kernel/
#
# The revision that is pulled from SVN is specified below
-IXP4XX_KERNEL_SVN_REV = "681"
+IXP4XX_KERNEL_SVN_REV = "682"
#
# The directory containing the patches to be applied is
# specified below
@@ -23,3 +23,16 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
+
+# Remove the specific cmdline hacking patches if we are not building for nslu2.
+addtask remove_cmdline_hacks before do_patch after do_unpack
+do_remove_cmdline_hacks() {
+
+# if [ "${MACHINE}" != "nslu2" ] ; then
+ sed -e '/88-nas100d-dflt-cmdline.patch/d' \
+ -e '/88-nslu2-dflt-cmdline.patch/d' \
+ '${WORKDIR}/series' > '${WORKDIR}/series.new'
+ mv '${WORKDIR}/series.new' '${WORKDIR}/series'
+# fi
+
+}
diff --git a/packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc6.bb b/packages/linux/ixp4xx-kernel_2.6.20.bb
index 5ab6d5c6e7..0cc6b387f7 100644
--- a/packages/linux/ixp4xx-kernel_2.6.19+2.6.20-rc6.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.20.bb
@@ -6,7 +6,7 @@
# http://trac.nslu2-linux.org/kernel/
#
# The revision that is pulled from SVN is specified below
-IXP4XX_KERNEL_SVN_REV = "681"
+IXP4XX_KERNEL_SVN_REV = "682"
#
# The directory containing the patches to be applied is
# specified below
@@ -23,3 +23,16 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
+
+# Remove the specific cmdline hacking patches if we are not building for nslu2.
+addtask remove_cmdline_hacks before do_patch after do_unpack
+do_remove_cmdline_hacks() {
+
+ if [ "${MACHINE}" != "nslu2" ] ; then
+ sed -e '/88-nas100d-dflt-cmdline.patch/d' \
+ -e '/88-nslu2-dflt-cmdline.patch/d' \
+ '${WORKDIR}/series' > '${WORKDIR}/series.new'
+ mv '${WORKDIR}/series.new' '${WORKDIR}/series'
+ fi
+
+}