aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/glib-2.0/glib-2.0_2.22.4.bb8
-rw-r--r--recipes/glib-2.0/glib-2.0_2.23.6.bb8
-rw-r--r--recipes/glib-2.0/glib-2.0_2.24.0.bb6
-rw-r--r--recipes/glib-2.0/glib-2.0_2.24.1.bb6
-rw-r--r--recipes/glib-2.0/glib-2.0_2.26.1.bb6
-rw-r--r--recipes/glib-2.0/glib-2.0_2.28.0.bb6
6 files changed, 26 insertions, 14 deletions
diff --git a/recipes/glib-2.0/glib-2.0_2.22.4.bb b/recipes/glib-2.0/glib-2.0_2.22.4.bb
index 7d2611b9d1..54a19f7096 100644
--- a/recipes/glib-2.0/glib-2.0_2.22.4.bb
+++ b/recipes/glib-2.0/glib-2.0_2.22.4.bb
@@ -6,8 +6,7 @@ UNIX-like platforms, Windows, OS/2 and BeOS."
LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "glib-2.0-native gtk-doc"
-DEPENDS_virtclass-native_append = " pkgconfig-native"
+DEPENDS = "glib-2.0-native gtk-doc virtual/libiconv virtual/libintl"
SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.22/glib-${PV}.tar.bz2;name=archive \
@@ -31,7 +30,6 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
-EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -44,6 +42,10 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
+DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
+ pkgconfig-native"
+EXTRA_OECONF_virtclass-native = ""
+
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.23.6.bb b/recipes/glib-2.0/glib-2.0_2.23.6.bb
index 3896f0fd1d..550e9752e7 100644
--- a/recipes/glib-2.0/glib-2.0_2.23.6.bb
+++ b/recipes/glib-2.0/glib-2.0_2.23.6.bb
@@ -6,8 +6,7 @@ UNIX-like platforms, Windows, OS/2 and BeOS."
LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "glib-2.0-native gtk-doc zlib"
-DEPENDS_virtclass-native_append = " pkgconfig-native"
+DEPENDS = "glib-2.0-native gtk-doc virtual/libiconv virtual/libintl zlib"
PR = "r3"
SRC_URI = "\
@@ -30,7 +29,6 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
-EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -43,6 +41,10 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
+DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
+ pkgconfig-native"
+EXTRA_OECONF_virtclass-native = ""
+
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.24.0.bb b/recipes/glib-2.0/glib-2.0_2.24.0.bb
index 82177d6eb1..5bb79015e2 100644
--- a/recipes/glib-2.0/glib-2.0_2.24.0.bb
+++ b/recipes/glib-2.0/glib-2.0_2.24.0.bb
@@ -7,7 +7,6 @@ LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0-native gtk-doc zlib"
-DEPENDS_virtclass-native_append = " pkgconfig-native"
PR = "r6"
@@ -36,7 +35,6 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
-EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -49,6 +47,10 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
+DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
+ pkgconfig-native"
+EXTRA_OECONF_virtclass-native = ""
+
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.24.1.bb b/recipes/glib-2.0/glib-2.0_2.24.1.bb
index 9b7cdf6434..b150a3fd24 100644
--- a/recipes/glib-2.0/glib-2.0_2.24.1.bb
+++ b/recipes/glib-2.0/glib-2.0_2.24.1.bb
@@ -7,7 +7,8 @@ LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0-native gtk-doc zlib"
-DEPENDS_virtclass-native_append = " pkgconfig-native"
+DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
+ pkgconfig-native"
PR = "r2"
@@ -38,7 +39,6 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
-EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -51,6 +51,8 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
+EXTRA_OECONF_virtclass-native = ""
+
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.26.1.bb b/recipes/glib-2.0/glib-2.0_2.26.1.bb
index 722c55179d..caccfde8c8 100644
--- a/recipes/glib-2.0/glib-2.0_2.26.1.bb
+++ b/recipes/glib-2.0/glib-2.0_2.26.1.bb
@@ -7,7 +7,8 @@ LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0-native gtk-doc zlib"
-DEPENDS_virtclass-native_append = " pkgconfig-native"
+DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
+ pkgconfig-native"
PR = "r3"
@@ -31,7 +32,6 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
-EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -45,6 +45,8 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
+EXTRA_OECONF_virtclass-native = ""
+
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.28.0.bb b/recipes/glib-2.0/glib-2.0_2.28.0.bb
index c34e522dc3..07e72d3a80 100644
--- a/recipes/glib-2.0/glib-2.0_2.28.0.bb
+++ b/recipes/glib-2.0/glib-2.0_2.28.0.bb
@@ -8,7 +8,8 @@ SECTION = "libs"
PRIORITY = "optional"
PR = "r1"
DEPENDS = "glib-2.0-native gtk-doc zlib"
-DEPENDS_virtclass-native_append = " pkgconfig-native"
+DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
+ pkgconfig-native"
SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.28/glib-${PV}.tar.bz2;name=archive \
@@ -30,7 +31,6 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
-EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -44,6 +44,8 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
+EXTRA_OECONF_virtclass-native = ""
+
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"