aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/linux/linux-omap-2.6.37/0001-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch30
-rw-r--r--recipes/linux/linux-omap_2.6.37.bb5
2 files changed, 33 insertions, 2 deletions
diff --git a/recipes/linux/linux-omap-2.6.37/0001-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch b/recipes/linux/linux-omap-2.6.37/0001-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch
new file mode 100644
index 0000000000..6e888d27cb
--- /dev/null
+++ b/recipes/linux/linux-omap-2.6.37/0001-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch
@@ -0,0 +1,30 @@
+From d1adf60fcb9b8b704e909aed90d64c8755340ceb Mon Sep 17 00:00:00 2001
+From: Steve Sakoman <steve@sakoman.com>
+Date: Wed, 12 Jan 2011 13:54:55 -0800
+Subject: [PATCH] omap: mmc: Adjust dto to eliminate timeout errors
+
+omap: mmc: Adjust dto to eliminate timeout errors
+
+A number of SD card types were experiencing timeout errors. This
+could also lead to data corruption in some cases.
+
+This fix proposed by Sukumar Ghoral of TI.
+---
+ drivers/mmc/host/omap_hsmmc.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/drivers/mmc/host/omap_hsmmc.c b/drivers/mmc/host/omap_hsmmc.c
+index 5d46021..4ba2f6c 100644
+--- a/drivers/mmc/host/omap_hsmmc.c
++++ b/drivers/mmc/host/omap_hsmmc.c
+@@ -1405,6 +1405,7 @@ static void set_data_timeout(struct omap_hsmmc_host *host,
+ cycle_ns = 1000000000 / (clk_get_rate(host->fclk) / clkd);
+ timeout = timeout_ns / cycle_ns;
+ timeout += timeout_clks;
++ timeout *= 2;
+ if (timeout) {
+ while ((timeout & 0x80000000) == 0) {
+ dto += 1;
+--
+1.6.6.1
+
diff --git a/recipes/linux/linux-omap_2.6.37.bb b/recipes/linux/linux-omap_2.6.37.bb
index 2953097e90..8cdc353531 100644
--- a/recipes/linux/linux-omap_2.6.37.bb
+++ b/recipes/linux/linux-omap_2.6.37.bb
@@ -7,7 +7,7 @@ COMPATIBLE_MACHINE = "(beagleboard|overo|omap3evm|omap3-touchbook|usrp-e1xx)"
# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
PV = "2.6.37"
-MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "d+gitr${SRCREV}"
SRCREV = "fa3b4e23ec20cfc944db7cc2b30b0d82c20e4472"
FILESPATHPKG_prepend = "linux-omap-2.6.37:"
@@ -197,7 +197,8 @@ SRC_URI_append = " \
file://0001-xM-audio-fix-from-Ashok.patch \
file://0001-omap3-allow-1GHz-mpurates.patch \
file://0001-BeagleBoard-Adjust-USER-button-pin-for-xM.patch \
- "
+ file://0001-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch \
+ "
SRC_URI_append_usrp-e1xx = "\
file://usrp/0001-Add-defines-to-set-config-options-in-GPMC-per-CS-con.patch \