aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/gnuplot/gnuplot-4.2.0/.mtn2git_empty0
-rw-r--r--packages/gnuplot/gnuplot-4.2.0/subdirs.patch11
-rw-r--r--packages/gnuplot/gnuplot_4.2.0.bb41
3 files changed, 52 insertions, 0 deletions
diff --git a/packages/gnuplot/gnuplot-4.2.0/.mtn2git_empty b/packages/gnuplot/gnuplot-4.2.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnuplot/gnuplot-4.2.0/.mtn2git_empty
diff --git a/packages/gnuplot/gnuplot-4.2.0/subdirs.patch b/packages/gnuplot/gnuplot-4.2.0/subdirs.patch
new file mode 100644
index 0000000000..8c7d1f0d35
--- /dev/null
+++ b/packages/gnuplot/gnuplot-4.2.0/subdirs.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile.am 2007-08-23 13:10:15.560659023 +0200
++++ gnuplot-4.2.0/Makefile.am 2007-08-23 13:10:34.961764629 +0200
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in -*-Makefile-*-
+ AUTOMAKE_OPTIONS = foreign 1.2h
+
+-SUBDIRS = config m4 term src docs $(LISPDIR) man demo tutorial share
++SUBDIRS = config m4 term src $(LISPDIR) man share
+
+ EXTRA_DIST = BUGS CodeStyle Copyright FAQ GNUmakefile INSTALL INSTALL.gnu \
+ Makefile.maint PATCHLEVEL PGPKEYS PORTING README README.1ST README.exp \
diff --git a/packages/gnuplot/gnuplot_4.2.0.bb b/packages/gnuplot/gnuplot_4.2.0.bb
new file mode 100644
index 0000000000..c6f51c4f15
--- /dev/null
+++ b/packages/gnuplot/gnuplot_4.2.0.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
+(text or binary) and function plotting utility."
+SECTION = "console/scientific"
+LICENSE = "BSD-4"
+PRIORITY = "optional"
+DEPENDS = "pango cairo virtual/libx11 libpng gd readline"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz \
+ file://subdirs.patch;patch=1 \
+ file://matrix.patch;patch=1 \
+ file://gnuplot.desktop \
+ file://gnuplot.png"
+
+inherit autotools
+
+acpaths = ""
+EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
+ --without-plot \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-gd=${STAGING_LIBDIR}/.. \
+ --without-lisp-files \
+ --without-tutorial"
+
+do_install_append() {
+ install -d ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
+}
+
+
+PACKAGES =+ "${PN}-x11-dbg ${PN}-x11"
+DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
+SECTION_${PN}-x11 = "x11/scientific"
+FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
+
+FILES_${PN} += "${datadir}/texmf"
+FILES_${PN}-x11-dbg += "${libexecdir}/gnuplot/*/.debug"
+
+