aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch19
-rw-r--r--recipes/icedtea/icedtea6-native_1.7.10.bb4
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch b/recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch
new file mode 100644
index 0000000000..925ca6c084
--- /dev/null
+++ b/recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch
@@ -0,0 +1,19 @@
+# HG changeset patch
+# User andrew
+# Date 1309217125 -3600
+# Node ID f7e8b10f51c6a622520b55df0c644fb09ec78542
+# Parent b8227c320dec384a94026fcaa650b0ebd4eef13b
+Allow building HotSpot with any Linux 3 version.
+
+diff -r b8227c320dec -r f7e8b10f51c6 make/linux/Makefile
+--- openjdk/hotspot/make/linux/Makefile Wed Jun 15 18:56:52 2011 +0100
++++ openjdk/hotspot/make/linux/Makefile Tue Jun 28 00:25:25 2011 +0100
+@@ -230,7 +230,7 @@
+ # Solaris 2.5.1, 2.6).
+ # Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
+
+-SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 2.7%
++SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3%
+ OS_VERSION := $(shell uname -r)
+ EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
+
diff --git a/recipes/icedtea/icedtea6-native_1.7.10.bb b/recipes/icedtea/icedtea6-native_1.7.10.bb
index 77c6232e04..a637bf0547 100644
--- a/recipes/icedtea/icedtea6-native_1.7.10.bb
+++ b/recipes/icedtea/icedtea6-native_1.7.10.bb
@@ -1,6 +1,6 @@
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI = "\
http://icedtea.classpath.org/download/source/icedtea6-${PV}.tar.gz;name=iced \
@@ -24,6 +24,7 @@ ICEDTEA_PATCHES = "\
file://icedtea-hotspot-make-arch-sane-for-x86.patch;apply=no \
file://icedtea-jdk-sane-x86-arch.patch;apply=no \
file://icedtea-unbreak-float.patch;apply=no \
+ file://icedtea-support_linux_3.patch;apply=no \
"
export DISTRIBUTION_PATCHES = "\
@@ -33,4 +34,5 @@ export DISTRIBUTION_PATCHES = "\
patches/icedtea-hotspot-make-arch-sane-for-x86.patch \
patches/icedtea-jdk-sane-x86-arch.patch \
patches/icedtea-unbreak-float.patch \
+ patches/icedtea-support_linux_3.patch \
"