aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/shr/initscripts-shr/palmpre/umountfs14
-rw-r--r--recipes/shr/initscripts-shr_0.0.1.bb2
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes/shr/initscripts-shr/palmpre/umountfs b/recipes/shr/initscripts-shr/palmpre/umountfs
new file mode 100644
index 0000000000..b526cfcf16
--- /dev/null
+++ b/recipes/shr/initscripts-shr/palmpre/umountfs
@@ -0,0 +1,14 @@
+#! /bin/sh
+#
+# umountfs Turn off swap and unmount all local filesystems.
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+# We leave /proc mounted.
+echo "Unmounting local filesystems..."
+grep -q /mnt/ram /proc/mounts && mount -o remount,ro /mnt/ram
+
+mount -o remount,ro /
+
+: exit 0
diff --git a/recipes/shr/initscripts-shr_0.0.1.bb b/recipes/shr/initscripts-shr_0.0.1.bb
index 1e67617bcf..294eab9d5e 100644
--- a/recipes/shr/initscripts-shr_0.0.1.bb
+++ b/recipes/shr/initscripts-shr_0.0.1.bb
@@ -8,7 +8,7 @@ RDEPENDS_${PN} = "procps ${EXTRA_DEPS}"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PV = "0.0.1"
-PR = "r30"
+PR = "r31"
RCONFLICTS_${PN} = "initscripts"