aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/angstrom-2008.1.conf1
-rw-r--r--recipes/bluez/bluez4_4.35.bb12
2 files changed, 9 insertions, 4 deletions
diff --git a/conf/distro/angstrom-2008.1.conf b/conf/distro/angstrom-2008.1.conf
index e3e36d5c59..37cb8f068a 100644
--- a/conf/distro/angstrom-2008.1.conf
+++ b/conf/distro/angstrom-2008.1.conf
@@ -163,6 +163,7 @@ PREFERRED_PROVIDER_ntp ?= "ntp"
PREFERRED_PROVIDER_hotplug = "udev"
PREFERRED_PROVIDER_libxss = "libxss"
PREFERRED_PROVIDER_bluez-utils-dbus = "bluez-utils"
+PREFERRED_PROVIDER_bluez-libs = "bluez4"
# we don't ship gtk-directfb by default
PREFERRED_PROVIDER_gtk+ ?= "gtk+"
diff --git a/recipes/bluez/bluez4_4.35.bb b/recipes/bluez/bluez4_4.35.bb
index 8c86a1a574..fec1411d00 100644
--- a/recipes/bluez/bluez4_4.35.bb
+++ b/recipes/bluez/bluez4_4.35.bb
@@ -5,6 +5,11 @@ DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
HOMEPAGE = "http://www.bluez.org"
LICENSE = "GPL"
+# For angstrom we want this to replace at least bluez-libs
+PROVIDES_append_angstrom = " bluez-libs"
+
+PR = "r1"
+
SRC_URI = "\
http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
@@ -13,10 +18,8 @@ SRC_URI = "\
"
S = "${WORKDIR}/bluez-${PV}"
-inherit autotools pkgconfig
-
-OE_LT_RPATH_ALLOW = "any"
-OE_LT_RPATH_ALLOW[export] = "1"
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
EXTRA_OECONF = "\
--enable-gstreamer \
@@ -56,6 +59,7 @@ FILES_${PN}-dev += "\
${libdir}/alsa-lib/*.la \
${libdir}/gstreamer-0.10/*.la \
"
+
FILES_${PN}-dbg += "\
${libdir}/bluetooth/plugins/.debug \
${libdir}/*/.debug \