aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xcontrib/python/generate-manifest.py4
-rw-r--r--packages/python/python-2.4.3-manifest.inc4
-rw-r--r--packages/python/python_2.4.3.bb4
3 files changed, 6 insertions, 6 deletions
diff --git a/contrib/python/generate-manifest.py b/contrib/python/generate-manifest.py
index 2fd681dc01..0c0aea27c1 100755
--- a/contrib/python/generate-manifest.py
+++ b/contrib/python/generate-manifest.py
@@ -226,7 +226,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-html", "Python HTML Processing", "python-core",
"formatter.* htmlentitydefs.* htmllib.* markupbase.* sgmllib.* " )
- m.addPackage( 0, "python-gdbm", "Python GNU Database Support", "python-core, libgdbm3",
+ m.addPackage( 0, "python-gdbm", "Python GNU Database Support", "python-core",
"lib-dynload/gdbm.so" )
m.addPackage( 0, "python-image", "Python Graphical Image Handling", "python-core",
@@ -281,7 +281,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-re", "Python Regular Expression APIs", "python-core",
"re.* sre.* sre_compile.* sre_constants* sre_parse.*" ) # _sre is builtin
- m.addPackage( 0, "python-readline", "Python Readline Support", "python-core, libreadline4",
+ m.addPackage( 0, "python-readline", "Python Readline Support", "python-core",
"lib-dynload/readline.so rlcompleter.*" )
m.addPackage( 0, "python-resource", "Python Resource Control Interface", "python-core",
diff --git a/packages/python/python-2.4.3-manifest.inc b/packages/python/python-2.4.3-manifest.inc
index 1d14654f85..3a460e562a 100644
--- a/packages/python/python-2.4.3-manifest.inc
+++ b/packages/python/python-2.4.3-manifest.inc
@@ -124,7 +124,7 @@ FILES_python-tkinter="${libdir}/python2.4/lib-dynload/_tkinter.so ${libdir}/pyth
DESCRIPTION_python-gdbm="Python GNU Database Support"
PR_python-gdbm="ml0"
-RDEPENDS_python-gdbm="python-core libgdbm3"
+RDEPENDS_python-gdbm="python-core"
FILES_python-gdbm="${libdir}/python2.4/lib-dynload/gdbm.so "
DESCRIPTION_python-fcntl="Python's fcntl Interface"
@@ -164,7 +164,7 @@ FILES_python-html="${libdir}/python2.4/formatter.* ${libdir}/python2.4/htmlentit
DESCRIPTION_python-readline="Python Readline Support"
PR_python-readline="ml0"
-RDEPENDS_python-readline="python-core libreadline4"
+RDEPENDS_python-readline="python-core"
FILES_python-readline="${libdir}/python2.4/lib-dynload/readline.so ${libdir}/python2.4/rlcompleter.* "
DESCRIPTION_python-subprocess="Python Subprocess Support"
diff --git a/packages/python/python_2.4.3.bb b/packages/python/python_2.4.3.bb
index 30c4ee1aee..2af6789b7a 100644
--- a/packages/python/python_2.4.3.bb
+++ b/packages/python/python_2.4.3.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-PR = "ml5"
+PR = "ml6"
PYTHON_MAJMIN = "2.4"
@@ -68,5 +68,5 @@ require python-${PV}-manifest.inc
RPROVIDES_python-core = "python"
RPROVIDES_python-curses = "python"
PACKAGES =+ "libpython2"
-PACKAGES_DYNAMIC = "python-* libpython2"
+PACKAGES_DYNAMIC = "libpython2"
FILES_libpython2 = "${libdir}/libpython*"