aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/chinook-compat.conf8
-rw-r--r--packages/gcc/gcc-cross-initial_csl-arm-2005q3.bb2
-rw-r--r--packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb2
-rw-r--r--packages/gcc/gcc_csl-arm-2005q3.bb1
4 files changed, 7 insertions, 6 deletions
diff --git a/conf/distro/chinook-compat.conf b/conf/distro/chinook-compat.conf
index aee81f240f..e89d2185a7 100644
--- a/conf/distro/chinook-compat.conf
+++ b/conf/distro/chinook-compat.conf
@@ -59,9 +59,9 @@ PREFERRED_VERSION_automake-native = "1.9.6"
PREFERRED_VERSION_binutils = "2.17.50.0.12"
PREFERRED_VERSION_binutils-cross = "2.18"
-PREFERRED_VERSION_gcc = "3.4.4+csl-arm-2005q3"
-PREFERRED_VERSION_gcc-cross = "3.4.4+csl-arm-2005q3"
-PREFERRED_VERSION_gcc-cross-initial = "3.4.4+csl-arm-2005q3"
+PREFERRED_VERSION_gcc = "3.4.4cs2005q3.2"
+PREFERRED_VERSION_gcc-cross = "3.4.4cs2005q3.2"
+PREFERRED_VERSION_gcc-cross-initial = "3.4.4cs2005q3.2"
# Use recent enough version of the headers to let HAL build successfully.
PREFERRED_VERSION_linux-libc-headers = "2.6.20"
@@ -146,7 +146,7 @@ PREFERRED_VERSION_libsoup = "2.2.7"
PREFERRED_VERSION_libglade = "2.4.2"
PREFERRED_VERSION_gnutls = "1.4.5"
PREFERRED_VERSION_libgpg-error = "1.4"
-PREFERRED_VERSION_libgcrypt = "1.2.3"
+PREFERRED_VERSION_libgcrypt = "1.4.0"
PREFERRED_VERSION_gpe-scap = "1.3"
diff --git a/packages/gcc/gcc-cross-initial_csl-arm-2005q3.bb b/packages/gcc/gcc-cross-initial_csl-arm-2005q3.bb
index 1639511362..aff22fb694 100644
--- a/packages/gcc/gcc-cross-initial_csl-arm-2005q3.bb
+++ b/packages/gcc/gcc-cross-initial_csl-arm-2005q3.bb
@@ -1,2 +1,2 @@
-require gcc-cross_${PV}.bb
+require gcc-cross_csl-arm-2005q3.bb
require gcc-cross-initial.inc
diff --git a/packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb b/packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb
index 4b7e7b715c..d9c818979c 100644
--- a/packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb
+++ b/packages/gcc/gcc-cross-kernel-3.4.4_csl-arm-2005q3.bb
@@ -7,7 +7,7 @@ SECTION = "devel"
# cut-down gcc for kernel builds
# only installs ${TARGET_PREFIX}gcc-${PV}, not ${TARGET_PREFIX}gcc.
-require gcc-cross-initial_${PV}.bb
+require gcc-cross-initial_csl-arm-2005q3.bb
PROVIDES = "virtual/${TARGET_PREFIX}gcc-${PV}"
diff --git a/packages/gcc/gcc_csl-arm-2005q3.bb b/packages/gcc/gcc_csl-arm-2005q3.bb
index 4c8f8227a9..b90f6907bb 100644
--- a/packages/gcc/gcc_csl-arm-2005q3.bb
+++ b/packages/gcc/gcc_csl-arm-2005q3.bb
@@ -4,6 +4,7 @@ SECTION = "devel"
LICENSE = "GPL"
BINV = "3.4.4"
PV = "3.4.4+csl-arm-2005q3"
+PV_chinook-compat = "3.4.4cs2005q3.2"
PR = "r3"
FILESDIR = "${FILE_DIRNAME}/gcc-csl-arm"