aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/kernel.bbclass23
-rw-r--r--conf/distro/familiar-0.8.3.conf4
-rw-r--r--conf/machine/handheld-common.conf6
-rw-r--r--conf/machine/ipaq-common.conf6
-rw-r--r--conf/machine/ipaq-pxa270.conf3
-rw-r--r--packages/bluez/bluez-utils-dbus_2.21.bb3
-rw-r--r--packages/bluez/bluez-utils.inc5
-rw-r--r--packages/dbus/dbus_0.50.bb1
-rw-r--r--packages/dbus/dbus_0.50.inc1
-rw-r--r--packages/gpe-autostarter/gpe-autostarter_0.11.bb2
-rw-r--r--packages/gpe-beam/gpe-beam_0.2.8.bb2
-rw-r--r--packages/gpe-calendar/gpe-calendar_0.66.bb2
-rw-r--r--packages/gpe-calendar/gpe-calendar_cvs.bb1
-rw-r--r--packages/gpe-conf/gpe-conf_cvs.bb2
-rw-r--r--packages/gpe-contacts/gpe-contacts_0.42.bb6
-rw-r--r--packages/gpe-filemanager/gpe-filemanager_0.23.bb6
-rw-r--r--packages/gpe-today/gpe-today_cvs.bb1
-rw-r--r--packages/module-init-tools/module-init-tools_3.2-pre4.bb3
-rw-r--r--packages/scap/files/scap.sh2
-rw-r--r--packages/sylpheed/sylpheed_2.0.0rc.bb1
20 files changed, 37 insertions, 43 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index 5902ec1fb4..8416b8acb3 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -10,6 +10,7 @@ export CROSS_COMPILE = "${TARGET_PREFIX}"
KERNEL_IMAGETYPE = "zImage"
KERNEL_PRIORITY = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[-1]}"
+
# [jbowler 20051109] ${PV}${KERNEL_LOCALVERSION} is used throughout this
# .bbclass to (apparently) find the full 'uname -r' kernel version, this
# should be the same as UTS_RELEASE or (in this file) KERNEL_VERSION:
@@ -102,9 +103,9 @@ kernel_do_stage() {
cp -fR drivers/sound/*.h ${STAGING_KERNEL_DIR}/include/drivers/sound/
fi
- install -m 0644 .config ${STAGING_KERNEL_DIR}/config-${PV}${KERNEL_LOCALVERSION}
- ln -sf config-${PV}${KERNEL_LOCALVERSION} ${STAGING_KERNEL_DIR}/.config
- ln -sf config-${PV}${KERNEL_LOCALVERSION} ${STAGING_KERNEL_DIR}/kernel-config
+ install -m 0644 .config ${STAGING_KERNEL_DIR}/config-${KERNEL_RELEASE}
+ ln -sf config-${KERNEL_RELEASE} ${STAGING_KERNEL_DIR}/.config
+ ln -sf config-${KERNEL_RELEASE} ${STAGING_KERNEL_DIR}/kernel-config
echo "${KERNEL_VERSION}" >${STAGING_KERNEL_DIR}/kernel-abiversion
echo "${S}" >${STAGING_KERNEL_DIR}/kernel-source
echo "${KERNEL_CCSUFFIX}" >${STAGING_KERNEL_DIR}/kernel-ccsuffix
@@ -119,7 +120,7 @@ kernel_do_stage() {
fi
cp -fR include/config* ${STAGING_KERNEL_DIR}/include/
install -m 0644 ${KERNEL_OUTPUT} ${STAGING_KERNEL_DIR}/${KERNEL_IMAGETYPE}
- install -m 0644 System.map ${STAGING_KERNEL_DIR}/System.map-${PV}${KERNEL_LOCALVERSION}
+ install -m 0644 System.map ${STAGING_KERNEL_DIR}/System.map-${KERNEL_RELEASE}
[ -e Module.symvers ] && install -m 0644 Module.symvers ${STAGING_KERNEL_DIR}/
cp -fR scripts ${STAGING_KERNEL_DIR}/
@@ -135,9 +136,9 @@ kernel_do_install() {
install -d ${D}/${KERNEL_IMAGEDEST}
install -d ${D}/boot
- install -m 0644 ${KERNEL_OUTPUT} ${D}/${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}-${PV}${KERNEL_LOCALVERSION}
- install -m 0644 System.map ${D}/boot/System.map-${PV}${KERNEL_LOCALVERSION}
- install -m 0644 .config ${D}/boot/config-${PV}${KERNEL_LOCALVERSION}
+ install -m 0644 ${KERNEL_OUTPUT} ${D}/${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}-${KERNEL_RELEASE}
+ install -m 0644 System.map ${D}/boot/System.map-${KERNEL_RELEASE}
+ install -m 0644 .config ${D}/boot/config-${KERNEL_RELEASE}
install -d ${D}/etc/modutils
# Check if scripts/genksyms exists and if so, build it
@@ -153,11 +154,11 @@ kernel_do_configure() {
}
pkg_postinst_kernel () {
- update-alternatives --install /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE} ${KERNEL_IMAGETYPE} /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}-${PV}${KERNEL_LOCALVERSION} ${KERNEL_PRIORITY} || true
+ update-alternatives --install /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE} ${KERNEL_IMAGETYPE} /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}-${KERNEL_RELEASE} ${KERNEL_PRIORITY} || true
}
pkg_postrm_kernel () {
- update-alternatives --remove ${KERNEL_IMAGETYPE} /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}-${PV}${KERNEL_LOCALVERSION} || true
+ update-alternatives --remove ${KERNEL_IMAGETYPE} /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}-${KERNEL_RELEASE} || true
}
inherit cml1
@@ -175,7 +176,7 @@ ALLOW_EMPTY_kernel-image = "1"
pkg_postinst_modules () {
if [ -n "$D" ]; then
- ${HOST_PREFIX}depmod -A -b $D -F ${STAGING_KERNEL_DIR}/System.map-${PV}${KERNEL_LOCALVERSION} ${KERNEL_VERSION}
+ ${HOST_PREFIX}depmod -A -b $D -F ${STAGING_KERNEL_DIR}/System.map-${KERNEL_RELEASE} ${KERNEL_VERSION}
else
depmod -A
update-modules || true
@@ -236,7 +237,7 @@ python populate_packages_prepend () {
bb.error("D not defined")
return
- kernelver = bb.data.getVar('PV', d, 1) + bb.data.getVar('KERNEL_LOCALVERSION', d, 1)
+ kernelver = bb.data.getVar('KERNEL_RELEASE', d, 1)
kernelver_stripped = kernelver
m = re.match('^(.*-hh.*)[\.\+].*$', kernelver)
if m:
diff --git a/conf/distro/familiar-0.8.3.conf b/conf/distro/familiar-0.8.3.conf
index 5d19ca02be..53614d9291 100644
--- a/conf/distro/familiar-0.8.3.conf
+++ b/conf/distro/familiar-0.8.3.conf
@@ -4,7 +4,7 @@ DISTRO_VERSION = "v0.8.3-unofficial-unsupported-snapshot-${DATE}"
include conf/distro/familiar.conf
-#"${@bb.fatal('This file is unmaintained in the org.oe.dev branch, use the org.openembedded.oz354fam083 branch instead. You can also remove this line, but don't complain if something breaks')}"
+"${@bb.fatal('This file is unmaintained in the org.oe.dev branch, use the org.openembedded.oz354fam083 branch instead. You can also remove this line, but don't complain if something breaks')}"
@@ -52,7 +52,7 @@ PREFERRED_PROVIDERS += "virtual/xserver:xserver-kdrive"
PREFERRED_PROVIDERS += "virtual/gconf:gconf-dbus"
PREFERRED_PROVIDER_x11 = "diet-x11"
-#include conf/distro/preferred-gpe-versions-2.7.inc
+include conf/distro/preferred-gpe-versions-2.7.inc
#
# E
diff --git a/conf/machine/handheld-common.conf b/conf/machine/handheld-common.conf
index a014c2be65..dab1d01e70 100644
--- a/conf/machine/handheld-common.conf
+++ b/conf/machine/handheld-common.conf
@@ -17,8 +17,8 @@ input uinput \
"
# Configuration bits for "generic handheld"
-BOOTSTRAP_EXTRA_DEPENDS += "pcmciautils apmd ppp wireless-tools irda-utils openswan wpa-supplicant-nossl lrzsz ppp-dialin scap network-suspend-scripts"
-BOOTSTRAP_EXTRA_RDEPENDS += "pcmciautils apm apmd network-suspend-scripts"
-BOOTSTRAP_EXTRA_RRECOMMENDS += "ppp wireless-tools irda-utils openswan wpa-supplicant-nossl lrzsz ppp-dialin scap ${@linux_module_packages('${HANDHELD_MODULES}', d)}"
+BOOTSTRAP_EXTRA_DEPENDS += "pcmcia-cs apmd ppp wireless-tools irda-utils openswan wpa-supplicant-nossl lrzsz ppp-dialin network-suspend-scripts"
+BOOTSTRAP_EXTRA_RDEPENDS += "pcmcia-cs apm apmd network-suspend-scripts"
+BOOTSTRAP_EXTRA_RRECOMMENDS += "ppp wireless-tools irda-utils openswan wpa-supplicant-nossl lrzsz ppp-dialin ${@linux_module_packages('${HANDHELD_MODULES}', d)}"
INHERIT += "linux_modules"
diff --git a/conf/machine/ipaq-common.conf b/conf/machine/ipaq-common.conf
index 95ac3d73f6..791abd2103 100644
--- a/conf/machine/ipaq-common.conf
+++ b/conf/machine/ipaq-common.conf
@@ -1,8 +1,8 @@
-IPAQ_MODULES = "apm h3600_generic_sleeve ipaq-sleeve ipaq-mtd-asset nvrd sa1100-rtc ipaq-hal h3600_ts usb-eth wavelan_cs keybdev"
+IPAQ_MODULES = "apm h3600_generic_sleeve ipaq-sleeve ipaq-mtd-asset nvrd atmelwlandriver sa1100-rtc ipaq-hal h3600_ts usb-eth wavelan_cs keybdev"
-BOOTSTRAP_EXTRA_DEPENDS += "kbdd bl hostap-modules orinoco-modules"
+BOOTSTRAP_EXTRA_DEPENDS += "kbdd bl hostap-modules orinoco-modules atmelwlandriver"
BOOTSTRAP_EXTRA_DEPENDS_append_kernel24 += "mipv6"
-BOOTSTRAP_EXTRA_RRECOMMENDS += "kbdd bl hostap-modules-cs orinoco-modules-cs ${@linux_module_packages('${IPAQ_MODULES}', d)}"
+BOOTSTRAP_EXTRA_RRECOMMENDS += "kbdd bl hostap-modules-cs orinoco-modules-cs atmelwlandriver ${@linux_module_packages('${IPAQ_MODULES}', d)}"
BOOTSTRAP_EXTRA_RRECOMMENDS_append_kernel24 += "mipv6"
PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
diff --git a/conf/machine/ipaq-pxa270.conf b/conf/machine/ipaq-pxa270.conf
index d8432702c2..626b5cf218 100644
--- a/conf/machine/ipaq-pxa270.conf
+++ b/conf/machine/ipaq-pxa270.conf
@@ -30,9 +30,6 @@ GUI_MACHINE_CLASS = "bigscreen"
GPE_EXTRA_DEPENDS += "gaim"
GPE_EXTRA_INSTALL += "gaim"
-GPE_EXTRA_DEPENDS += " nano less gdb strace avahi-daemon zeroconf"
-GPE_EXTRA_INSTALL += " nano less gdb strace avahi-daemon zeroconf"
-
# Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
include conf/machine/tune-xscale.conf
diff --git a/packages/bluez/bluez-utils-dbus_2.21.bb b/packages/bluez/bluez-utils-dbus_2.21.bb
index abe6dc2656..58b2725143 100644
--- a/packages/bluez/bluez-utils-dbus_2.21.bb
+++ b/packages/bluez/bluez-utils-dbus_2.21.bb
@@ -3,6 +3,7 @@ include bluez-utils.inc
PR = "r2"
DEPENDS += "dbus"
-SRC_URI += "file://smash.patch;patch=1 \
+SRC_URI += "file://dbus.patch;patch=1 \
+ file://smash.patch;patch=1 \
file://hcid-alignment-fix.patch;patch=1"
EXTRA_OECONF += "--with-dbus"
diff --git a/packages/bluez/bluez-utils.inc b/packages/bluez/bluez-utils.inc
index a4652b17ab..07dc5d6125 100644
--- a/packages/bluez/bluez-utils.inc
+++ b/packages/bluez/bluez-utils.inc
@@ -4,13 +4,11 @@ PRIORITY = "optional"
DEPENDS = "bluez-libs-${PV} pcmcia-cs"
RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils"
LICENSE = "GPL"
-PR = "r8"
+PR = "r7"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://base.patch;patch=1 \
file://blueboxes.patch;patch=1 \
- file://hciattach-ti-bts.patch;patch=1 \
- file://TIInit_3.2.26.bts \
file://hcid.conf \
file://bluetooth.default \
file://bluetooth.conf "
@@ -42,7 +40,6 @@ do_install_append() {
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
chmod 755 ${D}${sysconfdir}/pcmcia/bluetooth
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0644 ${WORKDIR}/TIInit_3.2.26.bts ${D}${sysconfdir}/bluetooth/
install -m 0644 ${WORKDIR}/bluetooth.default ${D}${sysconfdir}/default/bluetooth
cat ${WORKDIR}/bluetooth.conf >> ${D}${sysconfdir}/pcmcia/bluetooth.conf
}
diff --git a/packages/dbus/dbus_0.50.bb b/packages/dbus/dbus_0.50.bb
index e827457371..a1d19897cc 100644
--- a/packages/dbus/dbus_0.50.bb
+++ b/packages/dbus/dbus_0.50.bb
@@ -2,6 +2,7 @@ include dbus_${PV}.inc
DEPENDS = "expat glib-2.0 virtual/libintl dbus-native"
+DEFAULT_PREFERENCE = "-1"
SRC_URI_EXTRA = "file://no-introspect.patch;patch=1 file://no-bindings.patch;patch=1"
FILES_${PN} += "${bindir}/dbus-daemon"
diff --git a/packages/dbus/dbus_0.50.inc b/packages/dbus/dbus_0.50.inc
index 70546ed5b1..094a9b68d6 100644
--- a/packages/dbus/dbus_0.50.inc
+++ b/packages/dbus/dbus_0.50.inc
@@ -4,6 +4,7 @@ HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl"
+DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
diff --git a/packages/gpe-autostarter/gpe-autostarter_0.11.bb b/packages/gpe-autostarter/gpe-autostarter_0.11.bb
index e56d91f620..555134889b 100644
--- a/packages/gpe-autostarter/gpe-autostarter_0.11.bb
+++ b/packages/gpe-autostarter/gpe-autostarter_0.11.bb
@@ -4,5 +4,3 @@ RDEPENDS = "hotplug-dbus"
LICENSE = "GPL"
inherit gpe
-
-SRC_URI += "file://dbus-new-api.patch;patch=1"
diff --git a/packages/gpe-beam/gpe-beam_0.2.8.bb b/packages/gpe-beam/gpe-beam_0.2.8.bb
index 25a6b41b15..d55cd6db60 100644
--- a/packages/gpe-beam/gpe-beam_0.2.8.bb
+++ b/packages/gpe-beam/gpe-beam_0.2.8.bb
@@ -10,5 +10,3 @@ PRIORITY = "optional"
MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
LICENSE = "GPL"
-SRC_URI += "file://dbus-new-api.patch;patch=1"
-
diff --git a/packages/gpe-calendar/gpe-calendar_0.66.bb b/packages/gpe-calendar/gpe-calendar_0.66.bb
index 154de75762..d3741787ea 100644
--- a/packages/gpe-calendar/gpe-calendar_0.66.bb
+++ b/packages/gpe-calendar/gpe-calendar_0.66.bb
@@ -5,8 +5,6 @@ MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
inherit autotools gpe
-SRC_URI += "file://dbus-new-api.patch;patch=1"
-
DEPENDS = "libeventdb libschedule libxsettings libxsettings-client libgpepimc libdisplaymigration libgpevtype"
SECTION = "gpe"
RDEPENDS = "gpe-icons"
diff --git a/packages/gpe-calendar/gpe-calendar_cvs.bb b/packages/gpe-calendar/gpe-calendar_cvs.bb
index 134ec6ca2d..df84ff9475 100644
--- a/packages/gpe-calendar/gpe-calendar_cvs.bb
+++ b/packages/gpe-calendar/gpe-calendar_cvs.bb
@@ -1,4 +1,5 @@
LICENSE = "GPL"
+DEFAULT_PREFERENCE = "-1"
S = "${WORKDIR}/${PN}"
PV = "0.65+cvs-${CVSDATE}"
diff --git a/packages/gpe-conf/gpe-conf_cvs.bb b/packages/gpe-conf/gpe-conf_cvs.bb
index 4f23ec754f..e13ac767c2 100644
--- a/packages/gpe-conf/gpe-conf_cvs.bb
+++ b/packages/gpe-conf/gpe-conf_cvs.bb
@@ -1,3 +1,5 @@
+DEFAULT_PREFERENCE = "-1"
+
S = "${WORKDIR}/${PN}"
PV = "0.1.26+cvs-${CVSDATE}"
PR = "r0"
diff --git a/packages/gpe-contacts/gpe-contacts_0.42.bb b/packages/gpe-contacts/gpe-contacts_0.42.bb
index f277348c17..32103b1867 100644
--- a/packages/gpe-contacts/gpe-contacts_0.42.bb
+++ b/packages/gpe-contacts/gpe-contacts_0.42.bb
@@ -2,14 +2,14 @@ LICENSE = "GPL"
MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
inherit gpe autotools
-PR = "r1"
+PR = "r0"
DEPENDS = "libgpewidget libgpepimc libdisplaymigration libgpevtype dbus"
SECTION = "gpe"
RDEPENDS = "gpe-icons"
DESCRIPTION = "GPE contacts manager"
-SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2 \
- file://dbus-new-api.patch;patch=1"
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2"
+
FILES_${PN} += " ${datadir}/gpe ${datadir}/gpe-contacts"
diff --git a/packages/gpe-filemanager/gpe-filemanager_0.23.bb b/packages/gpe-filemanager/gpe-filemanager_0.23.bb
index 57a8e9a6b8..2beee83596 100644
--- a/packages/gpe-filemanager/gpe-filemanager_0.23.bb
+++ b/packages/gpe-filemanager/gpe-filemanager_0.23.bb
@@ -1,14 +1,12 @@
inherit gpe
-PR = "r1"
+PR = "r0"
LICENSE = "GPL"
DESCRIPTION = "GPE file manager"
-DEPENDS = "libgpewidget gnome-vfs-dbus dbus"
+DEPENDS = "libgpewidget gnome-vfs dbus"
SECTION = "gpe"
RDEPENDS = "gpe-icons"
RRECOMMENDS = "gnome-vfs-plugin-file"
FILES_${PN} += " ${datadir}/gpe"
-
-SRC_URI += " file://dbus-new-api.patch;patch=1"
diff --git a/packages/gpe-today/gpe-today_cvs.bb b/packages/gpe-today/gpe-today_cvs.bb
index a467d7e52f..a1ed5c6707 100644
--- a/packages/gpe-today/gpe-today_cvs.bb
+++ b/packages/gpe-today/gpe-today_cvs.bb
@@ -1,3 +1,4 @@
+DEFAULT_PREFERENCE = "-1"
DESCRIPTION = "Displays a summary of appointments and tasks for the day ahead"
DEPENDS = "gtk+ libxrandr libxsettings libxsettings-client libgpewidget libdisplaymigration libeventdb libgpepimc libtododb"
diff --git a/packages/module-init-tools/module-init-tools_3.2-pre4.bb b/packages/module-init-tools/module-init-tools_3.2-pre4.bb
index 72ec9c4fb0..41aea223fe 100644
--- a/packages/module-init-tools/module-init-tools_3.2-pre4.bb
+++ b/packages/module-init-tools/module-init-tools_3.2-pre4.bb
@@ -1,10 +1,9 @@
-DEFAULT_PREFERENCE="-1"
DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
removing kernel modules for Linux (versions 2.5.48 and above). It serves \
the same function that the modutils package serves for Linux 2.4."
LICENSE = "GPL"
SECTION = "base"
-PR = "r1"
+PR = "r0"
PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
RDEPENDS_${PN} += "module-init-tools-depmod"
diff --git a/packages/scap/files/scap.sh b/packages/scap/files/scap.sh
index 6ab1735748..ba8bc7e584 100644
--- a/packages/scap/files/scap.sh
+++ b/packages/scap/files/scap.sh
@@ -6,7 +6,7 @@ if [ -x /usr/bin/bl ]; then
fi
MODEL=`cat /proc/cpuinfo | grep ^Hardware | sed "s/.* //"`
test -e /etc/scap.conf && USER=`cat /etc/scap.conf`
-RES=`/usr/sbin/fbset 2>/dev/null | awk /geometry/{print\ \\$2\"x\"\\$3}`
+RES=`fbset 2>/dev/null | awk "/geometry/ { print \$2 "x" \$3 }"`
(echo "POST /scap/capture.cgi?$MODEL+$USER+$RES HTTP/1.1"
echo -n Content-length:
cat /dev/fb0 | wc -c
diff --git a/packages/sylpheed/sylpheed_2.0.0rc.bb b/packages/sylpheed/sylpheed_2.0.0rc.bb
index ca0320bdcd..531d694f98 100644
--- a/packages/sylpheed/sylpheed_2.0.0rc.bb
+++ b/packages/sylpheed/sylpheed_2.0.0rc.bb
@@ -4,6 +4,7 @@ DEPENDS = "gtk+ gpgme gnutls"
MAINTAINER = "Patrick Steiner <patrick.steiner@a1.net>"
LICENSE = "GPL"
PR = "r3"
+DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.0beta/sylpheed-2.0.0rc.tar.bz2 \
file://sylpheed-gnutls_2.0.0rc.patch;patch=1 \