aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/nylon.conf33
-rw-r--r--conf/machine/mtx-1.conf20
-rw-r--r--hostap/hostap-modules_0.2.5.oe22
-rw-r--r--linux/linux-mtx-1_2.4.24.oe16
-rw-r--r--linux/linux-mtx-1_2.4.27.oe51
-rw-r--r--meta/nylon-feed.oe3
-rw-r--r--meta/nylon-image-base.oe26
7 files changed, 147 insertions, 24 deletions
diff --git a/conf/distro/nylon.conf b/conf/distro/nylon.conf
index e69de29bb2..b5d1268dac 100644
--- a/conf/distro/nylon.conf
+++ b/conf/distro/nylon.conf
@@ -0,0 +1,33 @@
+#@TYPE: Distribution
+#@NAME: Nylon Linux
+#@DESCRIPTION: Distribution configuration for Nylon Mesh Linux distribution
+
+# this distribution is mainly for wireless networking devices and includes
+# packages necessary for wireless LAN access point, routing, encryption and
+# especially mesh routing applications
+#
+# it is primarily aimed at the 4G Systems MeshCube (mtx-1) and other
+# mipsel based platforms
+#
+# Bruno Randolf <bruno.randolf@4g-systems.biz>
+
+INHERIT += " package_ipk debian"
+INHERIT += " linux_modules"
+
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc:gcc-cross"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}libc-for-gcc:glibc"
+
+#CVSDATE = 20040916
+
+PREFERRED_VERSION_glibc = "2.3.3"
+PREFERRED_VERSION_gcc-cross-initial = "3.3.4"
+PREFERRED_VERSION_gcc-cross = "3.3.4"
+PREFERRED_VERSION_gcc-cross-sdk = "3.3.4"
+PREFERRED_VERSION_gcc = "3.3.4"
+PREFERRED_VERSION_binutils-cross = "2.14.90.0.7"
+PREFERRED_VERSION_binutils-cross-sdk = "2.14.90.0.7"
+PREFERRED_VERSION_binutils = "2.14.90.0.7"
+
+#PREFERRED_VERSION_prism54-module = "1.2"
diff --git a/conf/machine/mtx-1.conf b/conf/machine/mtx-1.conf
index e69de29bb2..7ec6409f8b 100644
--- a/conf/machine/mtx-1.conf
+++ b/conf/machine/mtx-1.conf
@@ -0,0 +1,20 @@
+#@TYPE: Machine
+#@NAME: 4G Systems mtx-1
+#@DESCRIPTION: Machine configuration for the mtx-1 (aka MeshCube)
+
+TARGET_ARCH = "mipsel"
+IPKG_ARCHS = "all mipsel ${MACHINE}"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-1"
+PREFERRED_VERSION_linux-mtx-1 = "2.4.24"
+
+EXTRA_IMAGECMD_jffs2 = "--pad=0x1c00000 --little-endian --eraseblock=0x20000 -n"
+
+# does not gain any speed and just creates problems:
+# TARGET_CC_ARCH = "-march=mips32"
+
+USE_DEVFS = "1"
+USE_VT = "0"
+SERIAL_CONSOLE = "115200 tts/0 vt100"
+
+BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-usb-storage kernel-module-scsi-mod kernel-module-sd-mod kernel-module-usbnet kernel-module-mii" \ No newline at end of file
diff --git a/hostap/hostap-modules_0.2.5.oe b/hostap/hostap-modules_0.2.5.oe
index 452e43a928..bbb3850076 100644
--- a/hostap/hostap-modules_0.2.5.oe
+++ b/hostap/hostap-modules_0.2.5.oe
@@ -15,8 +15,6 @@ S = "${WORKDIR}/hostap-driver-${PV}"
inherit module
-# Hack Alert :D
-ARCH_mipsel = "mips"
EXTRA_OEMAKE = "EXTRA_CFLAGS='-DPRISM2_NON_VOLATILE_DOWNLOAD'"
NET_MODULES = "hostap.o hostap_pci.o hostap_crypt_ccmp.o hostap_crypt_tkip.o hostap_crypt_wep.o"
@@ -32,11 +30,29 @@ do_install() {
install -m 0644 driver/modules/hostap_cs.o ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+
+ if [ "${MACHINE}" = "mtx-1" ]; then
+ install -d ${D}/etc/modutils
+ echo "hostap_pci" > ${D}/etc/modutils/hostap
+ fi
+}
+
+pkg_postinst_hostap-modules-pci() {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+update-modules || true
+}
+
+pkg_postrm_hostap-modules-pci() {
+#!/bin/sh
+update-modules || true
}
PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
-FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci.o"
+FILES_hostap-modules-pci = "/etc/modutils /lib/modules/${KERNEL_VERSION}/net/hostap_pci.o"
FILES_hostap-modules = "/lib/modules/"
RDEPENDS_hostap-modules-cs = "hostap-modules"
RDEPENDS_hostap-modules-pci = "hostap-modules"
diff --git a/linux/linux-mtx-1_2.4.24.oe b/linux/linux-mtx-1_2.4.24.oe
index 612635c105..14148393e8 100644
--- a/linux/linux-mtx-1_2.4.24.oe
+++ b/linux/linux-mtx-1_2.4.24.oe
@@ -2,11 +2,11 @@ SECTION = "kernel"
DESCRIPTION = "Linux kernel for MTX-1 (MeshCube)"
MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
LICENSE = "GPL"
-KV = "2.4.24"
-PV = "${KV}"
+KV = "${PV}"
PACKAGE_ARCH = "mtx-1"
RDEPENDS = "mtd"
+CVSDATE = "20041016"
SRC_URI = "cvs://anoncvs:anoncvs@meshcube.org/data/cvs;module=kernel/linux"
S = "${WORKDIR}/linux"
@@ -15,7 +15,7 @@ inherit kernel
ARCH = "mips"
KERNEL_OUTPUT = "arch/mips/zboot/images/mtx-1.flash.bin"
-KERNEL_IMAGETYPE = "zImage.flash.bin"
+KERNEL_IMAGETYPE = "zImage.flash"
KERNEL_IMAGEDEST = "tmp"
do_configure_prepend() {
@@ -26,9 +26,11 @@ pkg_postinst_kernel() {
if test "x$D" != "x"; then
exit 1
else
- echo "*** flashing kernel ***"
- flashcp -v /tmp/zImage.flash.bin-${KV} /dev/mtd/2
- echo "*** done. please reboot ***"
+ if test -e /tmp/zImage.flash.bin-${KV}; then
+ echo "*** flashing kernel ***"
+ flashcp -v /tmp/zImage.flash.bin-${KV} /dev/mtd/2
+ echo "*** done. please reboot ***"
+ fi
fi
}
@@ -36,7 +38,7 @@ FILES_kernel += " /tmp"
do_deploy() {
install -d ${DEPLOY_DIR}/images
- install -m 0644 ${KERNEL_OUTPUT} ${DEPLOY_DIR}/images/${MACHINE}-${KV}-${KERNEL_IMAGETYPE}-${DATETIME}
+ install -m 0644 arch/mips/zboot/images/mtx-1.flash.srec ${DEPLOY_DIR}/images/${MACHINE}-${KV}-${DATETIME}.srec
}
do_deploy[dirs] = "${S}"
diff --git a/linux/linux-mtx-1_2.4.27.oe b/linux/linux-mtx-1_2.4.27.oe
index e69de29bb2..52ba6eea97 100644
--- a/linux/linux-mtx-1_2.4.27.oe
+++ b/linux/linux-mtx-1_2.4.27.oe
@@ -0,0 +1,51 @@
+DESCRIPTION = "Linux kernel for MTX-1 (MeshCube)"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPL"
+KV = "${PV}"
+PACKAGE_ARCH = "mtx-1"
+RDEPENDS = "mtd"
+
+SRC_URI = "cvs://cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4 \
+ ftp://ftp.linux-mips.org/pub/linux/mips/people/ppopov/2.4/zboot-2.4.26.patch;patch=1 \
+ ftp://ftp.linux-mips.org/pub/linux/mips/people/ppopov/2.4/usb-nonpci-2.4.24.patch;patch=1 \
+ file://mtx-1-board-reset.diff;patch=1 \
+ file://zimage-flash-bin.patch;patch=1 \
+ file://defconfig-mtx-1"
+
+S = "${WORKDIR}/linux"
+
+BROKEN = "1"
+inherit kernel
+
+ARCH = "mips"
+KERNEL_OUTPUT = "arch/mips/zboot/images/mtx-1.flash.bin"
+KERNEL_IMAGETYPE = "zImage.flash"
+KERNEL_IMAGEDEST = "tmp"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig-mtx-1 ${S}/.config
+}
+
+pkg_postinst_kernel() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ if test -e /tmp/zImage.flash.bin-${KV}; then
+ echo "*** flashing kernel ***"
+ flashcp -v /tmp/zImage.flash.bin-${KV} /dev/mtd/2
+ echo "*** done. please reboot ***"
+ fi
+fi
+}
+
+FILES_kernel += " /tmp"
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 arch/mips/zboot/images/mtx-1.flash.bin ${DEPLOY_DIR}/images/${MACHINE}-${KV}-${DATETIME}.bin
+ install -m 0644 arch/mips/zboot/images/mtx-1.flash.srec ${DEPLOY_DIR}/images/${MACHINE}-${KV}-${DATETIME}.srec
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile \ No newline at end of file
diff --git a/meta/nylon-feed.oe b/meta/nylon-feed.oe
index e394e57e92..398bef60a9 100644
--- a/meta/nylon-feed.oe
+++ b/meta/nylon-feed.oe
@@ -7,6 +7,7 @@ db3 \
ddclient \
dhcp-forwarder \
dhcp \
+dnsmasq \
expat \
gdb \
glib-2.0 \
@@ -65,7 +66,6 @@ zlib \
"
# TODO:
-# linux arch/mips/Makefile: mipsel-linux-
# ksymoops / binutils
# strace: SYS_read?
# gdb-cross: install paths, sdk?
@@ -77,7 +77,6 @@ zlib \
# mrtg
# ipac-ng
# dyndns: http://ez-ipupdate.com/
-# tinc: MTU patch
# pptp
# egrep -i Pattern matched against "$Section $Package-Name"
diff --git a/meta/nylon-image-base.oe b/meta/nylon-image-base.oe
index 87e7f8ef6e..708e211d77 100644
--- a/meta/nylon-image-base.oe
+++ b/meta/nylon-image-base.oe
@@ -1,18 +1,22 @@
export IMAGE_BASENAME = "nylon-base"
-NYLON_COMMON = "base-files base-passwd bash busybox \
+NYLON_COMMON = "base-files base-passwd bash busybox bridge-utils \
+ dnsmasq \
hostap-utils \
- ipkg initscripts iproute2 \
- modutils modutils-initscripts \
- mtd netbase nylon-scripts openssh sysvinit tinylogin wireless-tools"
+ ipkg initscripts iproute2 iptables \
+ less \
+ mobilemesh modutils modutils-initscripts mtd \
+ nano ncurses netbase nylon-scripts \
+ openssh openvpn ppp rp-pppoe \
+ shorewall sysvinit \
+ tcpdump tinylogin \
+ wireless-tools"
-#update-modules
-
-DEPENDS = "virtual/kernel hostap-modules \
+DEPENDS = "virtual/kernel hostap-modules ntp \
${NYLON_COMMON} ${BOOTSTRAP_EXTRA_DEPENDS}"
-RDEPENDS = "kernel kernel-module-tun modutils-depmod modutils-modinfo ncurses-terminfo \
- hostap-modules-pci \
+RDEPENDS = "kernel modutils-depmod modutils-modinfo \
+ ncurses-terminfo ntpdate hostap-modules-pci \
${NYLON_COMMON} ${BOOTSTRAP_EXTRA_RDEPENDS}"
export IPKG_INSTALL = "${RDEPENDS}"
@@ -21,6 +25,4 @@ IMAGE_LINGUAS = ""
inherit image_ipk
-ROOTFS_POSTPROCESS_COMMAND = "rm -f ${IMAGE_ROOTFS}/tmp/zImage*"
-
-export FEED_URIS="nylon##http://192.168.0.5/feed/unstable" \ No newline at end of file
+ROOTFS_POSTPROCESS_COMMAND = "rm -f ${IMAGE_ROOTFS}/tmp/zImage*" \ No newline at end of file