aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/vorbis-tools/vorbis-tools-1.0.1/remove-deprecated-curl-option.patch13
-rw-r--r--packages/vorbis-tools/vorbis-tools_1.0.1.bb11
2 files changed, 19 insertions, 5 deletions
diff --git a/packages/vorbis-tools/vorbis-tools-1.0.1/remove-deprecated-curl-option.patch b/packages/vorbis-tools/vorbis-tools-1.0.1/remove-deprecated-curl-option.patch
new file mode 100644
index 0000000000..6261ac175c
--- /dev/null
+++ b/packages/vorbis-tools/vorbis-tools-1.0.1/remove-deprecated-curl-option.patch
@@ -0,0 +1,13 @@
+Index: vorbis-tools-1.0.1/ogg123/http_transport.c
+===================================================================
+--- vorbis-tools-1.0.1.orig/ogg123/http_transport.c
++++ vorbis-tools-1.0.1/ogg123/http_transport.c
+@@ -113,7 +113,7 @@ void set_curl_opts (http_private_t *priv
+ if (inputOpts.ProxyTunnel)
+ curl_easy_setopt (handle, CURLOPT_HTTPPROXYTUNNEL, inputOpts.ProxyTunnel);
+ */
+- curl_easy_setopt(handle, CURLOPT_MUTE, 1);
++ /* curl_easy_setopt(handle, CURLOPT_MUTE, 1); */
+ curl_easy_setopt(handle, CURLOPT_ERRORBUFFER, private->error);
+ curl_easy_setopt(handle, CURLOPT_PROGRESSFUNCTION, progress_callback);
+ curl_easy_setopt(handle, CURLOPT_PROGRESSDATA, private);
diff --git a/packages/vorbis-tools/vorbis-tools_1.0.1.bb b/packages/vorbis-tools/vorbis-tools_1.0.1.bb
index 7b8a75dd3b..9991156dcd 100644
--- a/packages/vorbis-tools/vorbis-tools_1.0.1.bb
+++ b/packages/vorbis-tools/vorbis-tools_1.0.1.bb
@@ -1,13 +1,14 @@
-LICENSE = "GPL"
-DEPENDS = "libogg libvorbis libao curl"
-DESCRIPTION = " vorbis-tools contains oggenc (an encoder), ogg123 (a playback tool), \
+DESCRIPTION = "vorbis-tools contains oggenc (an encoder), ogg123 (a playback tool), \
ogginfo (displays ogg information), vcut (ogg file splitter), and \
vorbiscomment (ogg comment editor)."
-
+LICENSE = "GPL"
+DEPENDS = "libogg libvorbis libao curl"
SECTION = "console/multimedia"
+PR = "r1"
SRC_URI = "http://www.vorbis.com/files/${PV}/unix/vorbis-tools-${PV}.tar.gz \
- file://m4.patch;patch=1"
+ file://m4.patch;patch=1 \
+ file://remove-deprecated-curl-option.patch;patch=1"
inherit autotools