aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/hdparm/hdparm-5.4/.mtn2git_empty0
-rw-r--r--packages/hdparm/hdparm-5.4/bswap.patch32
-rw-r--r--packages/hdparm/hdparm-5.4/readahead.patch32
-rw-r--r--packages/hdparm/hdparm-5.8/.mtn2git_empty0
-rw-r--r--packages/hdparm/hdparm-5.8/bswap.patch36
-rw-r--r--packages/hdparm/hdparm-5.8/readahead.patch32
-rw-r--r--packages/hdparm/hdparm-5.8/uclibc.patch32
-rw-r--r--packages/hdparm/hdparm_5.4.bb15
-rw-r--r--packages/hdparm/hdparm_5.8.bb14
9 files changed, 0 insertions, 193 deletions
diff --git a/packages/hdparm/hdparm-5.4/.mtn2git_empty b/packages/hdparm/hdparm-5.4/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/hdparm/hdparm-5.4/.mtn2git_empty
+++ /dev/null
diff --git a/packages/hdparm/hdparm-5.4/bswap.patch b/packages/hdparm/hdparm-5.4/bswap.patch
deleted file mode 100644
index 13670073a4..0000000000
--- a/packages/hdparm/hdparm-5.4/bswap.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur hdparm-5.4/hdparm.c hdparm-5.4-fix/hdparm.c
---- hdparm-5.4/hdparm.c 2004-07-14 01:29:30.000000000 +0200
-+++ hdparm-5.4-fix/hdparm.c 2004-07-14 01:28:31.000000000 +0200
-@@ -20,7 +20,9 @@
- #include <linux/types.h>
- #include <linux/hdreg.h>
- #include <linux/major.h>
--#include <asm/byteorder.h>
-+#include <byteswap.h>
-+
-+#define le16_to_cpus(x) bswap_16(htons(x))
-
- #include "hdparm.h"
-
-@@ -1299,7 +1301,7 @@
- }
- }
- for(i=0; i<(sizeof args)/2; i+=2) {
-- __le16_to_cpus((__u16 *)(&args[i]));
-+ le16_to_cpus(*(__u16 *)(&args[i]));
- }
- identify((void *)&args[4], NULL);
- identify_abort: ;
-@@ -1499,7 +1501,7 @@
- }
- for (i = 0; count >= 4; ++i) {
- sbuf[i] = (fromhex(b[0]) << 12) | (fromhex(b[1]) << 8) | (fromhex(b[2]) << 4) | fromhex(b[3]);
-- __le16_to_cpus((__u16 *)(&sbuf[i]));
-+ le16_to_cpus((__u16 *)(&sbuf[i]));
- b += 5;
- count -= 5;
- }
diff --git a/packages/hdparm/hdparm-5.4/readahead.patch b/packages/hdparm/hdparm-5.4/readahead.patch
deleted file mode 100644
index 2868d940d0..0000000000
--- a/packages/hdparm/hdparm-5.4/readahead.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur hdparm-5.4/hdparm.c hdparm-5.4-fix/hdparm.c
---- hdparm-5.4/hdparm.c 2004-07-14 00:36:03.000000000 +0200
-+++ hdparm-5.4-fix/hdparm.c 2003-04-18 22:29:38.000000000 +0200
-@@ -52,7 +52,7 @@
- static int flagcount = 0, do_flush = 0, is_scsi_hd = 0, is_xt_hd = 0;
- static int do_ctimings, do_timings = 0;
-
--static unsigned long set_readahead= 0, get_readahead= 0, readahead= 0;
-+static unsigned long set_readahead= 0, get_readahead= 0, readahead_state= 0;
- static unsigned long set_readonly = 0, get_readonly = 0, readonly = 0;
- static unsigned long set_unmask = 0, get_unmask = 0, unmask = 0;
- static unsigned long set_mult = 0, get_mult = 0, mult = 0;
-@@ -785,8 +785,8 @@
-
- if (set_readahead) {
- if (get_readahead)
-- printf(" setting fs readahead to %ld\n", readahead);
-- if (ioctl(fd, BLKRASET, readahead))
-+ printf(" setting fs readahead to %ld\n", readahead_state);
-+ if (ioctl(fd, BLKRASET, readahead_state))
- perror(" BLKRASET failed");
- }
- #ifdef HDIO_UNREGISTER_HWIF
-@@ -1830,7 +1830,7 @@
- case 'a':
- get_readahead = noisy;
- noisy = 1;
-- GET_NUMBER(set_readahead,readahead);
-+ GET_NUMBER(set_readahead,readahead_state);
- break;
- case 'B':
- get_apmmode = noisy;
diff --git a/packages/hdparm/hdparm-5.8/.mtn2git_empty b/packages/hdparm/hdparm-5.8/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/hdparm/hdparm-5.8/.mtn2git_empty
+++ /dev/null
diff --git a/packages/hdparm/hdparm-5.8/bswap.patch b/packages/hdparm/hdparm-5.8/bswap.patch
deleted file mode 100644
index 37fbcb7b38..0000000000
--- a/packages/hdparm/hdparm-5.8/bswap.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- hdparm-5.8/hdparm.c~bswap
-+++ hdparm-5.8/hdparm.c
-@@ -20,7 +20,9 @@
- #include <linux/types.h>
- #include <linux/hdreg.h>
- #include <linux/major.h>
--#include <asm/byteorder.h>
-+#include <byteswap.h>
-+
-+#define le16_to_cpus(x) bswap_16(htons(x))
-
- #include "hdparm.h"
-
-@@ -1160,7 +1162,7 @@
- }
- } else {
- for(i = 0; i < 0x100; ++i) {
-- __le16_to_cpus(&id[i]);
-+ le16_to_cpus(&id[i]);
- }
- identify((void *)id, NULL);
- }
-@@ -1380,7 +1382,7 @@
- }
- for (i = 0; count >= 4; ++i) {
- sbuf[i] = (fromhex(b[0]) << 12) | (fromhex(b[1]) << 8) | (fromhex(b[2]) << 4) | fromhex(b[3]);
-- __le16_to_cpus((__u16 *)(&sbuf[i]));
-+ le16_to_cpus((__u16 *)(&sbuf[i]));
- b += 5;
- count -= 5;
- }
diff --git a/packages/hdparm/hdparm-5.8/readahead.patch b/packages/hdparm/hdparm-5.8/readahead.patch
deleted file mode 100644
index 2868d940d0..0000000000
--- a/packages/hdparm/hdparm-5.8/readahead.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur hdparm-5.4/hdparm.c hdparm-5.4-fix/hdparm.c
---- hdparm-5.4/hdparm.c 2004-07-14 00:36:03.000000000 +0200
-+++ hdparm-5.4-fix/hdparm.c 2003-04-18 22:29:38.000000000 +0200
-@@ -52,7 +52,7 @@
- static int flagcount = 0, do_flush = 0, is_scsi_hd = 0, is_xt_hd = 0;
- static int do_ctimings, do_timings = 0;
-
--static unsigned long set_readahead= 0, get_readahead= 0, readahead= 0;
-+static unsigned long set_readahead= 0, get_readahead= 0, readahead_state= 0;
- static unsigned long set_readonly = 0, get_readonly = 0, readonly = 0;
- static unsigned long set_unmask = 0, get_unmask = 0, unmask = 0;
- static unsigned long set_mult = 0, get_mult = 0, mult = 0;
-@@ -785,8 +785,8 @@
-
- if (set_readahead) {
- if (get_readahead)
-- printf(" setting fs readahead to %ld\n", readahead);
-- if (ioctl(fd, BLKRASET, readahead))
-+ printf(" setting fs readahead to %ld\n", readahead_state);
-+ if (ioctl(fd, BLKRASET, readahead_state))
- perror(" BLKRASET failed");
- }
- #ifdef HDIO_UNREGISTER_HWIF
-@@ -1830,7 +1830,7 @@
- case 'a':
- get_readahead = noisy;
- noisy = 1;
-- GET_NUMBER(set_readahead,readahead);
-+ GET_NUMBER(set_readahead,readahead_state);
- break;
- case 'B':
- get_apmmode = noisy;
diff --git a/packages/hdparm/hdparm-5.8/uclibc.patch b/packages/hdparm/hdparm-5.8/uclibc.patch
deleted file mode 100644
index 495d7491bb..0000000000
--- a/packages/hdparm/hdparm-5.8/uclibc.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- hdparm-5.8/hdparm.c.ark 2005-05-22 19:48:34.000000000 +0000
-+++ hdparm-5.8/hdparm.c 2005-05-22 19:52:18.000000000 +0000
-@@ -17,7 +17,9 @@
- #include <sys/times.h>
- #include <sys/types.h>
- #include <sys/mount.h>
-+#ifndef __UCLIBC__
- #include <linux/types.h>
-+#endif
- #include <linux/hdreg.h>
- #include <linux/major.h>
- #include <byteswap.h>
---- hdparm-5.8/hdparm.h.ark 2005-05-22 19:51:49.000000000 +0000
-+++ hdparm-5.8/hdparm.h 2005-05-22 19:54:54.000000000 +0000
-@@ -1,6 +1,6 @@
- /* Some prototypes for extern functions. */
-
--#include <linux/types.h> /* for __u16 */
-+#include <stdint.h>
-
- #if !defined(__GNUC__) && !defined(__attribute__)
- #define __attribute__(x) /* if not using GCC, turn off the __attribute__
-@@ -11,7 +11,7 @@
- others, though, were declared in hdparm.c with global scope; since other
- functions in that file have static (file) scope, I assume the difference is
- intentional. */
--extern void identify (__u16 *id_supplied, const char *devname);
-+extern void identify (uint16_t *id_supplied, const char *devname);
-
- extern void usage_error(int out) __attribute__((noreturn));
- extern int main(int argc, char **argv) __attribute__((noreturn));
-
diff --git a/packages/hdparm/hdparm_5.4.bb b/packages/hdparm/hdparm_5.4.bb
deleted file mode 100644
index 21b5bd5d4d..0000000000
--- a/packages/hdparm/hdparm_5.4.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "hdparm is a Linux shell utility for viewing \
-and manipulating various IDE drive and driver parameters."
-SECTION = "console/utils"
-PRIORITY = "optional"
-LICENSE = "BSD"
-PR = "r1"
-
-SRC_URI = "http://www.ibiblio.org/pub/Linux/system/hardware/hdparm-${PV}.tar.gz \
- file://bswap.patch;patch=1 \
- file://readahead.patch;patch=1"
-
-do_install () {
- install -d ${D}${sbindir} ${D}${mandir}/man8
- oe_runmake 'DESTDIR=${D}' install
-}
diff --git a/packages/hdparm/hdparm_5.8.bb b/packages/hdparm/hdparm_5.8.bb
deleted file mode 100644
index a917289513..0000000000
--- a/packages/hdparm/hdparm_5.8.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "hdparm is a Linux shell utility for viewing \
-and manipulating various IDE drive and driver parameters."
-SECTION = "console/utils"
-PRIORITY = "optional"
-LICENSE = "BSD"
-
-SRC_URI = "http://www.ibiblio.org/pub/Linux/system/hardware/hdparm-${PV}.tar.gz \
- file://bswap.patch;patch=1 \
- file://uclibc.patch;patch=1"
-
-do_install () {
- install -d ${D}/${sbindir} ${D}/${mandir}/man8
- oe_runmake 'DESTDIR=${D}' install
-}