aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/fuse/.mtn2git_empty0
-rw-r--r--packages/fuse/fuse_2.4.2.bb23
2 files changed, 23 insertions, 0 deletions
diff --git a/packages/fuse/.mtn2git_empty b/packages/fuse/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fuse/.mtn2git_empty
diff --git a/packages/fuse/fuse_2.4.2.bb b/packages/fuse/fuse_2.4.2.bb
new file mode 100644
index 0000000000..a52578b550
--- /dev/null
+++ b/packages/fuse/fuse_2.4.2.bb
@@ -0,0 +1,23 @@
+HOMEPAGE = "http://fuse.sf.net"
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+LICENSE_${PN} = "LGPL
+
+DEPENDS = "fakeroot-native"
+RRECOMMEND_${PN} = "fuse-module"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/fuse/${P}.tar.gz"
+
+inherit autotools pkgconfig
+EXTRA_OECONF = " --disable-kernel-module"
+
+fakeroot do_install() {
+oe_runmake install DESTDIR=${D}
+}
+
+fakeroot do_stage() {
+autotools_stage_all
+}
+
+