aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/update-rc.d.bbclass2
-rw-r--r--packages/altboot/altboot_cvs.bb0
-rw-r--r--packages/altboot/files_collie/altboot.cfg0
-rw-r--r--packages/bison/bison-native_2.0.bb19
-rw-r--r--packages/busybox/busybox-1.00/defconfig1
-rw-r--r--packages/busybox/busybox-1.00/dhcp-hostname.patch0
-rw-r--r--packages/busybox/busybox_1.00.bb13
-rw-r--r--packages/busybox/files/busybox-httpd44
-rw-r--r--packages/linux-hotplug/linux-hotplug-20040920/usbrc-busybox.patch0
-rw-r--r--packages/linux-hotplug/linux-hotplug_20040920.bb3
-rw-r--r--packages/qpf-fonts/qpf-dejavu.inc20
11 files changed, 96 insertions, 6 deletions
diff --git a/classes/update-rc.d.bbclass b/classes/update-rc.d.bbclass
index c3ee89dfb9..5f256b28af 100644
--- a/classes/update-rc.d.bbclass
+++ b/classes/update-rc.d.bbclass
@@ -1,6 +1,8 @@
DEPENDS_append = " update-rc.d"
RDEPENDS_append = " update-rc.d"
+INITSCRIPT_PARAMS ?= "defaults"
+
INIT_D_DIR = "${sysconfdir}/init.d"
updatercd_postinst() {
diff --git a/packages/altboot/altboot_cvs.bb b/packages/altboot/altboot_cvs.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/altboot/altboot_cvs.bb
diff --git a/packages/altboot/files_collie/altboot.cfg b/packages/altboot/files_collie/altboot.cfg
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/altboot/files_collie/altboot.cfg
diff --git a/packages/bison/bison-native_2.0.bb b/packages/bison/bison-native_2.0.bb
index e69de29bb2..624ece4b50 100644
--- a/packages/bison/bison-native_2.0.bb
+++ b/packages/bison/bison-native_2.0.bb
@@ -0,0 +1,19 @@
+include bison_${PV}.bb
+SECTION = "devel"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/bison-${PV}"
+S = "${WORKDIR}/bison-${PV}"
+PR = "r1"
+
+inherit native autotools
+
+do_stage() {
+ install -m 0755 src/bison ${STAGING_BINDIR}/
+ cat >${STAGING_BINDIR}/yacc <<EOF
+#!/bin/sh
+exec ${STAGING_BINDIR}/bison -y "\$@"
+EOF
+ chmod a+rx ${STAGING_BINDIR}/yacc
+ install -d ${STAGING_BINDIR}/../share/bison/m4sugar
+ install -m 0755 data/c.m4 data/glr.c data/lalr1.cc data/yacc.c ${STAGING_BINDIR}/../share/bison/
+ install -m 0755 data/m4sugar/m4sugar.m4 ${STAGING_BINDIR}/../share/bison/m4sugar/
+}
diff --git a/packages/busybox/busybox-1.00/defconfig b/packages/busybox/busybox-1.00/defconfig
index 3b2f214c22..164ecec914 100644
--- a/packages/busybox/busybox-1.00/defconfig
+++ b/packages/busybox/busybox-1.00/defconfig
@@ -193,6 +193,7 @@ CONFIG_RESET=y
CONFIG_MKTEMP=y
# CONFIG_PIPE_PROGRESS is not set
CONFIG_READLINK=y
+CONFIG_FEATURE_READLINK_FOLLOW=y
CONFIG_RUN_PARTS=y
CONFIG_START_STOP_DAEMON=y
CONFIG_WHICH=y
diff --git a/packages/busybox/busybox-1.00/dhcp-hostname.patch b/packages/busybox/busybox-1.00/dhcp-hostname.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/busybox/busybox-1.00/dhcp-hostname.patch
diff --git a/packages/busybox/busybox_1.00.bb b/packages/busybox/busybox_1.00.bb
index 8554b95bd9..6d26dfa014 100644
--- a/packages/busybox/busybox_1.00.bb
+++ b/packages/busybox/busybox_1.00.bb
@@ -10,7 +10,7 @@ HOMEPAGE = "http://www.busybox.net"
LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
-PR = "r21"
+PR = "r23"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://add-getkey-applet.patch;patch=1 \
@@ -26,6 +26,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://fbset.patch;patch=1 \
file://mount-all-type.patch;patch=1 \
file://celf-ash-builtins.patch;patch=1 \
+ file://dhcp-hostname.patch;patch=1 \
file://defconfig \
file://busybox-cron \
file://busybox-httpd \
@@ -41,14 +42,16 @@ S = "${WORKDIR}/busybox-${PV}"
export EXTRA_CFLAGS = "${CFLAGS}"
EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
-PACKAGES =+ "${PN}-httpd"
+PACKAGES =+ "${PN}-httpd ${PN}-udhcpd"
FILES_${PN}-httpd = "${sysconfdir}/init.d/busybox-httpd /srv/www"
+FILES_${PN}-udhcpd = "${sysconfdir}/init.d/busybox-udhcpd"
FILES_${PN} += " ${datadir}/udhcpc"
-INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd"
+INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd ${PN}-udhcpd"
INITSCRIPT_NAME_${PN}-httpd = "busybox-httpd"
+INITSCRIPT_NAME_${PN}-udhcpd = "busybox-udhcpd"
INITSCRIPT_NAME_${PN} = "syslog"
inherit cml1 update-rc.d
@@ -93,12 +96,12 @@ do_install () {
install -m 0755 ${WORKDIR}/umount.busybox ${D}${base_bindir}/
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
update-alternatives --install /bin/mount mount /bin/mount.busybox 50
update-alternatives --install /bin/umount umount /bin/umount.busybox 50
}
-pkg_prerm () {
+pkg_prerm_${PN} () {
update-alternatives --remove mount /bin/mount.busybox
update-alternatives --remove umount /bin/umount.busybox
}
diff --git a/packages/busybox/files/busybox-httpd b/packages/busybox/files/busybox-httpd
index e69de29bb2..c8348e54a7 100644
--- a/packages/busybox/files/busybox-httpd
+++ b/packages/busybox/files/busybox-httpd
@@ -0,0 +1,44 @@
+#!/bin/sh
+DAEMON=/usr/sbin/httpd
+NAME=httpd
+DESC="Busybox HTTP Daemon"
+HTTPROOT="/srv/www"
+ARGS="-h $HTTPROOT"
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "starting $DESC: $NAME... "
+ if [ ! -d $HTTPROOT ]; then
+ echo "$HTTPROOT is missing."
+ exit 1
+ fi
+ start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS
+ echo "done."
+ ;;
+ stop)
+ echo -n "stopping $DESC: $NAME... "
+ start-stop-daemon -K -n $NAME
+ echo "done."
+ ;;
+ restart)
+ echo "restarting $DESC: $NAME... "
+ $0 stop
+ $0 start
+ echo "done."
+ ;;
+ reload)
+ echo -n "reloading $DESC: $NAME... "
+ killall -HUP $(basename ${DAEMON})
+ echo "done."
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/linux-hotplug/linux-hotplug-20040920/usbrc-busybox.patch b/packages/linux-hotplug/linux-hotplug-20040920/usbrc-busybox.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/linux-hotplug/linux-hotplug-20040920/usbrc-busybox.patch
diff --git a/packages/linux-hotplug/linux-hotplug_20040920.bb b/packages/linux-hotplug/linux-hotplug_20040920.bb
index dca0ba0c1f..9edb548939 100644
--- a/packages/linux-hotplug/linux-hotplug_20040920.bb
+++ b/packages/linux-hotplug/linux-hotplug_20040920.bb
@@ -7,12 +7,13 @@ RPROVIDES = "hotplug"
RCONFLICTS = "hotplug"
RREPLACES = "hotplug"
SECTION = "base"
-PR = "r2"
+PR = "r3"
RSUGGESTS = "pciutils usbutils"
SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-2004_09_20.tar.gz \
file://userspecified_hcd.patch;patch=1 \
file://hotplug-net-agent-usb.patch;patch=1 \
+ file://usbrc-busybox.patch;patch=1 \
file://fix-net.agent \
file://update-usb.usermap \
file://logcheck-ignore \
diff --git a/packages/qpf-fonts/qpf-dejavu.inc b/packages/qpf-fonts/qpf-dejavu.inc
index e69de29bb2..3db82c9c14 100644
--- a/packages/qpf-fonts/qpf-dejavu.inc
+++ b/packages/qpf-fonts/qpf-dejavu.inc
@@ -0,0 +1,20 @@
+SECTION = "opie/fonts"
+PRIORITY = "optional"
+MAINTAINER = "Marcin Juszkiewicz <openembedded@hrw.one.pl>"
+LICENSE = "Bitstream Vera"
+HOMEPAGE = "http://dejavu.sourceforge.net/wiki/index.php/Main_Page"
+PACKAGE_ARCH = "all"
+PR = "r1"
+
+SRC_URI = "http://www.hrw.one.pl/_pliki/oe/files/${PN}-${PV}-${PR}.tar.bz2"
+
+S = "${WORKDIR}/${PN}"
+
+do_install () {
+ install -d ${D}${palmqtdir}/lib/fonts/
+ for i in *.qpf; do
+ install -m 644 $i ${D}${palmqtdir}/lib/fonts/${i}
+ done
+}
+
+inherit qpf