aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/proftpd/files/proftpd-install-nostrip.patch13
-rw-r--r--recipes/proftpd/proftpd_1.3.3c.bb33
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes/proftpd/files/proftpd-install-nostrip.patch b/recipes/proftpd/files/proftpd-install-nostrip.patch
new file mode 100644
index 0000000000..8dbcfc0f47
--- /dev/null
+++ b/recipes/proftpd/files/proftpd-install-nostrip.patch
@@ -0,0 +1,13 @@
+--- a/Make.rules.in~ 2010-11-22 13:37:25.000000000 +0100
++++ b/Make.rules.in 2010-11-22 13:38:55.100022169 +0100
+@@ -28,8 +28,8 @@
+ INSTALL=@INSTALL@
+ INSTALL_USER=@install_user@
+ INSTALL_GROUP=@install_group@
+-INSTALL_BIN=$(INSTALL) @INSTALL_STRIP@ -m 0755
+-INSTALL_SBIN=$(INSTALL) @INSTALL_STRIP@ -m 0755
++INSTALL_BIN=$(INSTALL) -m 0755
++INSTALL_SBIN=$(INSTALL) -m 0755
+ INSTALL_MAN=$(INSTALL) -m 0644
+
+ RM=rm -f
diff --git a/recipes/proftpd/proftpd_1.3.3c.bb b/recipes/proftpd/proftpd_1.3.3c.bb
new file mode 100644
index 0000000000..63b5b2c397
--- /dev/null
+++ b/recipes/proftpd/proftpd_1.3.3c.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Secure ftp daemon"
+SECTION = "console/network"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "ftp://ftp.nl.uu.net/pub/unix/ftp/proftpd/ftp/distrib/source/${PN}-${PV}.tar.gz \
+ file://make.patch \
+ file://proftpd-install-nostrip.patch \
+ "
+
+
+EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes ac_cv_func_setgrent_void=yes --disable-cap"
+LDFLAGS += "-Llib"
+PARALLEL_MAKE = ""
+
+do_configure () {
+ ./configure \
+ --disable-auth-pam \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sharedstatedir=/com \
+ --localstatedir=/var \
+ ${EXTRA_OECONF} \
+ $@;
+}
+
+pkg_postinst () {
+ # more chown's might be needed
+ chown root:root /usr/sbin/proftpd
+}