aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/xorg-driver/xf86-video-omapfb_git.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes/xorg-driver/xf86-video-omapfb_git.bb b/recipes/xorg-driver/xf86-video-omapfb_git.bb
index f718e7684e..30a86cfdc8 100644
--- a/recipes/xorg-driver/xf86-video-omapfb_git.bb
+++ b/recipes/xorg-driver/xf86-video-omapfb_git.bb
@@ -2,17 +2,22 @@ require xorg-driver-video.inc
DESCRIPTION = "X.Org X server -- OMAP display driver"
-PR ="r20"
+PR ="r0"
-SRCREV = "ef0b41c332a710fb33f996df77bd4a96b56878da"
-PV = "0.0.1+${PR}+gitr${SRCREV}"
+SRCREV = "5317aae587a2bf48f07a8c06bfaf7bcbfd23bafc"
+PV = "0.1.1+${PR}+gitr${SRCREV}"
PE = "1"
SRC_URI = "git://git.pingu.fi/xf86-video-omapfb.git;protocol=http \
"
-SRC_URI_append_armv7a = " file://omapfb-neon.diff;patch=1"
-
S = "${WORKDIR}/git"
+EXTRA_OECONF_armv7a = " --enable-neon "
CFLAGS += " -I${STAGING_INCDIR}/xorg "
+
+# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
+do_compile_prepend_armv7a () {
+ sed -i -e s:fb1:fb2:g ${S}/src/omapfb-xv.c
+}
+