aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.34.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.34.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.34.bb
new file mode 100644
index 0000000000..093a10b72f
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.34.bb
@@ -0,0 +1,35 @@
+require linux-libc-headers.inc
+
+# untested for non nios2 systems
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_nios2 = "1"
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS += "unifdef-native"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ "
+
+# For nios2 the source comes from sopc.et.ntust.edu.tw, but as this one is very slow
+# a tarball is placed at opensource.axon.tv
+#SRC_URI_nios2 = "git://sopc.et.ntust.edu.tw/git/linux-2.6.git;branch=nios2mmu;protocol=http;tag=a32ca88c4f3f3850c5c9789db2afab2530c6856d;protocol=http \
+SRC_URI_nios2 = "ftp://opensource.axon.nl/mirror/git_sopc.et.ntust.edu.tw.linux-2.6.git_a32ca88c4f3f3850c5c9789db2afab2530c6856d.tar.gz;name=nios2tarball \
+ "
+
+# nios2 checksums
+SRC_URI[nios2tarball.md5sum] = "ad27c6ddfe5b2bb0f81968c0155d072d"
+SRC_URI[nios2tarball.sha256sum] = "7c99c5ee4bf26d08fde030c605c618454984dba5ae79c298064228ab0053e60f"
+
+S = "${WORKDIR}/linux-2.6"
+
+do_configure() {
+ cd ${S}
+ oe_runmake allnoconfig ARCH=$ARCH
+}
+
+do_compile () {
+}
+
+do_install() {
+ oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+}