aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/bitbake.conf1
-rw-r--r--conf/checksums.ini4
-rw-r--r--packages/adobe-flash/flash-plugin_10.0.12.36.bb35
3 files changed, 40 insertions, 0 deletions
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index 81d4c93dc0..a86317cba9 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -494,6 +494,7 @@ FREESMARTPHONE_GIT = "git://git.freesmartphone.org"
GENTOO_MIRROR = "http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles"
APACHE_MIRROR = "http://www.apache.org/dist"
KERNELORG_MIRROR = "http://kernel.org"
+ADOBE_MIRROR = "http://fpdownload.macromedia.com/get/flashplayer/current/"
# You can use the mirror of your country to get faster downloads by putting
# export DEBIAN_MIRROR = "ftp://ftp.de.debian.org/debian/pool"
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 9845ff6b1d..5333edf34e 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -5494,6 +5494,10 @@ sha256=ce4f7d11b3c04a7368c916ca4abc284dd0c0256f461dfb7f07df1ab445e7a5c0
md5=2bfc127cdda02834d0491ab531a20960
sha256=ce4f7d11b3c04a7368c916ca4abc284dd0c0256f461dfb7f07df1ab445e7a5c0
+[http://fpdownload.macromedia.com/get/flashplayer/current//flash-plugin-10.0.12.36-release.i386.rpm]
+md5=8845d4536fcd3a329690c93bce9bbf8e
+sha256=c7345faf10b269b3556f2e1373c4afc35f08891f8bbd54e45d49151a8c8e4ac0
+
[http://downloads.sourceforge.net/flex/flex-2.5.31.tar.bz2]
md5=363dcc4afc917dc51306eb9d3de0152f
sha256=701353279a17655d78e3b3678ad78d0375f5bf45877ad8b3507d589c42427f26
diff --git a/packages/adobe-flash/flash-plugin_10.0.12.36.bb b/packages/adobe-flash/flash-plugin_10.0.12.36.bb
new file mode 100644
index 0000000000..d6cde60031
--- /dev/null
+++ b/packages/adobe-flash/flash-plugin_10.0.12.36.bb
@@ -0,0 +1,35 @@
+# Adobe provides two versions of flash player packages
+#
+# One "unversioned" download at :
+#
+# ${ADOBE_MIRROR}/install_flash_player_9_linux.tar.gz
+#
+# And the other, versioned, which is encapsulated in RPM.
+#
+# We use the versioned one to make sure we can keep track of the
+# version and thus do repeatable builds at the cost of future download
+# failures when adobe updates.
+DESCRIPTION = "Adobe Flash 9 plugin for Mozilla/Firefox web browsers"
+LICENSE = "AdobeFlash"
+DEPENDS = "rpm2cpio-native"
+PR = "r1"
+
+SRC_URI = "${ADOBE_MIRROR}/flash-plugin-${PV}-release.i386.rpm"
+
+do_configure() {
+ rpm=${WORKDIR}/flash-plugin-${PV}-release.i386.rpm
+ if [ -f "$rpm" ]; then
+ rpm2cpio.pl $rpm | cpio -id
+ find . -type f -exec mv -i {} "`pwd`" \;
+ fi
+}
+do_install() {
+ mkdir -p ${D}${libdir}/mozilla/plugins/
+ install -m 0755 libflashplayer.so ${D}${libdir}/mozilla/plugins/
+ # AFAIK this is not needed
+ # install -m 0644 flashplayer.xpt ${D}${libdir}/mozilla/plugins/
+}
+
+FILES_${PN} = "${libdir}/* ${libdir}/X11/*"
+
+COMPATIBLE_HOST = "i.86.*-linux"