aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/kernel.bbclass9
-rw-r--r--classes/siteinfo.bbclass3
-rw-r--r--conf/bitbake.conf2
-rw-r--r--conf/checksums.ini12
-rw-r--r--conf/distro/include/preferred-xorg-versions-X11R7.4.inc2
-rw-r--r--recipes/fbprogress/fbprogress_1.1.bb19
-rw-r--r--recipes/gnome/gnome-bluetooth_git.bb7
-rw-r--r--recipes/gnome/gnote_0.5.0.bb8
-rw-r--r--recipes/kakasi/kakasi-native_2.3.4.bb2
-rw-r--r--recipes/libpcre/libpcre_7.6.bb21
-rw-r--r--recipes/uim/uim-native_1.3.1.bb2
11 files changed, 58 insertions, 29 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index ae7e643ca7..ef16669c3d 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -20,6 +20,11 @@ python __anonymous () {
image = bb.data.getVar('INITRAMFS_IMAGE', d, True)
if image != '' and image is not None:
bb.data.setVar('INITRAMFS_TASK', '${INITRAMFS_IMAGE}:do_rootfs', d)
+
+ machine_kernel_pr = bb.data.getVar('MACHINE_KERNEL_PR', d, True)
+
+ if machine_kernel_pr:
+ bb.data.setVar('PR', machine_kernel_pr, d)
}
INITRAMFS_IMAGE ?= ""
@@ -64,10 +69,6 @@ export CMDLINE_CONSOLE = "console=${@bb.data.getVar("KERNEL_CONSOLE",d,1) or "tt
KERNEL_VERSION = "${@get_kernelversion('${S}')}"
KERNEL_MAJOR_VERSION = "${@get_kernelmajorversion('${KERNEL_VERSION}')}"
-# A machine.conf or local.conf can increase MACHINE_KERNEL_PR to force
-# rebuilds for kernel and external modules
-PR = "${MACHINE_KERNEL_PR}"
-
KERNEL_LOCALVERSION ?= ""
# kernels are generally machine specific
diff --git a/classes/siteinfo.bbclass b/classes/siteinfo.bbclass
index 0221b123f1..e51d7ab8a6 100644
--- a/classes/siteinfo.bbclass
+++ b/classes/siteinfo.bbclass
@@ -32,7 +32,7 @@ def get_siteinfo_list(d):
"arm-linux-uclibc": "endian-little bit-32 common-linux common-uclibc arm-common",\
"arm-linux-uclibcgnueabi": "endian-little bit-32 common-linux common-uclibc arm-common arm-linux-uclibc",\
"avr32-linux-uclibc": "endian-big bit-32 common-linux common-uclibc avr32-common",\
- "bfin-uclinux-uclibc": "endian-little bit-32 common-uclibc bfin-common",\
+ "bfin-uclinux-uclibc": "endian-little bit-32 common-uclibc bfin-common",\
"i386-linux": "endian-little bit-32 common-linux common-glibc ix86-common",\
"i486-linux": "endian-little bit-32 common-linux common-glibc ix86-common",\
"i586-linux": "endian-little bit-32 common-linux common-glibc ix86-common",\
@@ -64,6 +64,7 @@ def get_siteinfo_list(d):
"sh4-linux": "endian-little bit-32 common-linux common-glibc sh-common",\
"sh4-linux-uclibc": "endian-little bit-32 common-linux common-uclibc sh-common",\
"sparc-linux": "endian-big bit-32 common-linux common-glibc",\
+ "viac3-linux": "endian-little bit-32 common-linux common-glibc ix86-common",\
"x86_64-linux": "endian-little bit-64 common-linux common-glibc",\
"x86_64-linux-uclibc": "endian-little bit-64 common-linux common-uclibc"}
if target in targetinfo:
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index 077e8e1e9a..4f00be73e6 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -164,7 +164,7 @@ P = "${PN}-${PV}"
# Define a PR for kernels that machines can override so things like
# modules get rebuilt
-MACHINE_KERNEL_PR ?= "r0"
+MACHINE_KERNEL_PR = ""
# Base package name
# Automatically derives "foo" from "foo-native", "foo-cross" or "foo-initial"
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 2f9c8289ab..bf8693d00e 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -3966,6 +3966,10 @@ sha256=73f3b92c0f85ab2bf0f9bb18f928a8b84cacdbb459f3a530df540d4ddf134405
md5=7bc5c89870d47c88f407fcfd666c739d
sha256=102bb7a5d329dd6831bc8a923fa0b5d7634efa215e3d15377630d9b738df49da
+[http://www.kernel.org/pub/linux/network/connman/connman-0.18.tar.gz]
+md5=b58cb56d0403bfafb3972e82a339546c
+sha256=923ce04b8ff93aa9eec4df6c822f1c7d35e8aea1ab8680bd0d9a5e4d327dd3c6
+
[http://www.kernel.org/pub/linux/network/connman/connman-0.19.tar.gz]
md5=3d61c5db55d225c3efbf4c950dc0842f
sha256=cc4a4b73d8d7b0e19dd2dd274ba91acb67b14c84fc448a921d1359e25e4d2df0
@@ -4006,6 +4010,10 @@ sha256=d7acac8bc0a38dfcab098137a76f5e9f4ce30ca86e82b26540502658e6b4e4a7
md5=c9a3b384f080ed4cdf139ce9377ef2c8
sha256=d7acac8bc0a38dfcab098137a76f5e9f4ce30ca86e82b26540502658e6b4e4a7
+[http://www.kernel.org/pub/linux/network/connman/connman-gnome-0.5.tar.gz]
+md5=0e1c4c25d19cad9b08a216848a320716
+sha256=4d5fe481b444fc3e64fd9caa149dbcd76de166a25733f18fd93da01d2abf5d1c
+
[http://www.conserver.com/conserver-8.1.14.tar.gz]
md5=f7825728e5af8992ed4a99fb560a3df8
sha256=48a9e2f8a02054bc6740ae354433bfa1636a6e726f2d62af22752d7a6103410b
@@ -8466,6 +8474,10 @@ sha256=77cb4bd39a4cec2aa3d61b0519134f9e4a65613960b3b3ee34dd2452d5e12ba7
md5=905a8df3513a519096bcf7d8efc35118
sha256=f08d0f214db875eac602bec37b20042f0ee4f14427f9559477a040ef39003538
+[http://ftp.gnome.org/pub/GNOME/sources/gnote/0.5/gnote-0.5.0.tar.bz2]
+md5=ca9e67a92945af7230eae72b2e8430ec
+sha256=19a1f79c42b37ee3c90ba6298442b52438f1c67d311ebd33db72210cee2d99d2
+
[ftp://ftp.gnu.org/gnu/ghostscript/gnu-ghostscript-8.16.tar.gz]
md5=c42dfaebc37fe81eab0b5676b124ab63
sha256=417922d35e66ee90cf93cf3e93fdf281ec6b92de4f7436c9c1a97c0cc35b94a8
diff --git a/conf/distro/include/preferred-xorg-versions-X11R7.4.inc b/conf/distro/include/preferred-xorg-versions-X11R7.4.inc
index 46fa8d496a..21f9758f0e 100644
--- a/conf/distro/include/preferred-xorg-versions-X11R7.4.inc
+++ b/conf/distro/include/preferred-xorg-versions-X11R7.4.inc
@@ -195,6 +195,7 @@ PREFERRED_VERSION_xtrans ?= "1.2.1"
# This should be here but is needed until bitbake can do
# versioned depends
PREFERRED_VERSION_mesa ?= "7.2"
+PREFERRED_VERSION_xtrans-native ?= "1.2.1"
# proto
PREFERRED_VERSION_applewmproto ?= "1.0.3"
@@ -218,6 +219,7 @@ PREFERRED_VERSION_videoproto ?= "2.2.2"
PREFERRED_VERSION_windowswmproto ?= "1.0.3"
PREFERRED_VERSION_xmiscproto ?= "1.1.2"
PREFERRED_VERSION_xextproto ?= "7.0.3"
+PREFERRED_VERSION_xextproto-native ?= "7.0.3"
PREFERRED_VERSION_xf86dgaproto ?= "2.0.3"
PREFERRED_VERSION_xf86driproto ?= "2.0.4"
PREFERRED_VERSION_xf86miscproto ?= "0.9.2"
diff --git a/recipes/fbprogress/fbprogress_1.1.bb b/recipes/fbprogress/fbprogress_1.1.bb
index 8d603b8a3e..855d1ca3d4 100644
--- a/recipes/fbprogress/fbprogress_1.1.bb
+++ b/recipes/fbprogress/fbprogress_1.1.bb
@@ -3,8 +3,8 @@ AUTHOR = "Angel Roman"
HOMEPAGE = "http://www.buglabs.net/"
LICENSE = "GPL"
DEPENDS = "freetype zlib virtual/kernel"
-SRCREV = "9118"
-PR = "r1"
+SRCREV = "9405"
+PR = "r2"
SRC_URI = "svn://svn.buglabs.net/bug/trunk;module=com.buglabs.bug.native.fbprogress;proto=svn \
file://fbprogress-init"
@@ -13,14 +13,17 @@ S = "${WORKDIR}/com.buglabs.bug.native.fbprogress"
inherit update-rc.d
-EXTRA_OEMAKE = "BUG_LINUX_SRC=${STAGING_KERNEL_DIR}"
+TARGET_CXXFLAGS += "-I${STAGING_INCDIR}/freetype2 -I${STAGING_KERNEL_DIR}/include"
+TARGET_LDFLAGS += "-L${STAGING_LIBDIR} -lfreetype -lz"
do_install() {
- install -d ${D}/${sysconfdir}/fbprogress
- install -m 0644 ${S}/images/* ${D}/${sysconfdir}/fbprogress/
- install -d ${D}${layout_bindir}
- install -m 0755 fbprogress ${D}${layout_bindir}
- install -m 0755 fbprogress.sh ${D}${layout_bindir}
+ install -d ${D}/${datadir}/fbprogress
+ install -m 0644 ${S}/images/* ${D}/${datadir}/fbprogress/
+
+ install -d ${D}${bindir}
+ install -m 0755 fbprogress ${D}${bindir}
+ install -m 0755 fbprogress.sh ${D}${bindir}
+
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/fbprogress-init ${D}/${sysconfdir}/init.d/fbprogress
}
diff --git a/recipes/gnome/gnome-bluetooth_git.bb b/recipes/gnome/gnome-bluetooth_git.bb
index de11874fab..23c4ca92ac 100644
--- a/recipes/gnome/gnome-bluetooth_git.bb
+++ b/recipes/gnome/gnome-bluetooth_git.bb
@@ -11,12 +11,13 @@ SRC_URI = "git://git.gnome.org/gnome-bluetooth;protocol=git \
S = "${WORKDIR}/git"
-SRCREV = "097aef044ced5937dd7e288bfee58b6138939117"
+SRCREV = "93fd8de2cc717b96ad719ab2fb5ed38b8a0fc707"
PV = "2.27.5"
+PR = "r2"
PR_append = "+gitr${SRCREV}"
-DEPENDS = "obexd obex-data-server gconf-dbus gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
-RRECOMMENDS_${PN} += "obexd obex-data-server"
+DEPENDS = "obexd gconf-dbus gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
+RRECOMMENDS_${PN} += "obexd"
RCONFLICTS_${PN} = "bluez-gnome"
do_configure_prepend() {
diff --git a/recipes/gnome/gnote_0.5.0.bb b/recipes/gnome/gnote_0.5.0.bb
new file mode 100644
index 0000000000..cc11022b7c
--- /dev/null
+++ b/recipes/gnome/gnote_0.5.0.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Note taking application"
+LICENSE = "GPL"
+
+DEPENDS = "libpcre libgnomeui gconf-dbus gtkmm boost"
+
+inherit gnome
+
+FILES_${PN}-dbg += "${libdir}/gnote/*/*/.debug"
diff --git a/recipes/kakasi/kakasi-native_2.3.4.bb b/recipes/kakasi/kakasi-native_2.3.4.bb
index 86a4c81b44..18f0061cfe 100644
--- a/recipes/kakasi/kakasi-native_2.3.4.bb
+++ b/recipes/kakasi/kakasi-native_2.3.4.bb
@@ -2,8 +2,6 @@ require kakasi.inc
inherit native
-S = "${WORKDIR}/kakasi-${PV}"
-
do_stage() {
install src/mkkanwa ${STAGING_BINDIR}
}
diff --git a/recipes/libpcre/libpcre_7.6.bb b/recipes/libpcre/libpcre_7.6.bb
index eb5af03db0..aa038c6e95 100644
--- a/recipes/libpcre/libpcre_7.6.bb
+++ b/recipes/libpcre/libpcre_7.6.bb
@@ -5,7 +5,7 @@ provides a POSIX calling interface to PCRE; the regular expressions \
themselves still follow Perl syntax and semantics. The header file for \
the POSIX-style functions is called pcreposix.h."
SECTION = "devel"
-PR = "r3"
+PR = "r4"
LICENSE = "BSD"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
file://pcre-cross.patch;patch=1"
@@ -17,7 +17,6 @@ inherit autotools binconfig
PARALLEL_MAKE = ""
-LEAD_SONAME = "libpcre.so"
CFLAGS_append = " -D_REENTRANT"
CXXFLAGS_powerpc += "-lstdc++"
EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
@@ -40,13 +39,19 @@ do_compile () {
}
do_stage () {
- oe_libinstall -a -so libpcre ${STAGING_LIBDIR}
- oe_libinstall -a -so libpcreposix ${STAGING_LIBDIR}
- install -m 0644 pcre.h ${STAGING_INCDIR}/
- install -m 0644 pcreposix.h ${STAGING_INCDIR}/
- install -d ${STAGING_BINDIR_NATIVE}
+ autotools_stage_all
+ install -d ${STAGING_BINDIR_NATIVE}
install -m 0755 ${S}/dftables ${STAGING_BINDIR_NATIVE}/
}
-FILES_${PN} = "${libdir}/lib*.so.*"
+python populate_packages_prepend () {
+ pcre_libdir = bb.data.expand('${libdir}', d)
+ pcre_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
+ do_split_packages(d, pcre_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev', allow_links=True)
+ do_split_packages(d, pcre_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
+ do_split_packages(d, pcre_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
+ do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.*', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
+}
+
+FILES_${PN} = "${libdir}/libpcre.so.*"
FILES_${PN}-dev += "${bindir}/*"
diff --git a/recipes/uim/uim-native_1.3.1.bb b/recipes/uim/uim-native_1.3.1.bb
index f23f6bd945..3404a36ab5 100644
--- a/recipes/uim/uim-native_1.3.1.bb
+++ b/recipes/uim/uim-native_1.3.1.bb
@@ -3,6 +3,4 @@ DEPENDS = "gtk+ anthy intltool-native"
inherit native autotools pkgconfig
PR = "r2"
-S = "${WORKDIR}/uim-${PV}"
-
EXTRA_OECONF += "--disable-xim"