aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/u-boot/u-boot.inc16
-rw-r--r--recipes/u-boot/u-boot_git.bb2
2 files changed, 15 insertions, 3 deletions
diff --git a/recipes/u-boot/u-boot.inc b/recipes/u-boot/u-boot.inc
index 24dcb2b966..323eaef318 100644
--- a/recipes/u-boot/u-boot.inc
+++ b/recipes/u-boot/u-boot.inc
@@ -17,8 +17,6 @@ UBOOT_BINARY ?= "u-boot.bin"
UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin"
-INSANE_SKIP_${PN} = True
-
do_compile () {
unset LDFLAGS
unset CFLAGS
@@ -29,6 +27,10 @@ do_compile () {
}
do_install () {
+ install -d ${D}/boot
+ install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
+ ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+
if [ -e ${WORKDIR}/fw_env.config ] ; then
install -d ${D}${base_sbindir}
install -d ${D}${sysconfdir}
@@ -36,8 +38,18 @@ do_install () {
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
fi
+
}
+FILES_${PN} = "/boot"
+# no gnu_hash in uboot.bin, by design, so skip QA
+INSANE_SKIP_${PN} = True
+
+PACKAGES += "${PN}-fw-utils"
+FILES_${PN}-fw-utils = "${sysconfdir} ${base_sbindir}"
+# u-boot doesn't use LDFLAGS for fw files, needs to get fixed, but until then:
+INSANE_SKIP_${PN}-fw-utils = True
+
do_deploy () {
install -d ${DEPLOY_DIR_IMAGE}
install ${S}/${UBOOT_BINARY} ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 8dca7cfd53..03c0661aad 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r49"
+PR ="r50"
FILESPATHPKG =. "u-boot-git:"