aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/autotools.bbclass146
-rw-r--r--conf/bitbake.conf9
-rw-r--r--packages/patcher/patcher-native_20040913.bb21
-rw-r--r--packages/quilt/quilt-native_0.37.bb0
-rw-r--r--packages/uclibc/uclibc-cvs/dyn-ldconfig.patch34
-rw-r--r--packages/uclibc/uclibc_cvs.bb1
6 files changed, 173 insertions, 38 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index e69de29bb2..820400680f 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -0,0 +1,146 @@
+inherit base
+
+def autotools_dep_prepend(d):
+ import bb;
+
+ if bb.data.getVar('INHIBIT_AUTOTOOLS_DEPS', d, 1):
+ return ''
+
+ pn = bb.data.getVar('PN', d, 1)
+ deps = ''
+
+ if pn in ['autoconf-native', 'automake-native']:
+ return deps
+ deps += 'autoconf-native automake-native '
+
+ if not pn in ['libtool', 'libtool-native', 'libtool-cross']:
+ deps += 'libtool-native '
+
+ return deps + 'gnu-config-native '
+
+EXTRA_OEMAKE = ""
+DEPENDS_prepend = "${@autotools_dep_prepend(d)}"
+acpaths = "default"
+EXTRA_AUTORECONF = "--exclude=autopoint"
+
+def autotools_set_crosscompiling(d):
+ import bb
+ if not bb.data.inherits_class('native', d):
+ return " cross_compiling=yes"
+ return ""
+
+# EXTRA_OECONF_append = "${@autotools_set_crosscompiling(d)}"
+
+oe_runconf () {
+ if [ -x ${S}/configure ] ; then
+ cfgcmd="${S}/configure \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=${prefix} \
+ --exec_prefix=${exec_prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --oldincludedir=${oldincludedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF} \
+ $@"
+ oenote "Running $cfgcmd..."
+ $cfgcmd || oefatal "oe_runconf failed"
+ else
+ oefatal "no configure script found"
+ fi
+}
+
+autotools_do_configure() {
+ case ${PN} in
+ autoconf*)
+ ;;
+ automake*)
+ ;;
+ *)
+ # WARNING: gross hack follows:
+ # An autotools built package generally needs these scripts, however only
+ # automake or libtoolize actually install the current versions of them.
+ # This is a problem in builds that do not use libtool or automake, in the case
+ # where we -need- the latest version of these scripts. e.g. running a build
+ # for a package whose autotools are old, on an x86_64 machine, which the old
+ # config.sub does not support. Work around this by installing them manually
+ # regardless.
+ ( for ac in `find ${S} -name configure.in -o -name configure.ac`; do
+ rm -f `dirname $ac`/configure
+ done )
+ if [ -e ${S}/configure.in -o -e ${S}/configure.ac ]; then
+ olddir=`pwd`
+ cd ${S}
+ if [ x"${acpaths}" = xdefault ]; then
+ acpaths=
+ for i in `find ${S} -maxdepth 2 -name \*.m4|grep -v 'aclocal.m4'| \
+ grep -v 'acinclude.m4' | sed -e 's,\(.*/\).*$,\1,'|sort -u`; do
+ acpaths="$acpaths -I $i"
+ done
+ else
+ acpaths="${acpaths}"
+ fi
+ install -d ${STAGING_DIR}/${HOST_SYS}/share/aclocal
+ acpaths="$acpaths -I ${STAGING_DIR}/${HOST_SYS}/share/aclocal"
+ # autoreconf is too shy to overwrite aclocal.m4 if it doesn't look
+ # like it was auto-generated. Work around this by blowing it away
+ # by hand, unless the package specifically asked not to run aclocal.
+ if ! echo ${EXTRA_AUTORECONF} | grep -q "aclocal"; then
+ rm -f aclocal.m4
+ fi
+ if [ -e configure.in ]; then
+ CONFIGURE_AC=configure.in
+ else
+ CONFIGURE_AC=configure.ac
+ fi
+ if grep "^AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+ if grep "sed.*POTFILES" configure.ac >/dev/null; then
+ : do nothing -- we still have an old unmodified configure.ac
+ else
+ oenote Executing glib-gettextize --force --copy
+ echo "no" | glib-gettextize --force --copy
+ fi
+ fi
+ if grep "^AC_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+ oenote Executing intltoolize --copy --force --automake
+ intltoolize --copy --force --automake
+ fi
+ oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
+ mkdir -p m4
+ autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
+ cd $olddir
+ fi
+ ;;
+ esac
+ if [ -e ${S}/configure ]; then
+ oe_runconf
+ else
+ oenote "nothing to configure"
+ fi
+}
+
+autotools_do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+STAGE_TEMP="${WORKDIR}/temp-staging"
+
+autotools_stage_includes() {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ make DESTDIR="${STAGE_TEMP}" install
+ cp -a ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ rm -rf ${STAGE_TEMP}
+}
+
+EXPORT_FUNCTIONS do_configure do_install
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index 86abdc1991..b15d744a96 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -304,9 +304,12 @@ SRC_URI = "file://${FILE}"
MKTEMPDIRCMD = "mktemp -d -q ${TMPBASE}"
MKTEMPCMD = "mktemp -q ${TMPBASE}"
-PATCHCLEANCMD = "patcher -B"
-PATCHCMD = "patcher -R -p '%s' -n '%s' -i '%s'"
-PATCH_DEPENDS = "patcher-native"
+# PATCHCLEANCMD = "patcher -B"
+# PATCHCMD = "patcher -R -p '%s' -n '%s' -i '%s'"
+# PATCH_DEPENDS = "patcher-native"
+PATCHCLEANCMD = 'if [ -n "`quilt applied`" ]; then quilt pop -a -R -f || exit 1; fi'
+PATCHCMD = "quilt upgrade; chmod 644 patches/* || true; quilt import -f -p '%s' -n '%s' '%s'; quilt push"
+PATCH_DEPENDS = "quilt-native"
##################################################################
# Not sure about the rest of this yet.
diff --git a/packages/patcher/patcher-native_20040913.bb b/packages/patcher/patcher-native_20040913.bb
index e69de29bb2..cebdde0b9c 100644
--- a/packages/patcher/patcher-native_20040913.bb
+++ b/packages/patcher/patcher-native_20040913.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Patcher is a perl script for managing patches."
+HOMEPAGE = "http://www.holgerschurig.de/patcher.html"
+LICENSE = "Perl"
+DEPENDS = ""
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Holger Schurig <hs4233@mail.mn-solutions.de>"
+PACKAGES = ""
+PR = "r1"
+
+inherit native
+
+SRC_URI = "http://www.holgerschurig.de/files/linux/patcher-${PV}.tar.bz2"
+S = "${WORKDIR}/patcher"
+
+PATCHCLEANCMD = ""
+PATCHCMD = "num='%s'; name='%s'; file='%s'; cat $file | patch -p "$num""
+
+do_stage() {
+ install -m 0755 patcher.py ${STAGING_BINDIR}/patcher
+}
diff --git a/packages/quilt/quilt-native_0.37.bb b/packages/quilt/quilt-native_0.37.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/quilt/quilt-native_0.37.bb
diff --git a/packages/uclibc/uclibc-cvs/dyn-ldconfig.patch b/packages/uclibc/uclibc-cvs/dyn-ldconfig.patch
deleted file mode 100644
index a053b9ee81..0000000000
--- a/packages/uclibc/uclibc-cvs/dyn-ldconfig.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- uClibc/utils/Makefile~dyn-ldconfig
-+++ uClibc/utils/Makefile
-@@ -45,7 +45,7 @@
- $(STRIPTOOL) -x -R .note -R .comment $@
-
- ldconfig: ldconfig.c
-- $(CC) $(CFLAGS) -Wl,-s -static \
-+ $(CC) $(CFLAGS) -Wl,-s $(if $(filter $(UCLIBC_STATIC_LDCONFIG),y),-static) \
- -DUCLIBC_RUNTIME_PREFIX=\"$(RUNTIME_PREFIX)\" \
- -DUCLIBC_LDSO=$(UCLIBC_LDSO) -I. -I../ldso/include \
- $^ -o $@
---- uClibc/extra/Configs/Config.in~dyn-ldconfig
-+++ uClibc/extra/Configs/Config.in
-@@ -311,6 +311,15 @@
- if you are using an older Linux kernel (2.0.x) that lacks large file
- support. Enabling this option will increase the size of uClibc.
-
-+config UCLIBC_STATIC_LDCONFIG
-+ bool "Link ldconfig statically"
-+ default y
-+ help
-+ If you wish to link the ldconfig binary statically, enable this option.
-+ It being static can be beneficial if you have a library problem and need
-+ ldconfig to recover from it. If keeping the size down is more important
-+ to you than system recovery, disable this option.
-+
- choice
- prompt "Malloc Implementation"
- default MALLOC if ! ARCH_HAS_MMU
diff --git a/packages/uclibc/uclibc_cvs.bb b/packages/uclibc/uclibc_cvs.bb
index 3d303a8795..27e306c29e 100644
--- a/packages/uclibc/uclibc_cvs.bb
+++ b/packages/uclibc/uclibc_cvs.bb
@@ -63,7 +63,6 @@ UCLIBC_LOCALE_URI_arm = "http://openembedded.org/dl/uclibc-locale/${UCLIBC_LOCAL
SRC_URI = "cvs://anonymous:@uclibc.org/var/cvs;module=uClibc \
${@['${UCLIBC_LOCALE_URI}', ''][bb.data.getVar('USE_NLS', d, 1) == 'no']} \
file://nokernelheadercheck.patch;patch=1 \
- file://dyn-ldconfig.patch;patch=1 \
file://uClibc.config"
S = "${WORKDIR}/uClibc"