aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/palmtop.bbclass20
-rw-r--r--packages/python/python-sip4_4.4.1.bb2
-rw-r--r--packages/python/python_2.4.3.bb6
3 files changed, 8 insertions, 20 deletions
diff --git a/classes/palmtop.bbclass b/classes/palmtop.bbclass
index 9d54de8748..523c3d71bb 100644
--- a/classes/palmtop.bbclass
+++ b/classes/palmtop.bbclass
@@ -1,20 +1,10 @@
-# this build class sets up qmake variables to
-# * build using the Qt Windowing System (QWS)
-# * use qt
-# * link against supc++ instead of stdc++
-# * use threads, if requested via PALMTOP_USE_MULTITHREADED_QT = "yes"
-# inherit this class to build programs against libqpe
-# inherit opie if you want to build programs against libopie2
-# don't override EXTRA_QMAKEVARS_POST, if you use inherit this class
+# basically a placeholder for something more fancy
+# for now, just declare some things
inherit qmake
-# special case for DISTRO = sharprom
-CPP_SUPPORT_LIB = "LIBS-=-lstdc++ LIBS+=-lsupc++"
-CPP_SUPPORT_LIB_sharprom = "LIBS-=-lstdc++"
-EXTRA_QMAKEVARS_POST += "DEFINES+=QWS CONFIG+=qt ${CPP_SUPPORT_LIB}"
-EXTRA_QMAKEVARS_POST += '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "CONFIG+=thread", "CONFIG-=thread",d)}'
-EXTRA_QMAKEVARS_POST += "${@["LIBS+=-lqpe ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
-DEPENDS_prepend = "${@["virtual/libqpe1 uicmoc-native ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
+EXTRA_QMAKEVARS_POST_append = " DEFINES+=QWS LIBS+=-lqpe CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
+
+DEPENDS_prepend = "virtual/libqpe uicmoc-native "
FILES_${PN} = "${palmtopdir}"
diff --git a/packages/python/python-sip4_4.4.1.bb b/packages/python/python-sip4_4.4.1.bb
index 4bdc8ed769..97f7375056 100644
--- a/packages/python/python-sip4_4.4.1.bb
+++ b/packages/python/python-sip4_4.4.1.bb
@@ -13,7 +13,7 @@ S = "${WORKDIR}/sip-${PV}/siplib"
inherit qmake distutils-base
-EXTRA_QMAKEVARS_POST += " TEMPLATE=lib \
+EXTRA_QMAKEVARS_POST = " TEMPLATE=lib \
CONFIG=console \
DESTDIR= \
VERSION=1.0.0 \
diff --git a/packages/python/python_2.4.3.bb b/packages/python/python_2.4.3.bb
index 289de18a53..7d3856d719 100644
--- a/packages/python/python_2.4.3.bb
+++ b/packages/python/python_2.4.3.bb
@@ -5,8 +5,7 @@ SECTION = "devel/python"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
-DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-PR = "ml2"
+PR = "ml0"
PYTHON_MAJMIN = "2.4"
@@ -63,7 +62,6 @@ do_install() {
include python-${PV}-manifest.inc
-RPROVIDES_python-core = "python"
-RPROVIDES_python-curses = "python"
PACKAGES =+ "libpython2"
FILES_libpython2 = "${libdir}/libpython*"
+