aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/qt4/qt4-embedded-gles-4.6.2/cursor-hack.diff34
-rw-r--r--recipes/qt4/qt4-embedded-gles/linux.conf2
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.6.2.bb6
-rw-r--r--recipes/qt4/qt4-x11-free-gles/linux.conf2
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.6.2.bb4
5 files changed, 41 insertions, 7 deletions
diff --git a/recipes/qt4/qt4-embedded-gles-4.6.2/cursor-hack.diff b/recipes/qt4/qt4-embedded-gles-4.6.2/cursor-hack.diff
new file mode 100644
index 0000000000..e297e520a0
--- /dev/null
+++ b/recipes/qt4/qt4-embedded-gles-4.6.2/cursor-hack.diff
@@ -0,0 +1,34 @@
+Patch originally done by Bin Liu, rediffed by Koen Kooi for Qt 4.6.2
+
+This patch is a first step to get a working cursor when using the powervr driver, it flickers when hovering over a QGLWidget, but still better than no cursor at all
+
+--- /tmp/pvreglscreen.cpp 2010-04-19 09:30:32.000000000 +0200
++++ qt-everywhere-opensource-src-4.6.2/src/plugins/gfxdrivers/powervr/pvreglscreen/pvreglscreen.cpp 2010-04-19 09:31:30.000000000 +0200
+@@ -85,6 +85,9 @@
+ bool PvrEglScreen::initDevice()
+ {
+ openTty();
++#ifndef QT_NO_QWS_CURSOR
++ QScreenCursor::initSoftwareCursor();
++#endif
+ return true;
+ }
+
+--- /tmp/qwindowsystem_qws.cpp 2010-04-19 09:32:47.000000000 +0200
++++ qt-everywhere-opensource-src-4.6.2/src/gui/embedded/qwindowsystem_qws.cpp 2010-04-19 09:33:30.000000000 +0200
+@@ -3501,7 +3501,6 @@
+ }
+
+ #ifdef QT_QWS_CLIENTBLIT
+-#ifdef QT_NO_QWS_CURSOR
+ // This optimization only really works when there isn't a crazy cursor
+ // wizzing around.
+ QRegion directPaint = (r - transparentRegion); // in gloal coords
+@@ -3513,7 +3512,6 @@
+ QWSRegionEvent::DirectPaint, id);
+ }
+ #endif
+-#endif
+ }
+
+ if (doLock)
diff --git a/recipes/qt4/qt4-embedded-gles/linux.conf b/recipes/qt4/qt4-embedded-gles/linux.conf
index 8c099a6439..4394fbc5f7 100644
--- a/recipes/qt4/qt4-embedded-gles/linux.conf
+++ b/recipes/qt4/qt4-embedded-gles/linux.conf
@@ -61,6 +61,6 @@ QMAKE_INSTALL_FILE = install -m 644 -p
QMAKE_INSTALL_PROGRAM = install -m 755 -p
#These defines are documented in the powervr README, please read it
-DEFINES += QT_NO_OPENVG QT_QWS_CLIENTBLIT QT_NO_QWS_CURSOR
+DEFINES += QT_QWS_CLIENTBLIT
include(unix.conf)
diff --git a/recipes/qt4/qt4-embedded-gles_4.6.2.bb b/recipes/qt4/qt4-embedded-gles_4.6.2.bb
index 20d4f27c11..8459ebd9a2 100644
--- a/recipes/qt4/qt4-embedded-gles_4.6.2.bb
+++ b/recipes/qt4/qt4-embedded-gles_4.6.2.bb
@@ -1,8 +1,10 @@
require qt4-embedded.inc
-PR = "${INC_PR}.7"
+PR = "${INC_PR}.8"
+
+SRC_URI += "file://cursor-hack.diff;patch=1"
PROVIDES += "qt4-embedded"
-QT_GLFLAGS = "-opengl es2 -no-openvg -depths 16,24,32 -plugin-gfx-powervr"
+QT_GLFLAGS = "-opengl es2 -depths 16,24,32 -plugin-gfx-powervr"
require qt-${PV}.inc
diff --git a/recipes/qt4/qt4-x11-free-gles/linux.conf b/recipes/qt4/qt4-x11-free-gles/linux.conf
index ef641f54a9..70eccce125 100644
--- a/recipes/qt4/qt4-x11-free-gles/linux.conf
+++ b/recipes/qt4/qt4-x11-free-gles/linux.conf
@@ -60,6 +60,4 @@ QMAKE_MKDIR = mkdir -p
QMAKE_INSTALL_FILE = install -m 644 -p
QMAKE_INSTALL_PROGRAM = install -m 755 -p
-DEFINES += QT_NO_OPENVG
-
include(unix.conf)
diff --git a/recipes/qt4/qt4-x11-free-gles_4.6.2.bb b/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
index a1b4e877b1..307770f0dc 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
@@ -1,7 +1,7 @@
require qt4-x11-free.inc
-PR = "${INC_PR}.6"
+PR = "${INC_PR}.7"
-QT_GLFLAGS = "-opengl es2 -no-openvg -depths 16,24,32 "
+QT_GLFLAGS = "-opengl es2 -depths 16,24,32 "
require qt-${PV}.inc