aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/linux/linux-2.6.37/gta02-dont-block-dai-switch.patch13
-rw-r--r--recipes/linux/linux-openmoko_2.6.37.bb2
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/linux/linux-2.6.37/gta02-dont-block-dai-switch.patch b/recipes/linux/linux-2.6.37/gta02-dont-block-dai-switch.patch
new file mode 100644
index 0000000000..92742ffecf
--- /dev/null
+++ b/recipes/linux/linux-2.6.37/gta02-dont-block-dai-switch.patch
@@ -0,0 +1,13 @@
+diff --git a/sound/soc/codecs/wm8753.c b/sound/soc/codecs/wm8753.c
+index ffa2ffe..a72a716 100644
+--- a/sound/soc/codecs/wm8753.c
++++ b/sound/soc/codecs/wm8753.c
+@@ -189,6 +189,9 @@ static int wm8753_set_dai(struct snd_kcontrol *kcontrol,
+ struct wm8753_priv *wm8753 = snd_soc_codec_get_drvdata(codec);
+ u16 ioctl;
+
++ if (wm8753->dai_func == ucontrol->value.integer.value[0])
++ return 1;
++
+ if (codec->active)
+ return -EBUSY;
diff --git a/recipes/linux/linux-openmoko_2.6.37.bb b/recipes/linux/linux-openmoko_2.6.37.bb
index 24ba7df25b..b590306ace 100644
--- a/recipes/linux/linux-openmoko_2.6.37.bb
+++ b/recipes/linux/linux-openmoko_2.6.37.bb
@@ -1,3 +1,3 @@
require linux_${PV}.bb
require linux-openmoko.inc
-OM-PR = "4"
+OM-PR = "5"