aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/ti/am-benchmarks_1.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/ti/am-benchmarks_1.3.bb b/recipes/ti/am-benchmarks_1.3.bb
new file mode 100644
index 0000000000..6070fe8db1
--- /dev/null
+++ b/recipes/ti/am-benchmarks_1.3.bb
@@ -0,0 +1,38 @@
+#NOTE: This package is currently only supported for the Angstrom
+# distribution. Other distributions and toolchains may or
+# may not work.
+
+DESCRIPTION = "AM Benchmarks"
+HOMEPAGE = "https://gforge.ti.com/gf/project/am_benchmarks/"
+LICENSE = "BSD"
+SECTION = "system"
+PRIORITY = "optional"
+
+SRCREV = "66"
+PR = "r2+svnr${SRCPV}"
+
+SRC_URI = "svn://gforge.ti.com/svn/am_benchmarks/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+S = "${WORKDIR}/trunk"
+
+do_configure() {
+ # Find all the objects.mk files for the Release target
+ files=`find ${BASE_PACKAGE_ARCH} -name "objects.mk" | grep Release`
+ for f in $files
+ do
+ sed -i -e 's|LIBS :=|LIBS := ${LDFLAGS} |' $f
+ done
+}
+
+do_compile() {
+ # don't build debug version
+ touch debug
+ export CROSS_COMPILE=${TARGET_PREFIX}
+ export ARCH=${BASE_PACKAGE_ARCH}
+ make release
+}
+
+do_install() {
+ export ARCH=${BASE_PACKAGE_ARCH}
+ make DESTDIR=${D} install
+}