aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/udev/udev_168.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/udev/udev_168.bb b/recipes/udev/udev_168.bb
index decd9db4c4..160fff9cf1 100644
--- a/recipes/udev/udev_168.bb
+++ b/recipes/udev/udev_168.bb
@@ -10,7 +10,7 @@ LICENSE = "GPLv2+"
# Untested
DEFAULT_PREFERENCE = "-1"
-PR = "r1"
+PR = "r2"
# Needed for udev-extras
DEPENDS = "gperf-native usbutils acl glib-2.0"
@@ -90,6 +90,11 @@ FILES_${PN} += "${base_libdir}/systemd"
RPROVIDES_${PN}_append = " udev-compat-wrapper"
+RDEPENDS_udev_bug += "udev-compat"
+do_unpack_append_bug() {
+ bb.build.exec_func('do_apply_compat_wrapper', d)
+}
+
# Modify init script on platforms that need to boot old kernels:
do_apply_compat_wrapper() {
cd ${WORKDIR}