aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/jamvm/files/jamvm-1.5.3-jni_h-noinst.patch13
-rw-r--r--recipes/jamvm/jamvm-native.inc10
-rw-r--r--recipes/jamvm/jamvm-native_1.5.3.bb8
3 files changed, 28 insertions, 3 deletions
diff --git a/recipes/jamvm/files/jamvm-1.5.3-jni_h-noinst.patch b/recipes/jamvm/files/jamvm-1.5.3-jni_h-noinst.patch
new file mode 100644
index 0000000000..f0884fd838
--- /dev/null
+++ b/recipes/jamvm/files/jamvm-1.5.3-jni_h-noinst.patch
@@ -0,0 +1,13 @@
+Index: jamvm-1.5.3/src/Makefile.am
+===================================================================
+--- jamvm-1.5.3.orig/src/Makefile.am 2009-09-29 09:29:13.386565473 +0200
++++ jamvm-1.5.3/src/Makefile.am 2009-09-29 09:33:47.702565852 +0200
+@@ -23,7 +23,7 @@
+ DIST_SUBDIRS = os arch interp
+
+ bin_PROGRAMS = jamvm
+-include_HEADERS = jni.h
++noinst_HEADERS = jni.h
+
+ lib_LTLIBRARIES = libjvm.la
+ noinst_LTLIBRARIES = libcore.la
diff --git a/recipes/jamvm/jamvm-native.inc b/recipes/jamvm/jamvm-native.inc
index ff2dba645b..6f8d2232bd 100644
--- a/recipes/jamvm/jamvm-native.inc
+++ b/recipes/jamvm/jamvm-native.inc
@@ -1,10 +1,14 @@
require jamvm.inc
-DEPENDS = "zlib-native classpath-native ecj-initial"
-RDEPENDS = ""
+DEPENDS = "zlib-native classpath-native ecj-initial libffi-native"
+RDEPENDS_${PN} = ""
PROVIDES = "virtual/java-native"
+# Use libffi instead of handcoded JNI calling code. This code seems to have issues which only randomly
+# trigger a segfault.
+EXTRA_OECONF += "--enable-ffi"
+
RPROVIDES_jamvm = ""
# This uses 32 bit arm, so force the instruction set to arm, not thumb
@@ -18,7 +22,7 @@ inherit native
S = "${WORKDIR}/jamvm-${PV}"
do_install_append() {
- ln -sf jamvm ${STAGING_BINDIR}/java
+ ln -sf jamvm ${STAGING_BINDIR}/java
}
# Enforce usage of ecj-initial.
diff --git a/recipes/jamvm/jamvm-native_1.5.3.bb b/recipes/jamvm/jamvm-native_1.5.3.bb
new file mode 100644
index 0000000000..d0ab533d02
--- /dev/null
+++ b/recipes/jamvm/jamvm-native_1.5.3.bb
@@ -0,0 +1,8 @@
+# Note: You *must* use this together with classpath-native 0.98. Otherwise it won't work!
+
+require jamvm-native.inc
+
+PR = "r2"
+
+SRC_URI += "file://jamvm-1.5.3-jni_h-noinst.patch;patch=1"
+