aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/powertop/powertop_1.5.bb (renamed from packages/powertop/powertop_1.2.bb)8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/powertop/powertop_1.2.bb b/packages/powertop/powertop_1.5.bb
index 2f9c7e44b0..ab84161ddc 100644
--- a/packages/powertop/powertop_1.2.bb
+++ b/packages/powertop/powertop_1.5.bb
@@ -1,9 +1,17 @@
DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
HOMEPAGE = "http://www.linuxpowertop.org/"
LICENSE = "GPLv2"
+DEPENDS = "ncurses"
SRC_URI = "http://www.linuxpowertop.org/download/powertop-${PV}.tar.gz"
+CFLAGS += "${LDFLAGS}"
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}
+
do_install() {
oe_runmake install DESTDIR=${D}
}