aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/cairo/cairo_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/cairo/cairo_git.bb b/packages/cairo/cairo_git.bb
new file mode 100644
index 0000000000..28b03b653a
--- /dev/null
+++ b/packages/cairo/cairo_git.bb
@@ -0,0 +1,24 @@
+#This is a development snapshot, so lets hint OE to use the releases
+#DEFAULT_PREFERENCE = "-1"
+
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11 libsm libpng fontconfig libxrender"
+DESCRIPTION = "Cairo graphics library"
+LICENSE = "MPL LGPL"
+
+PV = "1.3.2+git${SRCDATE}"
+
+SRC_URI = "git://git.cairographics.org/git/cairo;protocol=git \
+ "
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ sed -i s:PKGCONFIG_REQUIRED=0.19:PKGCONFIG_REQUIRED=0.15: configure.in
+}
+
+do_stage () {
+ autotools_stage_all
+}