aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/mpc8315e-rdb.conf4
-rw-r--r--packages/linux/linux-rt_2.6.24.bb66
-rw-r--r--packages/u-boot/u-boot_1.2.0.bb19
3 files changed, 80 insertions, 9 deletions
diff --git a/conf/machine/mpc8315e-rdb.conf b/conf/machine/mpc8315e-rdb.conf
index 3718ce5935..e0a1215bcf 100644
--- a/conf/machine/mpc8315e-rdb.conf
+++ b/conf/machine/mpc8315e-rdb.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the Freescale MPC8315E-RDB
# Development board with low power PowerPC SoC with MMU/FPU and PCI,
-# PCI Express, SATA onboard.
+# PCI Express x1, 2x SATA.
TARGET_ARCH = "powerpc"
PACKAGE_EXTRA_ARCHS = "ppce300c3"
@@ -14,7 +14,7 @@ MACHINE_FEATURES = "kernel26 usbhost pci ext2 uboot"
KERNEL_IMAGETYPE = "uImage"
-PREFERRED_VERSION_u-boot = "1.3.2"
+PREFERRED_VERSION_u-boot ?= "1.3.2"
UBOOT_MACHINE = "MPC8315ERDB_config"
UBOOT_ENTRYPOINT = "0"
UBOOT_LOADADDRESS = "0"
diff --git a/packages/linux/linux-rt_2.6.24.bb b/packages/linux/linux-rt_2.6.24.bb
index 83483bb0f5..8bda705166 100644
--- a/packages/linux/linux-rt_2.6.24.bb
+++ b/packages/linux/linux-rt_2.6.24.bb
@@ -3,24 +3,78 @@ require linux.inc
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
+DEFAULT_PREFERENCE_mpc8315e-rdb = "1"
-PR = "r4"
+PR = "r5"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.24.7.bz2;patch=1;p=1 \
- ${KERNELORG_MIRROR}/pub/linux/kernel/projects/rt/patch-2.6.24.7-rt11.bz2;patch=1;p=1 \
http://kamikaze.waninkoko.info/patches/2.6.24/kamikaze1/broken-out/squashfs-lzma-2.6.24.patch;patch=1 \
file://powerpc-clockres.patch;patch=1 \
- file://leds-cpu-activity.patch;patch=1 \
- file://leds-cpu-activity-powerpc.patch;patch=1 \
file://defconfig"
# file://sysctl_missing_include.patch;patch=1 \
S = "${WORKDIR}/linux-2.6.24"
-SRC_URI_append_mpc8313e-rdb = "\
+SRC_URI_append_mpc8313e-rdb = " \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.24.7.bz2;patch=1;p=1 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/projects/rt/patch-2.6.24.7-rt11.bz2;patch=1;p=1 \
+ file://leds-cpu-activity.patch;patch=1 \
+ file://leds-cpu-activity-powerpc.patch;patch=1 \
file://mpc8313e-rdb-leds.patch;patch=1"
# file://mpc831x-nand.patch;patch=1 \
# file://mpc8313e-rdb-rtc.patch;patch=1 "
+
+# override the device tree source file from linux.inc, as the patches below
+# introduce new variants. -- Leon Woestenberg
+KERNEL_DEVICETREE_mpc8315e-rdb = "arch/${ARCH}/boot/dts/mpc8315erdb_default.dts"
+
+# Patch series taken from MPC8315ERDB_20080627-ltib.iso, available as-is from
+# Freescale's web site. Patches also available at www.bitshrine.org, which I
+# use here. -- Leon Woestenberg
+
+SRC_URI_append_mpc8315e-rdb = " \
+${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.24.3.bz2;patch=1;p=1 \
+${KERNELORG_MIRROR}/pub/linux/kernel/projects/rt/older/patch-2.6.24.3-rt3.bz2;patch=1;p=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-platform-support.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-add-all-interrupts.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-Realtek-821x-phy.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-fix-gianfar.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-Gianfar-buffer-recycling.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-Gianfar-performance.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-sata-support.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-fsl-serdes-support.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-pcie-INTx-support.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-ipic-msi.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-usb-support.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-power-management.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-usb-power-mangement.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-NAND-flash.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-elbc-jffs2-on-nand.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-Codewarrior-kernel-debug.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-otg.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC831x-LFC.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-TDM.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-tdm-test-modules.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-spi-for-tdm-module.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-port-mutiplier-in-sata.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-performance-monitor.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-ieee-1588.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-DTS.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-sata-pm.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-fix-large-file-transfer.patch;patch=1 \
+http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-default-configuration.patch;patch=1 \
+"
+
+# Last 5 patches in the series, for crypto stuff. The 2nd of these is created
+# against crypto/ocf/ and thus needs a proper rebase against the base dir.
+# This remains a todo. -- Leon Woestenberg.
+#SRC_URI_append_mpc8315e-rdb = " \
+#http://www.bitshrine.org/gpp/ocf-linux-26-20071215.patch.gz;patch=1 \
+#http://www.bitshrine.org/gpp/ocf-linux-20071215-20080427.diff;patch=1 \
+#http://www.bitshrine.org/gpp/linux-fsl-2.6.24-OCF-fsl_soc-2.patch;patch=1 \
+#http://www.bitshrine.org/gpp/linux-2.6.24-Openswan-2.4.12.patch;patch=1 \
+#http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-openswan-sysctl.patch;patch=1 \
+#"
+
diff --git a/packages/u-boot/u-boot_1.2.0.bb b/packages/u-boot/u-boot_1.2.0.bb
index f1075bb00b..7c6aff8920 100644
--- a/packages/u-boot/u-boot_1.2.0.bb
+++ b/packages/u-boot/u-boot_1.2.0.bb
@@ -1,6 +1,6 @@
require u-boot.inc
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-1.2.0.tar.bz2 \
"
@@ -22,4 +22,21 @@ do_compile_prepend_lsppchd () {
cp ${WORKDIR}/defconfig_lsppchd ${S}/include/configs/linkstation.h
}
+SRC_URI_append_mpc8315e-rdb = " \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pre.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-soc.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-PHY.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-platform.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-controller.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-boot.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-serdes.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pcie.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-fsl-1.3.0-MPC83xx-CW.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-silicon-1.1-1.2.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-extra-config-for-333-266MHz.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-resume-deep-sleep.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-improve-ddr-performance.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-fix-PCI-IO-base.patch;patch=1 \
+"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
18'>118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142