aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/less/less_382.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/packages/less/less_382.bb b/packages/less/less_382.bb
index b489722edb..f336a59ad6 100644
--- a/packages/less/less_382.bb
+++ b/packages/less/less_382.bb
@@ -1,16 +1,22 @@
-SECTION = "console/utils"
-DEPENDS = "ncurses"
DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
based program for viewing text files and the output from other \
programs. Less offers many features beyond those that more does."
HOMEPAGE = "http://www.greenwoodsoftware.com/"
+SECTION = "console/utils"
LICENSE = "BSD"
+DEPENDS = "ncurses"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/less/less-${PV}.tar.gz \
- file://configure.patch;patch=1"
+ file://configure.patch;patch=1"
-inherit autotools
+inherit autotools update-alternatives
do_install () {
- oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+ oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+ mv ${D}${bindir}/less ${D}${bindir}/less.${PN}
}
+
+ALTERNATIVE_NAME = "less"
+ALTERNATIVE_PATH = "less.${PN}"
+ALTERNATIVE_PRIORITY = "100"