aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/kexecboot/initramfs-kexecboot-image.bb2
-rw-r--r--packages/kexecboot/initramfs-kexecboot_1.0.bb28
2 files changed, 1 insertions, 29 deletions
diff --git a/packages/kexecboot/initramfs-kexecboot-image.bb b/packages/kexecboot/initramfs-kexecboot-image.bb
index 3fd1088b7d..6c3a76bf78 100644
--- a/packages/kexecboot/initramfs-kexecboot-image.bb
+++ b/packages/kexecboot/initramfs-kexecboot-image.bb
@@ -6,5 +6,5 @@ inherit image
export IMAGE_BASENAME = "initramfs-kexecboot-image"
-IMAGE_INSTALL = "initramfs-kexecboot"
+IMAGE_INSTALL = "kexecboot"
IMAGE_LINGUAS = ""
diff --git a/packages/kexecboot/initramfs-kexecboot_1.0.bb b/packages/kexecboot/initramfs-kexecboot_1.0.bb
deleted file mode 100644
index a6450b0bfb..0000000000
--- a/packages/kexecboot/initramfs-kexecboot_1.0.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-DESCRIPTON = "A init script that mounts a device and kexecs a new kernel from it."
-PR = "r8"
-RDEPENDS = "kexecboot klibc-utils-static-mount klibc-utils-static-sh klibc-utils-static-sleep"
-
-FBANGLE = "270"
-FBANGLE_c7x0 = "0"
-INPUTDEV = "/dev/event0"
-
-
-do_compile() {
- cat > init.sh << EOF
-#!/bin/sh
-/bin/sleep 3
-/bin/mount -t proc proc /proc
-echo "0 4 1 7" > /proc/sys/kernel/printk
-/usr/bin/kexecboot -a ${FBANGLE} -i ${INPUTDEV}
-EOF
-}
-
-do_install() {
- install -m 0755 ${S}/init.sh ${D}/init
- install -d ${D}/proc
- install -d ${D}/mnt
-}
-
-PACKAGE_ARCH = "all"
-
-FILES_${PN} = "/init /proc /mnt"