aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/meta/external-toolchain-generic.bb4
-rw-r--r--recipes/meta/external-toolchain.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes/meta/external-toolchain-generic.bb b/recipes/meta/external-toolchain-generic.bb
index 73f823f192..c840301aac 100644
--- a/recipes/meta/external-toolchain-generic.bb
+++ b/recipes/meta/external-toolchain-generic.bb
@@ -22,8 +22,8 @@ PR = "r2"
inherit sdk
do_stage() {
- if [ ! -e ${prefix}/package-status ]; then
- echo "The external toolchain could not be found in ${prefix}!"
+ if [ ! -e ${prefix}/package-status -a ! -e ${prefix}/usr/lib/opkg/status ]; then
+ echo "The package status file of the external toolchain could not be found in ${prefix}!"
exit 1
fi
diff --git a/recipes/meta/external-toolchain.bb b/recipes/meta/external-toolchain.bb
index 4c70054b0f..352126396f 100644
--- a/recipes/meta/external-toolchain.bb
+++ b/recipes/meta/external-toolchain.bb
@@ -21,8 +21,8 @@ PR = "r2"
inherit sdk
do_stage() {
- if [ ! -e ${prefix}/package-status ]; then
- echo "The external toolchain could not be found in ${prefix}!"
+ if [ ! -e ${prefix}/package-status -a ! -e ${prefix}/usr/lib/opkg/status ]; then
+ echo "The package status file of the external toolchain could not be found in ${prefix}!"
exit 1
fi