aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/documentation.conf1
-rw-r--r--packages/fakeroot/fakeroot-native_1.2.13.bb8
2 files changed, 8 insertions, 1 deletions
diff --git a/conf/documentation.conf b/conf/documentation.conf
index 19aaf2dd48..93cf911d02 100644
--- a/conf/documentation.conf
+++ b/conf/documentation.conf
@@ -20,6 +20,7 @@ HOST_VENDOR[doc] = "The name of the vendor. Normally same as the TARGET_VENDOR @
HOST_SYS[doc] = "FIXME"
HOST_PREFIX[doc] = "Normally same as the TARGET_PREFIX @see TARGET_PREFIX @group base"
HOST_CC_ARCH[doc] = "Normally same as the TARGET_CC_ARCH @see TARGET_CC_ARCH @group base"
+HOST_NONSYSV[doc] = "Setable flag in local.conf to override SysV specific compiles when needed. 1 or 0 are usable values. See fakeroot-native for example."
TARGET_ARCH[doc] = "Build for which architecture. Examples are arm, i686, sh3, mips, powerpc"
TARGET_OS[doc] = "Build for which Operating System. Currently possible values are \
diff --git a/packages/fakeroot/fakeroot-native_1.2.13.bb b/packages/fakeroot/fakeroot-native_1.2.13.bb
index 4df6eeb5c5..cc3dfd2231 100644
--- a/packages/fakeroot/fakeroot-native_1.2.13.bb
+++ b/packages/fakeroot/fakeroot-native_1.2.13.bb
@@ -6,7 +6,13 @@ inherit native
SRC_URI += "file://fix-prefix.patch;patch=1"
S = "${WORKDIR}/fakeroot-${PV}"
-EXTRA_OECONF = "--program-prefix="
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
do_stage_append () {
oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/