aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--recipes/ezx/ezxd/ezxd.init5
-rw-r--r--recipes/ezx/ezxd_svn.bb4
3 files changed, 9 insertions, 2 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 7c0c5597ff..fe6a756619 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -56,7 +56,7 @@ SRCREV_pn-epiphany ?= "7837"
SRCREV_pn-essential-dialer ?= "194"
SRCREV_pn-ezx-boot-usb-native ?= "2512"
SRCREV_pn-ezx-gen-blob ?= "2426"
-SRCREV_pn-ezxd ?= "2074"
+SRCREV_pn-ezxd ?= "2513"
SRCREV_pn-fbgrab-viewer-native ?= "1943"
SRCREV_pn-flashrom ?= "3682"
SRCREV_pn-frameworkd-config-shr ?= "cdf5b5f3d8f37d6d91e1eb8d9cf07d034291df87"
diff --git a/recipes/ezx/ezxd/ezxd.init b/recipes/ezx/ezxd/ezxd.init
index a345952d1e..ba44942829 100644
--- a/recipes/ezx/ezxd/ezxd.init
+++ b/recipes/ezx/ezxd/ezxd.init
@@ -37,6 +37,11 @@ start_it_up()
fi
echo -n "Starting $DESC: "
+ modprobe ohci-hcd
+ sleep 2
+ modprobe moto-usb-ipc
+ modprobe ts27010mux
+
start-stop-daemon --start --background --quiet --pidfile $PIDFILE \
--exec $DAEMON -- --system $PARAMS
# We need to sleep here because opening the mux devices takes some time
diff --git a/recipes/ezx/ezxd_svn.bb b/recipes/ezx/ezxd_svn.bb
index 134980f4c0..19bbd93184 100644
--- a/recipes/ezx/ezxd_svn.bb
+++ b/recipes/ezx/ezxd_svn.bb
@@ -22,7 +22,9 @@ CFLAGS_append = " -DDEBUG "
TARGET_CC_ARCH += "${LDFLAGS}"
do_configure() {
- sed -i -e s:CROSS:CC:g Makefile
+ # Comment out both CC and CROSS definitions
+ sed -i -e 's:^CC.*$:#\0:g' Makefile
+ sed -i -e 's:^CROSS.*$:#\0:g' Makefile
}
fakeroot do_install() {